Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

BEACON

Sci-fi Action Roguelite. Collect DNA from enemies and mutate yourself to victory! · By monothetic

I can't seem to modify the settings, at least the video ones.

A topic by The Chakatrasj created Jun 08, 2020 Views: 383 Replies: 19
Viewing posts 1 to 9
(+1)

Maybe I'm just dumb, but clicking on them doesn't seem to do anything, nor do the arrow keys or any other thing one would use to modify settings.

Same here. Also the cursor doesn't seem to te respond properly to muse movement - occasionaly freezes in place or changes direction unpredictably.

Developer(+2)

We have heard a few people mentioning this now but have never run into it ourselves while testing so it might be a bit difficult to track down. Are either of you using Steam to launch the game or just the itch launcher? Steam's controller options might interfere with the input. 

We have a patch releasing this week that might fix the options not responding, and if it's still broken for you after that we'll try to make it a priority to fix for the next minor patch. 

I've launched it only from itch launcher. Hope it helps.

Hey, forgot to take it down, restarting the game fixed it as it somehow unlocked a bunch of new options and allowed me to mess around with the settings. It would appear that it happened on the 1st time I launched the game, launched it only once more. I will tell you on the discord if it bugs out again. Oh, and i was using the basic Itch launcher. Is it still possible to get steam keys ?

It seems the patch didn't fix this. I just installed the game (got it from the bundle) and most settings just don't respond.
Checkboxes work and sliders work, but any dropdowns just don't react (which includes most graphic settings).
Also most control settings are doubled, but maybe that's intentional to allow multiple binds?

Developer

Have you tried restarting the game after the first launch? That fixed the options for at least a few people. The control settings shouldn't be doubled either, if you can click on the Reset to Default button and it responds try that and it should fix it. 

I both restared the game (multiple times), played some then tried again and even reisntalled it once. Nothing helped.

Developer

Sorry about that, we'll try to get it fixed soon if we can figure out what's causing it. I'll let you know if we need any other info that could help us fix it. 

At start I have same problem (before update) and game start work normal (config) anfter 3 times played xD (before update)

ey, same problem there, first launch, can't change video setting (and few others), controls windows' empty... maybe a kind of loadin error ?

I had that same problem with the downloadable version, but then I installed Beacon in Itch launcher and all about the menus work fine. 

I've got a similar issue. Downloaded the game on itch launcher, I can rebind controls, tick or untick boxes, drag and slide bars but can't do anything on dropdown options (same issue as MIC132 encountered.

Developer

We've released patch 2.62 which replaces the Input System entirely! Hopefully this will fix the issue you were having, let us know if you are still having trouble. You can view the patch notes here. 

https://steamcommunity.com/games/856610/announcements/detail/2534912799763184998

While I'm yet to play more due to lack of time, the update at the very least seems to have fixed the problem with being unable to interact with dropdown settings. Thanks.

Issue still not fixed for me, neither 2.62 or 2.63 seemed to have fixed it :(

Developer

Here's a few things that might be able to help us figure out why it's not working:

  • What mouse and keyboard do you use?
  • Do you have a controller plugged in? 
  • Do you have any 3rd party controller drivers installed? 
  • Double check that the latest patch has installed, itch doesn't auto update unless you use the app. The patch number in the bottom left of the Main Menu should change when updated. 

Hi!

- I'm currently playing on a laptop, so the keyboard is the laptop one and I'm using a Steelseries Rival 310 as a mouse (Tried to play with another mouse, a logitech one and also another older Steelseries model mouse, both didn't gave any results,).
- I have no controller plugged in, I tried to change settings with an official Xbox 360 wireless controller, it didn't worked (I mean I could navigate and start a game, but couldn't change the options with the dropdown menus).
- No third party controller driver installer (I've actually never used one of these controllers)
- I've deleted the previous version of the game and reinstalled it, at every new release (so actually twice, since I got the game throught the bundle, I've downloaded the 2.61 version, then deleted it, got the 2.62 and deleted this one in order to install the 2.63 today, I had that issue on every version of the game mentionned above). I've always downloaded the game throught the itch.io launcher btw.

Developer

If you get a chance can you send us the log file generated after opening the game when the options is broken and trying to click on a dropdown? There might be an error there that could help us fix the issue. 

Here's where the log is located:

Local Disk (C:)/Users/(User)/AppData/LocalLow/Monothetic/Beacon/Player.log

Deleted 283 days ago

Seems that the issue is now fixed, looking forward to get my hands on that game :D