Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Evolvedustry

E-Dustry: Sandbox Adventure Tower Defense Game · By Evolvedustry

Report Bugs Here Sticky

A topic by Evolvedustry created Jun 04, 2020 Views: 638 Replies: 42
Viewing posts 1 to 23
Developer (1 edit)

Hey everyone, here is a bug report topic to post to. Any bugs here will be fixed immediately and ill notify you when its fixed. 

How the bug was produced or extra information is appreciated.

Developer

Found in 1.47, Perfect Laser Turrets all named with ruby prefix : Fixed in 1.48

(+1)

Umm... Sometimes my character doesn't respond when i click my mouse. Is there any reason for this?

Developer

I think I know what the problem is and I'll fix it in the next version. Basically, there is invisible UI that overlays certain parts of the screen and I forgot to disable ray casting on them. This means if you click on the region where this panel resides, then they will block user input. Thanks for letting me know and have a good day.

Developer (13 edits)

Current bugs in 1.48 that are being fixed and tsome fixes will appear in the 1.48.1 patch update.

  • Some user input clicks not registered. =Fixed=
  • Loading times for large worlds are extremely long.
  • Achievements only can be achieved once per game not per player.
  • Boss health bars stay on screen after if player dies during fight. =Fixed=
  • HDR screen flashing on some computers. (If someone experiences this, can you leave more information so I can pinpoint the exact cause)
  • If full inventory and trying to pick up items, the player gets pushed by those items.
  • Crafting UI can change as player is crafting and they run out of that material which can lead to crafting the wrong item
  • Crash/freeze in both 1.47/1.48 versions shown by a black screen on launch with sound and no user input. =Fixed=
  • Slimes spawn too excessively. =Fixed=

Need Feedback on Certain Bug

  • Runs around 90 fps on integrated graphics as start of game, but some computers have significantly low fps in intervals of around 0.2s per fps drop. I assume it's due to one of my shaders not being supported (lighting engine shader), but not entirely sure. If you are getting low fps, let me know with some details!
(+1)

It's probably just my game, but the game is flashing between white and black while the HDR option is enabled. And if I disable this option, it will always be black.

Developer

Is the game playable before you modify the HDR? I'll add it to the bugs list and also try to find a solution.

 Any extra information is appreciated.

(+1)

1.4.7 and 1.4.8 alpha causes my system to lock up and not render the game. Unable to tab out to the desktop and have had to do three force restarts throughout testing. I'm running on a Windows 8.1 x64 bit system with an older AMD videocard.

Developer (1 edit)

Weird, can you describe what you were doing when that happens? Was it when you were opening up a world or ... 

I want to fix this as soon as possible and I don't currently know what could cause it. I do know opening new worlds can cause freezes if the world is extremely large, but will bounce back after a minute or two. Quick question, did you explore a large part of the world / was exploring the world when the crashes happen? Also, I have another idea that it is ram related. In your task manager, have you seen the game use too much ram?

(1 edit) (+1)

Happens whenever I launch the game. 1.4.7 it starts windowed then expands, only giving audio. 1.4.8 goes straight to audio and a black screen. I haven't even been able to play yet.

Edit: I'm locked into a black screen whenever the game is launched, so I can't even check Task Manager. Hoping this is just a system issue.

Developer(+1)

I am trying to find the reason to why this is happening. I've had about 700 players play the new update with no other reported crashes, but I want to make sure this doesn't happen to anyone else. I'll research and browse for a cause for the crashes while seeing if I can find a solution to mitigate this in the future if it is system related. I'm sorry for the inconvenience and I will be working fixing this ASAP.

(+1)

Please and thanks. Will there be a discord or subreddit in the future? I'd be able to shoot you a dxdiag file if so.

Developer(+1)

Yes, I just got a subreddit and a discord up around 30 minutes ago, but I am still configuring some settings on them. Something I am working on in the new version is a bug reporter built into the game where it would save everything I need to know into a text file on crash and that can be sent to me so I can diagnose problems faster. Thanks again and here is the subreddit "r/IndustrialEvolution".

(+1)

Experiencing the same thing, tried both the alpha and the other download. Big oof.

Developer (2 edits) (+1)

It happened to you too?  Do you have any extra information to add? So when you launch the game, it shows a black screen, sound plays, and prevents you from leaving/tabing out?  Do you have a graphics card and is it old or is your monitor aspect 16:9? Sorry for asking so many questions as I want to solve this before more experience this problem. 

Edit: I think I found the cause and I'll get the new version out in the next day or so. I think its because of a conflict with supported resolutions when the game enters full screen mode, thus I'll release a version that is windowed instead to test if this is the case.

Thanks for your time.

Developer

I think I have a fix and the patch will be released in a couple days to test if it is fixed. Thanks again.

(+1)

I never played the game before this day but when I launch the game and start playing it's all black except near some lava pools. it also flashes with color somethimes. is this intentionally?

Developer

No, it's not intentional. It sounds like a driver compatibility issue with a shader.  When it is night, the lava pools emit light, but I assume it was like this even when it was day? The flashing of color is definitely  not suppose to happen. I will see if I can come up with a solution and more details is appreciated.

Thanks for the heads up!

if it's a compatibility issue then il send some information of my pc.

graphics: NVIDIA GeForce GT 705

cpu: Intel Core i7 4790S @ 3.20GHz

if there is any other thing you need to know about my pc ask me.

(+1)

cant open wooden chest at some point, restarting client fixed it.
multiple wooden chests would glitch and have duplicate items of each other.

Developer

Interesting, I'll look into it. 

Thanks!

(1 edit) (+1)

sorry i couldn't be more specific, the unopen-able chest bug was totally random, even tried to build a new chest and both wouldn't open.
as for the multiple wooden chest duplicate item, it was that new chest i built that had the same items as the first chest.

Developer

Thanks for the extra information.

(+1)

exp collectors loses collected exp when exiting, save&exit doesn't preserve it either.

Developer

Yeah, I never implemented a save for experience siphons in the prototype version. The next version that is coming out is way more polished as I didn't leave anything out and has way more stuff like 10 dimensions, 20 biomes, +2000 items, etc... It will be the first non-prototype release. 1.47 & 1.48 was to see if people liked the game style. 

Thanks for reporting bugs as it makes it way easier to fix them.

(1 edit) (+2)

Wooden Barrels only has 25 capacity instead of 50.


(2 edits) (+1)

Sorter-to-Sorter backflow* crash.
*sorter is set to something and outputs directly to a sorter thats been set to pass it back.
*have not tested with sorter-to-router but possibly would crash as well.

logs:

StackOverflowException: The requested operation caused a stack overflow.

 at (wrapper managed-to-native) UnityEngine.GameObject.GetComponentFastPath(UnityEngine.GameObject,System.Type,intptr)

at UnityEngine.GameObject.GetComponent[T] () [0x00021] in <eea339da6b5e4d4bb255bfef95601890>:0

at SorterControllerScript.canInputItem (UnityEngine.GameObject tempObject_, UnityEngine.GameObject tower) [0x00079] in <d1331d07dd094728a770cb0d9331efdc>:0

at SorterControllerScript.canInputItem (UnityEngine.GameObject tempObject_, UnityEngine.GameObject tower) [0x0009f] in <d1331d07dd094728a770cb0d9331efdc>:0

at SorterControllerScript.canInputItem (UnityEngine.GameObject tempObject_, UnityEngine.GameObject tower) [0x0009f] in <d1331d07dd094728a770cb0d9331efdc>:0

(1 edit) (+1)

router chokes input throughput when one or more of the output is full.


(1 edit) (+1)

conveyer and buildings (smelter/furnace/compactor/etc.) loses all the items in them upon exiting game.

Developer (1 edit)

Fixed the barrel problem in the upcoming update. 

Fixed the stack overflow error (Can't believe I didn't find this one myself in testing).

Fixed saving in upcoming update as I implemented a new saving algorithm that saves literally everything in the game. I originally didn't save conveyors and building in the prototyping version as it was extremely slow if there was a lot of conveyors. 

The router is trying to output to the barrel but can't because it is full, then swaps to another tower to output to but that has a delay. I will remove the delay in the next version.

Thanks for all the help as I really appreciate it!

(+1)

coal oven will continuously consume coal even if the output is already full.

persistent flickering graphical glitch, the glitch is still there even after restarting client.
the glitch is possibly related to sorters.


Developer

Ok, I'll fix it in the next update.

Are the item images flashing there and then disappearing? If so, I fixed the bug in the next update.

Thanks!

(+1)

yes the images would flash in and out, i noticed the image reflects what the sorters have in them so i thought it was related to sorters.
i only have leaves, branches and coal going through sorters and coincidentally the flickering image also shows those.

Here’s some bugs or just 1 idk:

  1. When it has a mission/task to build something and you just press the block without even building it it somehow counts as doing it.

  2. When your interacting with the ui it somehow counts as attacking/punching/interact

  3. Strange lag spikes.

Overall experience: Great game! :)

Developer(+1)

Thanks for letting me know! 

I am glad you liked the game.

I'd love to know how to rotate objects on a laptop, how do?

Why i play this game and inf night

I can't open the game because some kind of an error appears. Can anyone help me solve it? 

current alpha version if you are holding a tool, (axe, pickaxe etc.) and you die, it will swing way faster until you switch to different item (it will be rapid hit, not accelerating)

for some reason, my skill tree is stuck, i cant zoom out

Not sure if it's zoomable, you can drag it around by holding the middle mouse button (I had to connect a mouse).

1. Most graphics options while playing don't seem to change, only HDR seems to make a difference. Although some seemed to work the first time I started the game. The same happens with the sound. The slider moves but the number remains at 100.

2. The ballista and turret have their names/descriptions interchanged (I think I saw this mentioned elsewhere).

3. The rarity of all items show Unique, even the common ones.

4. When trying to manually place a single filter item for the filtered router, the item remains "floating" above the structure. If one clicks on another item, the one clicked is lost, and the hovering item disappears. If one tries to place the same item with a stack, the item is placed but the amount doesn't decrease. After taking out the filter item, the stack returns to the original amount in the beginning. A workaround I found is to configure it semi-automatically by sending items through a barrel.

5. The player sometimes can't grab an item that's too close and gets pushed by it.

6. The game starts lagging after a while, I thought it was the world size (which might be a factor) but the game returned to normal after shutting down and starting it over. Intel Core i7-3630QM CPU @ 2.40GHz, Intel HD Graphics 4000.

7. Some weapons (even your hand) can damage your own structures, not sure if it's intentional but the magic ones don't.

8. This may be a feature request if not a bug. The items inside a barrel are lost if the container is destroyed.

9. This is subtle, probably hard to pinpoint, but a group of iron ores (6 extractors with one conveyor belt) were entering the furnace slowly and forming a line, as a bottleneck. I thought it was normal till it sped up after removing an adjacent copper barrel (I'm pretty sure it wasn't connected to the system).

10. Not sure if it's a bug but there were a lot of hearts in the snowy biome. Maybe they just spawned over the course of a longer playtime, since it was my first world.

11. Sinterred is typed with "rr" in the skill tree, while items have it as "sintered". The charcoal production facility is the only one that mentions charcoal instead of coal.

(1 edit)

anyone know why my game crashes when i try opening the server? I'm on a low-end PC and explored a LOT to find desert hearts.

mabye unload chunks to fix this issue? i dont know lmao