Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Possible fix for Mac OSX 10.15 Catalina...

A topic by stam created 77 days ago Views: 269 Replies: 14
Viewing posts 1 to 6
(1 edit)

Hello there,

as its mentioned again here, the latest mac osx upgrade broke the simulator.

On an other mac though, I had an older (not very old, but not the last one) version of the simulator and its working great on 10.15. I copied on my main mac (that stopped working after the upgrade and its working great there too!

The thing is I don't know which version/build of the game I have and it is working so somehow we can have a temporary fix for everybody who upgraded their mac to the last version... I tried the info tab but I can't see the version...

FYI none of those methods https://itch.io/t/587567/does-it-run-on-mac-os-1015 worked for me, just the old version that I had on my other mac :)

I hope we can find a way to help everybody that they broke their favourite fpv simulator!!!

stam



Developer

Thank you for the information, it's interesting that you got it working with an older version. Do you have any idea how old it may be - for example, does it have the round "Racetrack Generator" icon on the main menu?

In the recent releases the zip file is named with the build date in the filename (for example "FPVFreerider_MacOS_2019-11-23.zip" for the latest release). So if you still have the zip file for the working version you might find the date there (unless it's a really old version where the date is not in the filename). Also, sometimes it seems to work if you unzip the zip file on a Windows computer and transfer it to your Mac via a USB drive for example, but perhaps you have already tried that.

(1 edit)

Hello there,

No it doesn't have the racetrack generator icon. Unfortunately I don't have the zip file so we can see the release date :(

From the first time I had the problem with the unzip so I always extract it in ubuntu and then copy it to my mac.

Does it help if I go to Applications and press Show Package Contents for FPV Freerider app? 

Maybe some config files I can see there to find the version?

I think somewhere you must put a version number in the simulator for future reference... :)

I attached a screenshot of the info screen maybe it helps you... Maybe the copyright that it says 2015-2017 but it's must newer than that...

Thanks for replying, I think is a major issue the last mac upgrade that crashed our favorite simulator... :(



EDIT: 

I also attached a picture from Custom Settings maybe that helps to recognise the version...



Developer (1 edit)

Thank you for the screenshots. Since it doesn't have the Racetrack Generator, rates not in degrees/second and no expo/superexpo curve adjustment  I'm pretty sure it's actually from 2017. So it's a really old version which lacks a lot of stuff... Still, it's a strange that that one works and not the latest (although it is a lot older I think it's built with the same version of the Unity engine (used for development) as the latest one).

I suspect that the problem is that Apple has tightened the security measures in the latest version of MacOS, which makes it harder to run independently developed apps.

Not sure how to solve that, most people seem to still be able to get it running by using one of the methods mentioned in the user manual or in the other Mac thread. But it would be nice to be able to find a simple universal solution that just makes it work without requiring any special hacking skills.

id didnt really know, were to contact you, so i just Contact you here. PLEASE put individual expo and rates for yaw, roll and pitch. This would be really great, cause im a racer, and have kinda complex rates. I would also like it much, if you would include a feature, were you could change the tracks, wich are in the start menu. I would than change a racetrack with the "forest" eich i do not use. Thanks

Developer (1 edit)

 I realize some people have very specialized needs when it comes to rate/curve settings.

 I want to avoid feature creep and cluttering of the interface as much as possible though. I'm not saying it will never be available, but at the moment it's not likely to be there anytime soon.

My suggestion to those who have special rate/curve adjustment needs is to use a linear curve setting in Freerider, and adjust the curve exactly to your liking for each channel in the menu of the transmitter itself.

In FPV Freerider Recharged you have the full level editor so that you can create your own tracks. It is not possible to change the built in levels in the desktop version of Recharged (the forest, factory, carpark etc.) though because they use a completely different level creation method.

ok

Ok, any chance to have access to the first version with the racetrack so at least I can try it and see if it works?

All the other methods you posted unfortunately don't work on Catalina for me ☹️☹️

Developer

Sure, send me an email at fpvfreerider@gmail.com, I think I will be able to find an old version for you to try.

Thank you very much, I already contacted you via mail. 😄

Developer

Update: It seems like after you have done the chmod thingy you might need to go to your Mac menu System Preferences>Security & Privacy

If it says something like "Freerider was blocked from use because it is not from an identified developer" you need to select "Open Anyway".

See this video for more info: youtube.com/watch?v=GvFqKVIsHO4

Everything works now to my mac!

It was either installing the latest Catalina update (10.15.1 I think) or deleting all old versions (demo & full) of FPV Freerider and then just installing the latest one that made the trick!

Thank you very much 😄😄

Developer

Glad you got it working!

Hello, 

I just download the app but I can't open it on my MAC. 

I'm on Catalina 10.15.3.

I tried in my terminal : Open FPVFreerider.app but I got this error 

LSOpenURLsWithRole() failed with error -10810 for the file

After a little investigation, it seems that the app use an old API for authorization.

Is this ring a bell to someone ? 

Thanks in advance for your help :)


Developer (1 edit)

Hello, 

Did you try the suggestions mentioned in the install instructions and the user manual?

(Especially the chmod method  seem to work for a lot of people).

1. If you unzip the file on a Windows machine and transfer the file to your mac with a USB stick it should
work.
2. Better solution for anybody else who has this problem. MacOS is picky about which programs can be run
(the first time) by double-clicking. To run a program that says "this can't be opened", right-click the icon and
choose "Open". You'll be given an option to open the program, and from then on it won't bug you.
3. For Mac's having trouble installing FPV Freerider try going to the Mac's System Preferences>Security and
Privacy> General Tab and check the box "Anywhere" to see if this allows your Mac to install FPV Freerider.
4. For anybody who is still having the issue of the simulator not opening you need to open up terminal and
type sudo chmode +x (fpvfreerider.app) and that should do it.
It should look something like:
chmod +x "/Applications/FPVFreerider.app/Contents/MacOS/FPVFreerider"
or
~ chmod +x /Applications/FPVFreerider_Recharged.app/Contents/MacOS/FPVFreerider_Recharged
(adding sudo at the start if needed).
After that you might need to go to your Mac menu System Preferences>Security & Privacy
If it says something like "Freerider was blocked from use because it is not from an identified developer" you
need to select "Open Anyway".


There are also some tips in this thread.

Good luck, I hope you manage to get it running!