Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Does it run on mac OS 10.15?

A topic by Atsupon created 25 days ago Views: 237 Replies: 10
Viewing posts 1 to 7

Can we play FpvFreeRider series on Mac OS 10.15?

If I updated mac OS  yesterday, the software didn’t run after that.  I want to know if it is my mac problem or OS matching problem.

(1 edit)

Same problem. On Mac 10.15 I get a window that says:

The application “FPVFreerider” can’t be opened.

Thank you for giving your comment.
I hope that next update will be come soon to be adapt mac OS 10.15 or later.

How about this?

1. Extract zip file with third-party archiver (like "keka").

2. Allow "Input Monitoring".

Excellent advice for me!

I have been able to open the app by your indicated procedure. Thank you very much.

This worked for me.  Had to download the zip with Chrome since Safari automatically unzips.  But using a third-party archiver (Keka) worked for me.  Thanks for the suggestion!

Developer (7 edits)

Thanks for sharing you r solution tak_asn!

I remember hearing of a similar issue before. In case tak_asn's solution isn't working for someone, you might try to set the permissions for the FPVFreerider app using a chmod +x command. Since I don't own a Mac myself I'm not very knowledgeable in these matters, but here is more info on this: https://superuser.com/questions/1345755/how-to-fix-the-application-cant-be-opened-on-mac

Basically:

Open a terminal window (CMD + Space -> terminal);
Using the cd command, navigate to the place where the application is stored: cd <path_to_application>
Run chmod +x <application_file> to make it executable. If it doesn't let you, sudo it:
sudo chmod +x <application>

(Your command should look something like this: 
chmod +x "/Applications/FPVFreerider.app/Contents/MacOS/FPVFreerider"
adding sudo at the start if needed).


Edit:

or:
sudo chmod +x ~/Applications/FPVFreerider.app

or, for Freerider Recharged:

~ chmod +x /Applications/FPVFreerider_Recharged.app/Contents/MacOS/FPVFreerider_Recharged

I also found this info:
As recent versions of MacOS doesn't have run everywhere option in GUI, you either have to disable Gatekeeper compeletely (sudo spctl --master-disable) or selectively enable given application: sudo spctl --add /Path/To/Application.app

(1 edit)

I can't get the demo nor the Recharged demo to work on 10.15 with any of the tricks above.

Can any confirm if the paid versions will work?

Developer

The paid version use the exact same input system as the demo, so if you can't get the input to work in the demo it will be the same in the full version.

It is not just the input. The demo app doesn't start up at all.
With chmod +x I can pass the "can’t be opened" notification. I also tried the spctl, but it won't start. The icon just bunch but the app doesn't come up. I had no problem before 10.15.

Developer (1 edit)

Oh, sorry, my guess is Apple decided to implement some new permissions/security stuff that wasn't there before. Or, perhaps it is trying to start the 32-bit version of Freerider (Freerider still includes both 32- and 64-bit executables for Mac). I tried searching  for answer but I didn't find anything definitive, seems like a pretty common problems that some apps doesn't start after updating to Catalina though... 

(Still, if the demo doesn't run the full version most likely won't either).