Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Luna Engine MV

A script that modifies RPG Maker MV UI easily · By Archeia

How to Line-up Actor's Faces Horizontally In Battle? Locked

A topic by ZeroBeat032 created Aug 16, 2019 Views: 297 Replies: 7
This topic was locked by Archeia Nov 19, 2019
Viewing posts 1 to 5

I've been at this for probably way longer than I should've... I've got the worst feeling there's something extremely simple that I just missed. but basically. I was trying to just line my actor's faces up at the bottom of the screen... as opposed to where they are in this image. I've figured out how to move them... but unfortunately I can't get them to go across horizontally. I've tried adding horizontal true commands... it get's rid of the other actor's face but lines them up, at least if I add horizontal true and limit 1. I've tried adding another column to the battle status... that makes the game flip out with a stack too deep error. I'm unfortunately at my wit's end here. I was basically trying to move them horizontally to the bottom of the screen next to the actor command bar. then I was going to figure out how to use bigger actor faces to make it look like a XP style battle... I figured if I could get them moved at least, I could figure out all the other stuff from there.


To make the menu horizontal, change the following command in the BattleStatus window:

    columns: -insert max number of actors here-

So for example, if you wanted a row of 5 actors laid out horizontally, you would change it to this:

    columns: 5


To move the position of the block of battle statuses, change the x and y settings of the BattleStatus window: 

  BattleStatus:
    type: Window
    x:
      type: fixed
      value: -horizontal-
    y:
      type: fixed
      value: -vertical-

If you're still confused on what to do, feel free to screenshot the config for the window and I'll annotate it for you.

as I read this I JUST realized what was going on that was stopping that from working. I'd tried that a ton of times and an stack too deep error of some sort would pop up, so I figured that wasn't how you did it. BUT that was because of another plugin... oddly enough one of the plugins that came with the Luna Engine. the DisableAsync plugin was causing this. I hadn't thought to turn it off tho because of it helping load pictures faster that were in subfolders... which the pics in the battle hud were in. I knew how to move them tho, I just had the issue of them stacking on top of each other because I couldn't setup the columns. I wonder why the stack error... Thanks a ton, I'm closer to setting everything up now!

That seems really odd. As far as I know disable async hasn't caused that error for anyone else.

Can you post the console error and your config for the window? If it's a bug, we'll squish it. owo b

Developer (1 edit)

Stack error usually happens if there's duplicates of the plugin or functions. You probably have two versions of it or you have another preloader that interferes with it or added a script that or disables asynch.

(1 edit)

That makes a lot of sense actually. I'm not sure why I didn't think of that eariler. I'll check through my plugins and see what might be the cause of that.

EDIT: here's the error that pops tho... I actually figured out it's connected to the hp/mp gauges I have setup in battle. tho I guess I found that odd as they're setup the exact same as the ones in the Base 00 Example project outside of sizing, text, and position. I didn't touch anything else related to them.


Developer

Maybe you accidentally have two duplicate components in your yaml files or something?

(1 edit)

That could be the case. I've noticed some differences in the files between the two times I downloaded the plugin. I'll check and see tho as soon as I can to see if I copied something twice or anything of that sort.

EDIT: I haven't found anything... but the oddest thing is, these issues went away when I started using images for the gauges (which was my plan from the get go) so that works out I suppose? Otherwise, I've gotten everything setup as I was intending. tho I wanted to say and I'm only saying it here because I had a topic open already, that Yanfly's Steal&Snatch causes issues in battle with the item window. It took ages to narrow down why it was the only one I couldn't move, when I was trying to move the rest for my XP setup, but yeah it causes the Item window (and just the item window) to stay in it's default place. and when you select an item, it erases the your hud. I only wanted to mention it NOT as to try to get any fix, but as a heads up that that even happens. 

Developer locked this topic