Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Wild Woods

Go on an expedition, cooperate with up to four friends and fight your way through the woods · By WildWoods, TheBuergermeister, nadjacl, _Jar, Ruhken

Bugs Sticky

A topic by _Jar created Jul 14, 2019 Views: 557 Replies: 29
Viewing posts 1 to 11
Developer (1 edit) (+1)

If you can find any kind of bugs, we would appreciate if you could share them with us :)

(-1)

Sometimes defeated enemies won't disappear, but instead, they'll just stand still and seem intact at where they're supposed to fall.

Developer

Thank you for pointing this out.  Fortunately that's a bug we already know and we also know how to fix it :) 

(in-depth stuff: it's because the enemies get a point to walk if the sun rises, but our world build algorithm is destroying the path to this particular point, so they hang around and shaking their bodies :P )

When you die, in the follow-up menu that pops up, where you have the two options, you can't navigate with keyboard. Could you please check into that?

Developer

Yeah for sure. Thank you for pointing that out!

Died a few times to check if that is consistent, and it isn't. I'll try to figure out what exactly I'm doing that triggers it.

Hey I had an issue downloading the game to play. I'm running windows 8.1. I tried to download the setup.exe and install it directly but my antivirus kept picking it up. I disabled my antivirus and tried again, this time the installation began but halfway through it just closed and also the setup.exe disappeared from my desktop, really weird, I've never seen that happen with anything. I downloaded it again and tried again, the same thing happened.
Ultimately I downloaded the Itch.io windows app and was able to install your game through that, it ran with no problems after that :).

Developer

Thats really weird. Think the next patch will remove the setup.exe because of bugs with the itch.io launcher so you just have to unzip and go :)

wether im using keyboard and mouse or controller i cant get past the select screen

Developer

Which OS do you have?

Thats sounds really weird, because you are the first with these issue 

(1 edit)

I am using InputMapper for Windows10 to be able to play with my PS4 controller. However, when I press X(A) on my controller in the player selection screen the game would register a second player for me, both being controlled with the same controller

Developer

Currently we are not able to test or configure this because we don't have ps4 controllers. A friend of mine has also a ps4 controller and could play the game without problems. Maybe you can change some InputMapper settings?

After some testing I figured out it only happens when I connect the controller after opening the game. So it's kinda my fault. But, it's still technically a bug.

If you pause the game, you will get sent back to the main menu after about 5 minutes. It happened twice.

Developer

Thats  intended, because its our gamescom version and we forgot to disable it for itch ... sorry for that we will fix this soon. Im currently on vacation.

(1 edit)

when on the character selection menu, when I press A two players appear. I'm using a Xbox controller with no extra software downloaded. I'm using Windows 10

Developer

Thank you for reporting this.

We will recreate the menu logic completly anyway ;) 

We were on gamescom the last 6 days and nothing like that happened. Did you tried  to reconnect your controller or use another usb hub?

We tried with and without USB hub and  and also tried to switch around with the controllers and usb ports. Nothing helped.

Developer

Do you have the latest version of wild woods?

when Iposted this coment, it was the latest version that we were playin

I am unable to open the game at all on PC.

It just keep showing that the game crash. My specs are as follows:

Manufacturer - CyperPowerPC

Operating System - Windows 10 Pro

CASE - CyberPowerPC COUGAR PANZER Mid-Tower High Airflow Gaming Case w/ USB 3.0 & Tempered Glass Window & 3 RED LED FAN

Processor - AMD Ryzen 7 3700X 3.6GHz [4.4GHz Turbo] 8 Cores/ 16 Threads 36MB Cache 65W Processor

CS_FAN - 4X 120mm Thermaltake Riing 12 Series High Static Pressure 120mm Case/Radiator Fan (Blue Color LED)

Fan - Cooler Master Hyper 212 CPU Cooler w/ PWM fan - Efficient Cooling Performance

Graphics Card - GeForce RTX 2060™ 6GB GDDR6 (Turing) [VR Ready] (Single Card)

Motherboard - MSI MPG X570 GAMING PRO CARBON WIFI ATX W/WIFI 6

Memory - 32GB (16GBx2) ADATA XPG Z1 DDR4/3000MHz Dual Channel Memory

Solid State Drive - 240GB WD Green SSD

Hard Drive - 2TB SATA III Hard Drive

POWERSUPPLY - 800 Watts - Standard 80 Plus Gold Certified Power Supply

Monitors - Insignia 29 inch, HP 20 inch

Webcam - Logitech C920 - HD Pro Webcam

Headset - Gaming HeadSet

Mouse - Razer Naga Trinity Gaming Mouse: 16,000 DPI Optical Sensor - Chroma RGB Lighting - Interchangeable Side Plate w/ 2, 7, 12 Button Configurations

Keyboard - CyberPowerPC RGB 7 Color Premium Gaming Keyboard

Controller - XBOX One Wired After Glow (RGB)

Any Help would be appreciated as I wanted to make a gameplay video for my YouTube Channel.

Developer

Did you unzipped the folder completely?

Yes, I did but figured out that I needed to roll back my drivers in order to get the game to work. 

Developer

wow weird. Thank you for trying:)

The mac version of this game has its launch file (in folder /wildwoods/Contents/MacOS)  that file is marked as a text file instead of a executable so mac gives an error that the game cannot be opened. This can be fixed by the command [chmod +x]. If you can find out why this is the case I would love to know as I have seen it in three other games on itchio so far.

Developer

Thank you for pointing this out. I'll look into this. Currently we just press "Build for MAC" in Unity :) So looks like Unity has some problems with that.

If someone had problems with the mac version we always pasted this link to help (because unfortunately no one of us has a mac)
https://howtomacos.com/2019/02/24/fix-the-application-cant-be-opened-on-mac/

(2 edits)

Hi, I actually came across this issue several times and decided to look into it. The problem seems to be with the .Zip compression format stripping metadata on unix systems. Tar was built as a complete archive with unix support in mind so it has better support for MacOS. I sent another dev this and after they bundled it as a .APP.TAR their game was fixed so I can confirm it works at least one case. If that does not work I also found this on unity bundling in particular. https://answers.unity.com/questions/28677/how-to-call-chmod-x-from-a-unity-mac-applications.html

If you want them all bundled as a zip this should be the fix if you can only access windows OS (although it might be easier with linux)  https://stackoverflow.com/questions/434641/how-do-i-set-permissions-attributes-on-a-file-in-a-zip-file-using-pythons-zip

What I sent to the other dev {

This issue in particular is one I have seen only some people have a problem with.  I downloaded several games from Itch io that didn't have this issue which made me suspect there was a workaround.  I spent some  time researching and it seems this is actually an issue with .zip compression. Im not a developer so I cant help too much but here is what I found. https://stackoverflow.com/questions/107903/how-to-create-a-zip-file-in-the-same-format-as-the-finders-compress-menu-item

the other solution I heard is to use .TAR https://github.com/golang/go/issues/24057

the comments on this thread are quite informative

It seems that macs default zip compression does not properly store metadata so you need to use the [ditto] command

I also found this although you probably already read it https://itch.io/docs/itch/integrating/compatibility-policy.html

I hope that helped some :)}

Developer

This is awesome, thank you for your time and effort. I'll try this later today. Are you on our discord server, could send you a test build there.

Having a similar issue to the one reported a year ago...

Windows 10 machine, 2 Xbox-compatible controllers (Logitech Dual Action).

Player 1 joins (Top-left).  Top-left appears correctly, but so does the bottom-right character.  Same thing happens when Player 2 joins first. 

Player 2 joins, and we also get Top-right.

Once both players ready up, either player can hit A again to also ready up the extra character.  When the game starts, BOTH controllers ALSO control the third character, which I'm guessing is the keyboard/mouse player (Even when no one is using that).

Developer

Think the problem here is, that maybe your controllers imitating the keyboard and therefore you have some odd configurations. I personally had the same issue with my steam controller, i had to change the settings in the config panel of the steam controller menu. Don't know if you have something like that for Logitech.

The logic how players join and get there colors will change in the future, maybe the system is much more solid after that but unfortunately that is not something for the near future. :(