🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Just can't install this damn thing

A topic by fort447 created 304 days ago Views: 195 Replies: 7
Viewing posts 1 to 5

Had to format my hard drive. Trying to reinstall Aven Colony. It just refuses to install. Now it won't even unzip. What a load crap,

Admin (Edited 1 time)

Got any more details so we can help you through this? What error messages are you seeing? Are you using https://itch.io/app or not? How come you had to format your disk?

(Edited 2 times)

OMG, I tried both the app, and installing it by hand. As for error messages it saying I needed "Microsoft Visual C++ 2015" which it installed but refused to recognize it's own work. I checked and it's installed. So where it stands is I have Microsoft Visual C++ 2015, Aven Colony insist I don't, and refuses to run. The "app" supposedly "installed" the game, but it's the same story, it can't find Microsoft Visual C++ 2015. Not much I can do if the software can't deal with reality.

Why did I format my disk? Answer: Microsoft Windows operating system, needs to be nuked on a regular basis.


Hmm, its looking like this may not be something thats isolated to Aven Colony, but appears to be an issue with Microsoft VC++ 2015 that effects many other games as well. There's a thread here on Steam you can check out that seems to offer a few suggestions and solutions, one being that you may not have the required system updates to be able to properly install MSVC++ 2015 redistributable.

(Edited 1 time)

Yeah, looks like they are having the same problem. Even the part about windows update not updating. Looked like most of them just got a refund, and never solved it. My updates are 1 for "silverlight", 1 for MSE (which is just an ad for Windows 10), 2 for my sound card, and 1 for displaying multiple windows. The last one is only one that has anything remotely involved with the situation. I'll try downloading it and installing it manually. Thanks for your reponse.

Ok, their is no updating Windows it just does the same thing as the regular update program. When I try to install it just endlessly "searches" for updates, which what I was supposed to have downloaded with the file I ran. So their is no updating.

http://i44.photobucket.com/albums/f42/gt447ny/Never%20ending_zpscgekt79a.jpg

What version of windows are you running? If windows update is causing issues, its may still be possible to download an available service pack with the required updates and manually install them.

(Edited 4 times)

That's a big part of the problem, I did download the update and manually install it. That is the picture I posted of the manual install, just spinning it's wheels forever "searching for updates on this computer". What? I thought that was the update. What it does is put some zipped files on my C drive. I guess those are the ones it's looking for. How stupid is that, puts files on my computer then can't find them. At this point my computer is not able to update period. End of story. The game will never work, the computer will never update. That's just the way it is. I googled it and this is a known problem. The "Fix" makes your computer unable to boot. So my choice is, 1) Keep the status quo and never update, or 2) turn my computer into a brick. Which one do think I will pick.

Update: I took the chance and installed the fix, which took over 12 hrs to install (read that you should just leave your computer on and let it run for however long it takes to install). After that I was able to install 98 updates to Windows 7, so i am a happy camper now. Thanks Sysop-Delco for trying to help, it meant a lot while i was going though all this.