🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Game Uploaded fine in butler but no game is available to buy

A topic by SDMG-STUDIO created 250 days ago Views: 243 Replies: 13
Viewing posts 1 to 14

Hi thank you for Butler,

great time saver, in the future for me though,

because i uploaded my zip game like in the youtube video help, but

once on my page editor there is still no game to sell, so no price too.

in itch.app , i can see "my creations" with "Not availbale on Windows" filter

i sent my zip with ":windows-stable" tag, i tried ":win" too, but nothing works.

Another question: is "butler wipe" command deleting the zip on itch.io site in my creations folder ?

thank you for your time

regards

Admin

Hey there,

It looks like the build failed to process — I wasn't sure why, so I looked into it: I downloaded the patch and tried to apply it myself, it seems to work fine. I'll be upgrading butler's backend today and trying your build again, so you have nothing to do — I'll reply here once your build has been correctly processed!

As for the wipe command, it acts on your local disk only, not on itch.io.

(Edited 2 times)

thanks a lot for your answer, i will wait so.

Hello there !

a bit time passed and i am still stuck with my unpublished game !

it seems i can't add a channel properly with my upload i put ":win32" or ":win" at the end of my game name in the command line

even if the upload seems good, the butler status always give me "no such channel found..."

what am i doing wrong ?

thank you for your time

Do you still see the upoad in your "edit game" page?

For me, I can see the files I uploaded from butler there and see the channel name on the green button

It could also have to do with the status of the game page. When it was in draft (and restricted I think), I couldn't retrieve the game version with the https://itch.io/api/1/x/wharf/latest... line

Hi and thank you for answering

Not at all, i can't see the uploaded files (which have to be somewhere because i attempted to upload my game so much times !)

the game is 523Mo ~ and the direct upload on edit page is impossible due to the 500Mo restriction so i uploaded it via butler.

My game status is restricted for now and was draft at start.

Perhaps i'll give a try to publish a non-downloadable game ! what a f...

On second thought, I don't think the status has anything to do with it. you should just see the files pop up in your edit page.

Sounds more like it has to do with the size. maybe try uploading just a few files to see if that actually works.

could be that there's still an upload limit on butler:(

I think the 500Mo limit is the problem too,
i will try a smaller folder size and see
even if the support team assure me the size would not be a problem.
Amos said he have a look at my files but still no news...
Thanks for your time though

No problem, good luck

So i tried a less heavy upload: 480Mo
and still no chance to see the game published, i am starting thinking that i am loosing my time
with the butler and itch things.
So pitty to see indie devs not very encouraged.
I think i am done.

(Edited 2 times)

That doesn't sound good.

It may not be ideal, but have you tried uploading this version the regular way at the "edit game" page?

nope, will try, good idea.

I need to read the post from Amos too, concerning big uploads.

Admin

Hey SDMG-STUDIO!

18 days later... I finally upgraded our backend, and kicked your most recent (1 day old) build into processing, and it worked!

Your page now shows the download. So sorry for the delay!

Thank you Amos for the fix and your time !
Great to see butler evolving.


Yes my game is uploaded now but
i can not install it: i got a "spawn butler returned code 1"
error then install stops.
Hope it is not too hard to resolve
Any clue ?