Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

I can't download any games. please help

A topic by Tony created Aug 30, 2016 Views: 2,924 Replies: 23
Viewing posts 1 to 18

whenever i try to download a game it says "UploadServer at commondatastorage.googleapis responded with HTTP 400 Bad request" i tried to install 2 games and i kept getting that message.


Hey, sorry for the trouble. Are you trying to download from the website or from the app? Is it possible to tell us which game you're trying to download and where in the world you're located. If it's private information feel free to email us at

i tried downloading them from the app. i tried to download Breach and Clean and Urban Horror. im in Canada.

Same problem with me... I tried to download pages over the last few days, I always get a 403 Forbidden error from, and I don't get any links to an 'alternative' download URL like I used to. (Google downloads don't work for French users, I'm guessing.)

Please fix :(

Yoddles, getting a Dl Error for Aven Colony, commondatastorage, and a whole lot of other code that's tl,tr or type, redone the proxy and still get an error, I love new apps there, so inviting.


Are any of you using a download manager or a proxy server? Please try without and see if that fixes anything. Our download URLs expire after a few seconds to prevent them from being shared. It's possible you're using something that is interfering with that. A screenshot of the error you're seeing when you try to download from the website would be helpful for us to debug the issue as well.

Nope, no proxy or download manager... Just Opera (Chromium-based).

I see no errors for some pages because I get a popup saying the download will start soon. (But the console indicates a 403 error from the download link.)

On pages where the game is downloaded directly through clicking the download link, I get a clear 403 error page. Reloading the page (or the link itself) doesn't work.

nope still nothin, sent. Png even Dl the game of Mother site installed in Itch game folder, tryed to make an Cmd string to say here it's here but Itch says or wont see the Dl game in folder. yeah I've run out of stamina and now my brian hurts,


Holy cow, I retried my file (the one I've been trying to get for days), and today it's working!

Woohoo! Was it a fix on's side or Google's..?

itch io 22.2.0 I dont know what these means or how to fix it, maybe it's an australian not allowed zone, seems there cutting of a few sites...


at RequestError (C:\Users\...........\AppData\Local\itch\app-22.2.0\resources\app.asar\appsrc\util\net.ts:24:5)

at ClientRequest.req.on (C:\Users\...........\AppData\Local\itch\app-22.2.0\resources\app.asar\appsrc\util\net.ts:118:14)

at emitOne (events.js:96:13)

at ClientRequest.emit (events.js:188:7)

at URLRequest._emitRequestEvent (C:\Users\............\AppData\Local\itch\app-22.2.0\resources\electron.asar\browser\api\net.js:89:29)

either way useless app.. Im done

(1 edit) (+1)

I'm also facing the same problem :/

It starts downloading then become 0 Byte/sec and stops (in Chrome it says Network error)

I have pass the same problem of SpeedRider, I don't know what to do...

Any idea why this happends?


Hello, we had a separate more recent issue with our CDN that should be resolved now. Tell me if you're still having any issues.

Any fixes? I'm having the same problem on the browser, can't download any games. Chrome, no proxys or download managers, no idea what's happening.


Please check the dates before replying, you replied to a post that was over 1 year old. The issue from this topic has long been fixed. Thanks

They haven't. When I click the download button, nothing happens, there's a reason I'm looking for help.

Admin (1 edit)

This topic is about a completely unrelated issue from 1 year ago. I'm sorry you're personally having an issue getting a game to download. I see you've already created a new topic for your problem so please keep discussion there. Thanks

(1 edit)

I'm trying to download Loot Rascals, and it's just not working. The download starts, then stalls and craps out. This is both through the site (using Firefox, no download manager or proxy), and using the app.

I've tried downloading other games, and get the same result.

I have successfully downloaded games from Itch on this system before, both directly from the site and through the app.

When I use the app I get the following error message, after about 20 to 30 seconds:

(1 edit)

no not really I don't think your got google inserted into your what ever it is .........................error:dot::ERR_PROXY_CONNECTION_FAILED at requestError ( users\...........) so fourth, yeah, REALLY NOT INTERESTED IN YOUR APP ANYMORE<< ill just DL the update files from the server every new update and DL 5.5 gigs everytime like its only 3 hours, and yes this is the latest

I have the same error with Proxy Connection. Any clue how to solve this error?

the proxy is not working

I have allways error ..........You've configured this page to show a html game but you haven't uploaded the appropriate file!

i upload my game test from unity i switch platform to webgl and upload three files with winrar

when i play the index file allone open with firefox it work please help !!!!!!!!!!

When I try to open games this comes up 



There are too many unknowns that could be causing this message so I can't really tell you what the problem is. It most likely is related to how your computer is configured though. If you're having trouble downloading and running games from your browser then I recommend using our app:

Admin moved this topic to Questions, Ideas & Feedback