Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Tailor Tales

Romance hot guys and create your own clothes. · By Celianna

Bug reports v. 2.0.0 Sticky

A topic by Celianna created Jan 06, 2019 Views: 750 Replies: 26
Viewing posts 1 to 9
Developer (2 edits)

For version 2.0.0, Windows only, please post your errors and other general glitches here.

Letting me know the steps you took leading up to the error is crucial! If you can replicate the bug/error, even better! I will try my best to fix it :)

Mac users, I'm sorry, Mac is not officially supported, I cannot fix any bugs for this OS.

Edit: at the moment, red eyes do not work in CGs. Please select a different eyecolour while I patch it. Please go to Settings > Profile > CG Colours, and set your CG colours again, the missing image has been patched! Make sure you've installed Tailor Tales through the Ich app, otherwise you will not receive the update.

Neil route, just after chapter 20, at the home page, when I click the "Outfit" button, I get "Loading Error - Failed to load: img/pictures/Fashion/Completed/CLTH_00008.png". There is a "Retry" button, but it results in no change. All other buttons work as expected.

I looked around a bit, found the folder in question (Tailor Tales\www\img\pictures\Fashion\Completed) with similarly named files of clothing I'd created, figured that the error file was an article of clothing I'd deleted, copied a different file and renamed the copy "CLTH_00008", and that resolved the issue. It looks like the delete function works in the short term, but the outfit function is still trying to load deleted files. But on the upside, there's a relatively easy workaround.

Developer

Thank you for mentioning it. I tried to replicate it and it seems it's caused by you wearing the clothing item in question, then deleting it. It was never removed from your avatar, so when you exited Outfit, you were still technically wearing it, but the image related to that clothing item was successfully deleted. The game then tried to load the image, but obviously couldn't find it.

I'll try and patch it :)

I don't think I was wearing that object of clothing at the time. It was a shirt that clipped pretty badly with my default skirt so I never exited the outfit function with it on, that's why I deleted it. Not trying to be difficult, just trying to give relevant info.

Developer

Then what most likely happened is that you simply did not save your progress when you deleted the item after exiting Outfit. It's easy to replicate.

Unfortunately I do not yet have a patch for it, as my programmer is unavailable at this moment. Luckily it's a very specific bug that people don't easily come across upon :)

I'm playing the game normally, and when a CG scene appeared, the heroine is see-through and this showed up for both Neil and Dimitri route. 

Example: Loading Error

                    Failed to load: imp/pictures/CG/Neil/CG_neil_02_s_0.png.

And when I press retry, it still won't load.

Developer

Hey there, the second skintone wasn't coded properly into the game. Please make sure you have your game updated (a standalone version doesn't update, you must install through the Itch app to receive updates).

Once updated, go to Settings > Profile > CG Colours, and simply reset your skintone there and click finished. This should fix it!

Alright, thank you

I'm playing Dimitris route and my game froze on starting a new chapter, the one where you have to wear the wedding dress I think. I restarted my computer and when I try to load either manual or quick save I get TypeError Cannot read property 'name' of null. It happened on the last version I downloaded too, but on a few chapters ahead. 

Developer

Really sorry to hear that, I will try and investigate what's causing it, as it seems like something got corrupt, I'm just unsure what.

Can you confirm when you say "last version I downloaded to" to mean the version from 2017, version 1.4? So it happened in that one as well?

Thank you for your help :)

Oh no, that version worked perfectly. I meant the version from when you first added Dimitris complete route, before the bug patching that fixed things like the red eyes and skin tone in cgs.

Developer

When you got the error for the first time, did your game also crash, causing the error? Either way, if you join the Discord, I can be of much better assistance.

No, the game was working fine. I saved and turned off for the night. The next day when I went to play it wouldn't let me load. It was around the chapter you unlock the 5th CG in.

I just made an account, I didn't post anything there yet but my username is the same.

Developer

Please click this link to join my Discord, I cannot chat with you otherwise :p

I'm starting to believe that when I pushed out an update to fix some bugs, it may have corrupted your save file somehow.

In Neil's route, I think I found a typo. But I'm not sure. Anyway, here it is.

"But one thing Is clear; I want Neil."

Not sure if that "Is" is supposed to be captalised. 

Developer

Thanks for catching it!

In  Caine's route, I think there's a missing speech mark at the beginning.  Here it is:

True, it's a little sad since I've enjoyed my experience so far." I'm going to miss college.

Developer

Thanks! Seems I didn't include it in this update.

I keep getting "TypeError, Cannot read property 'name' of null" everytime I try to load my save data? I stopped playing right after the chapter where protag kept looking through Dimitri's photo album. I've tried switching to different versions and reinstalling through itch's app but it won't let me play anymore :(

Developer (1 edit)

Bad news first; your save file got corrupted and it's wiped, hence why it cannot be loaded. I'm really sorry. I'm working on a back-up save data for your save files, so that this won't happen anymore.

Did you crash during your last save? That's the only thing people have had in common; their PC/game crashed at some point.

If you join the Discord I may be able to assist you further, I'd like to get your save file.

Ah I see :( It hasn't crashed anytime before while saving up til now, unless I closed it while it was saving (which is very unlikely). I'll check out the Discord to see if anything might be able to be done though!

I'm not sure if this is a bug per se, but when I finished the "kind" routes for Neil and Dimitri, I can't switch to the "passionate" routes. Here's what just happened with Dimitri:

1. Finished Dimitri kind route.

2. Accept to be taken back to chapter 25 to play passionate route.

3. Chapter 25 is the passionate route.

4. Chapter 26 goes back to the kind route.

I would expect the behavior to be that once you've indicated you'd like to be taken back to chapter 25 to try the passionate route, chapter 25 and all remaining chapters would be the passionate route.

Something similar happened with Neil in that it just replayed the kind route again for chapters 25+ after my first playthrough, but then I still got the achievements for the passionate route.

Is it because I built up so many kind points on my first playthrough that it's triggering the kind chapters again on my second chapter 25+ playthroughs?

Thanks for your help!

Developer (1 edit)

It was an error on my part, but it should have been fixed.

That is, provided you updated the game on the 16th. If you've installed the game through the Itch app, you should have automatically received the updates. If you have a standalone version, you will not receive any updates, and therefor are stuck with this small error.

You can still get his other endings if you personally go to Settings > Character > Story > select chapter 25 and click  start new route.

Thanks, Celianna! I have the Steam version. I'll install itch.io instead so I can get updates. 

Developer

Well if you had the Steam version, you should have been up to date regardless. That's very odd.

I'll push out a new update to make sure the fix was included then.

Hey, it says that Dimitri's route has been completed, but after Chapter 22 it says there are no more chapters available, how do I fix this?

Developer

I'm guessing you're a Patreon supporter and you're playing the early access? If so, you need to enter the latest password for the Patreon game, which you can find on the Patreon itself.