Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Cookie Cutter MZ - Farming System

A project template for RPG Maker MZ. Copy and paste it into your own project to utilize a custom evented farming system! · By Caz

Locked in " use " position with tools

A topic by CreatureCola created Mar 02, 2024 Views: 95 Replies: 7
Viewing posts 1 to 4
(4 edits)

So i just bought and installed everything for the wave1 bundle, reserved all the switches and variables and all that, but i've run into a bit of a problem and i don't know what the issue is. I tested in the demo and the files in my own game and it seems to only affect my game. When i select the hoe, i A, can't use it, and B, get stuck in a sideways pose and no matter which direction i run i'm stuck in the animation for hoeing, standing sideways ready to use the tool and not able to run. I have the visustella plugin pack ( movement core, engine core, battle core, message core, options core, ect. )  with wsad movements setup. I did send you a friend request on Discord as you suggested on youtube i message you there ( i had to send a request in order to send a message because it doesn't allow me to message you there otherwise and i don't have twitter- Hi this is StarlightBettaGamer btw lol ) but you've probably been busy which is fine. 

Edit: I realized i forgot to move over the animation for Reid with the hoe, and that SORTOF fixed it, it changes the character to ried as soon as you try to use an item like the hoe, and it stays reid lol so i can move around now, ( even tho it changes to reid- i'll obviously be animating the MC with the tools separately to fix this problem ) but also it still doesn't actually hoe the ground, and the hoe animation only shows the how on the ground not the swinging motion? i've obviously missed something somewhere but i thought i got it all xD
do you by chance have the blank base template for the items so i can make my MC clearly? 

I was also wondering if there was a way to easily hide the tools menu when not in use? its a blank box at the start, but as soon as you start cycling through tools you're stuck showing your selected tool all the time and i'd like to have a button hide and bring it back up if possible?? if not, that's fine, i was just wondering if it was possible to do. Do you know of a plugin that allows for MZ to use other keys besides the defaults for " if button is pressed " statements? i'd prefer to not use Q souly for the item selection. arrow keys appear to be locked as a secondary movement option so i can't use the up arrow unless you know of a way to adjust that i'm kind of new lol IF it was possible, i'd prefer to keep wasd keys for movement, and up arrow to bring up tools, down to hide the tools, and left/right arrows to cycle through tools but i'm not sure that's possible or easily achieved for a noob like myself. being dyslexic makes it a huge chore to try and sift through text through the plugins ;3;



Edit: I would also like to add, that in the download map that comes with the bundle, the book that opens the relationship manager for some reason changes the time to 12am when the book is closed, it doesn't just do this on my game it does it on the one i got in the bundle too

Developer

Are you importing this into an existing project? Make sure you're not already using variables that need to be reserved for the farming system, and make sure you're setting the region for farm tiles to 97.

You can change the appearance of the UI by adjusting Common Event 117: Tools UI. You can hide it by using erase picture after waiting a period of for the tool buttons to stop being pressed, or something similar for how you want it to appear.

I'm not at my computer right now but you should be able to find a list on the RPG Maker Web forums for script calls for button inputs, or there are plugins that let you use the full keyboard I believe.

(1 edit)

Ok so i tinkered around with it and i managed to fix the farming system to work on my map, Now i just need to see if there's a way to play with the movement settings so my character turns before they start walking when pressing the arrow keys, its hella annoying trying to hoe the ground when you have to keep backtracking to previous spaces every time you try to move forwards because you walk over the space you want to hoe instead of just facing it xD
 and i'm still having the same problems with the relationship manager not functioning properly, and its got an issue that happens on the demo map so i have no idea what's wrong still, i can't really compare the two files because the main one has the issue lol

Edit: If it helps, i used the " time is flowing " switch and turned it off and on ( like how its set in other events of yours ) and that also set the time to midnight when it turned back on.  

It is an existing project, but i've barely done anything in it, mostly just making maps. i wanted to wait to do much of anything involving variables and what not to make sure i didn't use up any since i knew i wanted to get some plugins, and as i said the issue with the time changing to midnight after closing the relationship manager is in the map that came with the plugin bundle, which also copied over to my game lol I'm pretty positive i've already gone through and checked to make sure the variables weren't already being used. i might just make a new file, copy your stuff first THEN the few things i have to make sure there's no crossovers, though i'm pretty sure there are none. being dyslexic makes it difficult for me to go back and forth between existing things and see all the info correctly so might just be easier to start over in a coherent way. wish RPG maker allowed you to " save as " an make a new file from an existing one instead of having to make an entirely new one from scratch every time haha

and its no problem, i don't mind waiting a while if need be, you've got your own stuff to deal with

I also wanted to add, that with the relationship manager, i'm not quite sure how to make it work properly, because i'm not sure what's wrong. i've double checked and every single variable, switch and common event are copied correctly, when i click an arrow key to scroll the list, it jumps to 2 or 3 instead of just 1 at a time, and there's a lag between movements, sometimes it does nothing, and its bugging out, my game keeps freezing if i do it too much. i actually had to task manger force shut down on it because it wouldn't close.
i imagine its something to do with another plugin, but the only ones i have that aren't visustella ( which affects the screen resolution ), is a zoom one, that allows me to adjust how zoomed in my screen is ( because its set to 1920 x 1080 and the character is TINY and too much of the map is visible. ) i have the show pictures plugin, which you also have so that's not the issue, and the " Galv's Layer Graphics MZ " for parallaxing. I tried disabling the 'zoom' and 'Galv's Layer Graphics MZ' plugins, and the issue didn't resolve. so its probably something to do with the screen resolution. the relationship manager window stays small, and is over to the left side with the res at 1920 x 1080, as it should, i'm going to have to recenter it if i figure out what's going on with the tabs. P:
The scrolling between characters in the manager works fine on your map, its only on mine where its doing that. 

I've had the same issue. As troubleshooting process, I started a freshly downloaded project (checked and it worked fine) and only updated VisuMZ_0_CoreEngine and VisuMZ_1_EventsMoveCore to their latest versions (1.81 and 1.50 respectively) and tilling the ground doesn't work. 

Animation plays as normal, it's just that events stopped spawning right after updating the plugins.

Developer

I'm going to look into updating all the base projects shortly with the updated versions of the VS plugins. :>

(1 edit)

Figured out what was wrong in my case. Had some free time after work and decided to tinker a bit in my project.

Turned out after updating, I forgot to set up the Event Template Settings of the necessary events. Code was working as intended, I was the one who derped.. lol

For anyone reading this comment and has the same issue, go to [Plugin Manager -> VisuMZ_1_EventsMoveCore -> Event Template Settings -> Event Template List]. Updating the plugin deletes this setting. In Event Template List , just adding new entries with all needed events does the job.

Anyways, can confirm that even after updating Visustella's plugins, project works as intended :)