Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Demo worked well, latest version sucks

A topic by silbaer created May 07, 2018 Views: 519 Replies: 12
Viewing posts 1 to 4

Hi!

I tried the linux demo and it worked well for me so I purchased the FPV Freerider recharged. But the performance is very bad: 0,3-0,5 FPS or less. I read the other FPS thread. I think I am glad with a little bit less physics accuracy but very much better framerate. Changing the resolution does not help.

silbaer

Developer

Since you experience that bad framerate it seems like there is something else wrong besides the performance hit from the extra physics accuracy.

Could you try to monitor the CPU and GPU usage to see if there is any unusual behavior there when running the sim?

Unfortunately I can not monitor the gpu usage (GeForce 9600GT).

This is the CPU usage when I start the desert demo. The spike at ~48 seconds indicates the click in the selection screen and I flew straight foward, around the rock and back to startplace. I don't know the framerate, but it work very well.



Here I tride the same in the latest version. The framerate was poor (lower than 1 FPS) and the stick input was also laggy.


Looks for me there is no GPU rendering but only software CPU rendering...

CU,

silbaer

Developer

I've been trying to think of what might be the cause but I have no clue, except for the added physics accuracy in the latest version. If it was only rendering by CPU you would certainly see a difference when running at really low resolution. You can try that to see if you notice a difference, like, running it in a window at 640x360 resolution or something like that.

-screen-fullscreen 0 -screen-width 640 -screen-height 360

Still, it's weird that it runs lower than 1 fps...Even the added physics accuracy shouldn't make such a difference.

hI start a game in a 640x350 px windows, but still 1-2 FPS max. Here is the CPU graph:

It is posible to get a full version with the code base of the demo? Not only to test if the glitch is perhaps in the scene data, but to have a working full version for me.

Developer

Have you tried running it at the lowest graphics quality? I'm asking since on the lowest quality setting there is no VSync enabled, perhaps that can make a difference in case it is a screen refresh sync issue.

Sorry there are so many changes made to the latest version that it would be too much work to go back to the old codebase.

If there is no way you can get it working email me at fpvfreerider@gmail.com and I will arrange for a refund.

I have tried lowest quality, small screen resolutions but nothing works. I'll email you.

But I wonder you mention too much work to get en old code base. Do you not using a version control system like git? I code by my self and the first thing I do when I start a project is to set up a (local) git repository...

Developer

Perhaps memeber lrs can help you (see message below). I don't use git, I do have an own system of keeping track of old code, but since I increased the physics simulation accuracy I made a lot of changes and it's not so easy to just change it back since the physics frequency affects a lot of things and it needs to be tested very thoroughly to not introduce any sync issues.

Please provide complete information about your System:

Linux distribution, Kernel Version, CPU, Motherboard, RAM, GPU, hard drive, System encryption? Spectre/meltdown patches?

Do you play other games on this computer?

I am using Linux and I experienced similar problems. I don't think that the coding style from FPV_Freerider (alone) causes these problems.

Not quiet the same but I also have problems on linux. I bought both versions. Freerider runs fine but in the Recharged I have no control. Everything is the same (I mean opsystem (Ubuntu, controller (Taranis X9D, settings). 

uname -a
Linux marci-LIFEBOOK-E752 4.15.0-42-generic #45-Ubuntu SMP Thu Nov 15 19:32:57 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

What should I provide to get some help? Thank you!

Developer

What problem do you have exactly, does it have to do with low framerate or with the stick input itself? Please get back with more info and I might be able to help.

Hi, thanks for the reply. It is a little bit strange because it happened only on the customs levels. I can’t connect the problem to anything. But one more thing most of the times (6 out of 10) when I try to load a custom level the app exits. 

Developer

Have you ever been able to run the custom levels?

Have you tried the level editor itself, does that seem to work?