Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Ribs

granular sound design tool for Win and OS · By hvoya audio

A little note on the Mac version

A topic by Jeroen P. Broks created Mar 13, 2018 Views: 1,914 Replies: 9
Viewing posts 1 to 4
(+1)

I could not open the application, until I found out the binary file Ribs.app/Contents/MacOS/Ribs didn't have the 'x' attribute that Unix based systems require here, so with a simple 'chmod' command I could 'fix' that, but I'm noting it here, as not all Mac users are aware of such things ;)

Developer

Thanks for pointing this out!

Hello, I still haven't been able to use ribs. There seems to be a code problem with the Mac version. Perhaps it has to do with the "chmode" that Broks has pointed out in her post? Would appreciate some help! 

Thank you, R.

any luck installing the app? 

hello, can you please explain how to install RIBS on Mac? thanks!

tried chmod but didn't work - see screenshots attached- 

(1 edit)

You do not need to +x the application bundle itself. You need to go inside the application bundle.

sudo chmod +x "/Applications/Ribs.app/Contents/MacOS/Ribs"

With that command it should work. Ribs.app is only a folder, the file I referred to in the command above is the actual "Unix executable file" and that file needs the x attribute in order to be recognized by Unix (and thus by MacOS) as an executable file.

This worked for me! I executed the command without the quotation marks and then allowed an app from an unidentified developer.  Thank you!

I'm on a OSX 10.15.7 macbookpro and I can't get it to work. i can "ls -la" the directory and see that both the .app and .vst are executable. 

When I put the .vst into the VST folder and try to run Ableton Live 9, it hangs upon booting with the infinite beachball...



I see I misread your original instruction of 

sudo chmod +x "/Applications/Ribs.app/Contents/MacOS/Ribs"

But I went back and applied that to both the .app and .vst. Now the .app "opens" and I see an icon in the bar but no window pops up. And the  .vst still gives my ableton infinite beachball mode...