Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Seeds of Resilience

Build your village and survive against the storms · By Stormland

Bug Reports Sticky

A topic by Stormland created Mar 08, 2018 Views: 543 Replies: 41
Viewing posts 1 to 18
Developer

Hey everyone,

Please post any bugs you find in here. 

To help expedite the process of solving your issues, i'll need you to let me know: 

  1. What version of the game you are running. 
  2. Description of any issue or error message
  3. An image (if possible)
  4. Steps to reproduce the issue (if possible)
  5. System specs.

Thank you !

(2 edits)

Long awaited !

We managed to download the game but the game is unavailable on windows on itch.io app. Maybe a configuration setting is missing ?

We'll play with it and send you a feedback list !

Developer

Thank you Morphiks Studio ! I'll dig into this tomorrow. I have not tried the app yet.

Developer(+1)

Problem solved ! Thank you for the report :)

(5 edits)

there probably one or two issues,

After a save and reload, previous game,

Day six. I had houses built on incline so storm should not have whalloped it, my goodness was I wrong maybe it should been mud or stone house to begin with. ,<-even though you can't

Anyhow house was gone and there no material to recycle which disturbed me. People or avatars never appear in game which kind baffle me are they avatars or something? 

But after day seven your kind have bug the game get weird after that. I am not sure if game has issue just that after storm one point if you don't save you end up having slow down and then you can't click on anything. I was lucky used window mode for while. But after using progressing with saving each time it kind stopped that for bit until I had revert having taskmaster on taskbar as just in case.

There no issue just some strange issue with game just stopped and stopped responding in itself.  Not sure what caused this...

sound and music still plays just after new villager appears seems only happen when you place a building down after there no building down. Seems occur all the time when I have my game I wait to gather resources and then when its time I realize the characters don't have enough power, to the task, is there way we turn away new villagers or I don't that just seems crazy...is there a way send villagers to auto task them to do things while your doing one task? because I got grey turned meaning they can't move and can't turn there is no way to hit key that make them to continue on...no save no load nothing.   

I think grey meant the characters died or you just giving me no hint what heck happened there...it happened again...even with no building before hand...I also loss of resources like food went down real quick the renewable rate what is renewable rate on food does anyone know is there a way to regrow certain foods?   I guess now itch.io client works jeez...but before I had use download version and that kind of sucked. 

I guess was offline variety? I have to stop typing before I get real complainer soon [he] he despises the typing even though his tantrum is all about imitation typing sound. 


You could hint to gamers who try play your game to use the itch client remind them turn off or white-list their firewall on the game app it might help playing both itch.io client and game program?  Got stop adding adding too much salt I seem too much of cuckoo.

Developer

Thank you for the bug reports, we'll investigate. Some of the things you point at are just feature we still have to implement. I know the game is in a quite  unfinished state and lacks important features, we'll do our best to fix that in the next months (yes, it takes quite some time). Next update is coming on 03/28 with bugfixes and a few improvements. Thank you for your understanding and your patience. 

(2 edits)

In the assign colonist screen, the colonists vanished from one of my huts. I haven't been able to reproduce it unfortunately. I'd send you a save file, but I don't know where they are. Edit:  It is possible to move additional colonists into the hut. They will all get the rest benefit.

I've got a corrupted save file. Most of the assets on the island have vanished, and I can't interact with the screen besides entering the main menu. This issue can be reproduced very reliably by clicking the "save" button multiple times.

Edit: Version 0.8.1, Win 10 64 bit

(2 edits)

Day 68 twice now has bugged on me to where when I load it looks like lennZ's lower pic. Also after I placed the best house the pink slots to place the people to live there didn't show up. I tried to tear down the middle best house to see if I could force the people to live in it. It didn't work. Have to start over day 1 to get the game working. I know it's beta and buggy as heck. Short of not being able to finish a game yet due to bugs (it kinda stinks). Anther thing that has happened a couple times is after the storm stops the sound and wind gust continue day after day. I do love the idea of the game and I see a great potential for the future of this game.

Developer(+1)

Thanks to both of you for the bugs reports, I have logged them in my todolist and will be working on it this week. I know there still are several really annoying bugs, there are really tricky to handle, I'll do my best so they are no longer present in the next update. 

ver. 8.0.2

Can no longer assign people to houses.  Dragging villager from scroll (assign tab) no longer shows the pinkish house frame.

Recreate by trying to assign a villager normaly.

Win 10 running on Bootcamp

(1 edit)

Ver. 0.8.2 #2

Held object sticks to game window.

When trying to take a screenshot of the previous bug, I found this one.


While holding an object (in this case a character frame from the assign scroll) use (Win+tab) or other shortcut keys that put the game window in the background. When returning to the game, press the left mouse button and the object attaches to the cursor location.

running in win10 from Bootcamp

(4 edits)

Ver. 0.8.2 #3

Key bindings

Screen movement key bindings on right  are arrow keys <- correct,  but for the left keyboard side its not W,A,S,D.    it's Q,S,D,Z.

Win10 running on Bootcamp

(1 edit)

Ver. 0.8.2 #4

Error When loading

Happens when loading from main menu and from in session. Error is "not" fatal.


Win10 Running on Bootcamp

Developer

Thank you very much Xam1d for all the reports.  I've corrected some problems, I'm pushing a build right now.

- Dragging people in houses should be possible again (pink squares were out of the screen)

- For the sticky objects when you do Win+Tab, press the T key to remove them (I'll fix it later)

- The left keys were Z-Q-S-D as I use a French keyboad. I've change it to W-A-S-D. I have to add in-game key binding options very soon!

- I'll dig into the loading error tomorrow

Awsome responce time. I'm verry interested in this game so I'll probably be testing alot.

Developer

Awesome! If you prefer we also have a discord server: https://discord.gg/stormland

Figured out there is the option to change keybindings in the launcher :)

(1 edit)

I've noticed that once I updated to the 0.8.2c version and restarted a game that the tornado spawns but doesn't move and then upon saving and reloading the game gets an error about loading all the fish(they disappear). Running windows 7 Ultimate, will try to reproduce.

Ah if you save while the Tornado starts or is rolling through the  land it'll bug it out when you reload the save file.

Developer

I'll try to reproduce it as well!

(1 edit)

I've noticed that not all the items have descirptions but show coded labels <?MapEntitySpeltYoung?>. I've noticed it on young versions of plants and some minerals. 


Also had a solid lockup of the UI creating strapping. Error message requiring more materials but created anyways. No materials list was shown on strapping



V0.8.2d Windows 10

Developer(+1)

Thanks for the reports!
The strapping should not be visible yet, I'll remove it for now

(1 edit)

0.8.3a Windows 7

When i click on any of the tabs(Farm, Craft etc) they just dissapear, nothing happens. And then some more, the cancel key does not work(tried changing it). Unplayable version i guess. 

Developer

Hi, sorry for the delay. Other players don't seem to have this problem, and I can't reproduce it myself either. Could you please send me the log file ?

It should be located here (replace USERNAME by your username):

C:\Users\USERNAME\AppData\LocalLow\Subtle Games\Seeds of Resilience\output_log.txt

(4 edits)

Here it is. Don't know how to upload txt directly so... i took ss.


(1 edit)

Im having the same problem since updating.

The assets for the moving portion of the scroll seem to go up, off screen rather than down like it was before the update. pressing a number key brings back the options but repeating produces the same results.

Running on Win 10 Bootcamp.

Developer (1 edit)

Thanks Oacc, next time you can simply copy-paste the text file content in your post.

It might be related to your resolution, which are you using ? (Xam1d if you can tell me your resolution too, it might help me to reproduce the bug)

Developer

Hey guys, I've found a quick fix (it worked for 2 people, I hope it will work for you as well). I probably have found the cause of the bug as well, but before I correct it you can try the following :

- Launch the game

- Open the Options window (press escape then click options)

- Press Back

It should work, even if you exit and restart the game. Tell me if it doesn't.

Getting the same issue, just bought the game and was booting it for the first time so not a run over from previous versions. I updated my GPU drivers after the issue first came up just to make sure Nvidia hadn't introduced something odd, as I saw the above poster was Nvidia too.

Tried the fix the you suggested with the options menu then clicking back but no luck. As some additional info is does appear like it scrolls upwards, if you (once the bar is hiding) click the number keys it won't display again until you hit two of the same number back to back (I assume this would usually minimise the bar again). Issue also found in both itch.io manual download and steam installed download.

Log file:

Initialize engine version: 2017.1.1f1 (5d30cf096e79)
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: NVIDIA GeForce GTX 970 (ID=0x13c2)
    Vendor:   NVIDIA
    VRAM:     4043 MB
    Driver:   24.21.13.9836
Begin MonoManager ReloadAssembly
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\Assembly-UnityScript.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.UI.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.UI.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.Networking.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.Timeline.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.Timeline.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.Analytics.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\UnityEngine.Analytics.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween43.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween43.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween46.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween46.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween50.dll (this message is harmless)
Loading C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\DOTween50.dll into Unity Child Domain
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\System.dll (this message is harmless)
Platform assembly: C:\Users\JJ\Downloads\stormland-windows\Seeds of Resilience_Data\Managed\System.Core.dll (this message is harmless)
- Completed reload, in  0.017 seconds
<RI> Initializing input.

<RI> Input initialized.

<RI> Initialized touch support.

The referenced script on this Behaviour (Game Object 'Housed Villager Bubble') is missing!
 
(Filename:  Line: 1759)

UnloadTime: 2.012922 ms
NullReferenceException: Object reference not set to an instance of an object
  at Stormland.UI.InteractionBlocker.OnEnable () [0x00000] in <filename unknown>:0 UnityEngine.GameObject:SetActive(Boolean)
FadingUI:FadeIn()
Stormland.UI.InteractionBlocker:RequireBlocker(UseInteractionBlocker)
Stormland.UI.UseInteractionBlocker:OnEnable()
UnityEngine.GameObject:SetActive(Boolean)
FadingUI:FadeIn()
UnityEngine.Events.InvokableCall:Invoke(Object[])
UnityEngine.Events.InvokableCallList:Invoke(Object[])
UnityEngine.Events.UnityEventBase:Invoke(Object[])
UnityEngine.Events.UnityEvent:Invoke()
UnityEngine.UI.Button:Press()
UnityEngine.UI.Button:OnPointerClick(PointerEventData)
UnityEngine.EventSystems.ExecuteEvents:Execute(IPointerClickHandler, BaseEventData)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent()
UnityEngine.EventSystems.StandaloneInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()
 
(Filename:  Line: -1)

Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
NullReferenceException: Object reference not set to an instance of an object
  at Stormland.UI.InteractionBlocker.OnDisable () [0x00000] in <filename unknown>:0  
(Filename:  Line: -1)

UnloadTime: 6.043118 ms

Unloading 24 unused Assets to reduce memory usage. Loaded Objects now: 165211.
Total: 65.041736 ms (FindLiveObjects: 9.051622 ms CreateObjectMapping: 3.978484 ms MarkObjects: 51.838830 ms  DeleteObjects: 0.172031 ms)

Update: I was able to fix the issue by unchecking fullscreen then rechecking fullscreen again. Continues to work fine even after game restart.

Developer

Thanks for these additional details, I'm pretty sure to fully understand the problem now. Will be fixed soon.

(1 edit)

You're right! It's related to resolution, every other resolution works (except 1920x1080 which i was using).

Now i can enjoy :D

Your fix does not work for 1920x1080, not for me.

(1 edit)

I don't know if this is still relevant since I played using the version I downloaded 30.5.2018 (don't know what the version name is) but crafting strapings(and I think clicking about the unlocking of it) caused the game to stop reacting the mouse clicks except for the esc button which opened the menu. The menu was not reacting to clicks either. There was no error message.  Don't know how to give a short version of what the computers specs are so here is a link to a storepage for it.

https://www.dustinhome.fi/product/5010875084/rog-g751jy-t7373h?ssel=false

sorry for the fact that the site is in finnish.


Edit: Seems like the problem with strapings have been mentioned earlier

Developer (1 edit)

I believe this has been fixed in the last build, I'm going to double-check

0.9b sur Macbook pro le premier "spacious wattle shack" que je crée, il est impossible dele réparer après la tempête. Si j'en crée un second, celui là je peux le réparer.

Developer

Ok, étrange comme bug, je vais tenter de le reproduire de mon côté. Merci !

Si ca se reproduit y a t'il moyen que je vous envoie ma sauvegarde du jeu étant donné que je suis sous mac ?

Developer

Oui, ça devrait marcher quand même.

J'ai a nouveau une maison que je n'arrive pas à réparer. Je ne sais pas ou trouver les fichiers de sauvegarde

Developer

Sous Windows c'est dans C:\Users\<username>\AppData\LocalLow\Subtle Games\Seeds of Resilience\Saves

(pense à remplacer username par ton nom d'utilisateur)

Je suis sous Mac. Par ailleurs j'ai pas mal de sauvegardes corrompues quand je veux les ouvrir. J'ai du mal à comprendre le but du jeu : on se développe jusqu'au moment ou on a épuisé les réserves de schiste et de malachite et on regarde ses settlers mourir faute de pouvoir réparer les bâtiments ? C'est assez déprimant.

Developer(+1)

Je n'ai pas de Mac pour vérifier mais d'après ce que j'ai trouvé sur le net ça devrait être dans ~/Library/Application Support/Subtle Games/Seeds of Resilience
Comme indiqué sur la page du jeu, il est en cours de développement. Tu peux jeter un oeil à notre roadmap ici : https://trello.com/b/VZ2LWnRS/seeds-of-resilience-public-roadmap

Le jour d'après je peux à nouveau réparer la maison