Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Pixel Composer

Node based VFX compositor for pixel art. · By MakhamDev

Execution issues

A topic by Celestial Games created Jan 12, 2022 Views: 478 Replies: 12
Viewing posts 1 to 7

Hello,

I have tried version 0.7.5 0.8.0 and 0.8.1 all don’t start when I click the executable.

I unzip it and have tried running as administrator. Is there any way I could enable some kind of logging that might help me debug.

I will continue to see if I can figure out a root cause.

Best Regards

Developer

So it doesn't show anything at all right? Hmmm... I agree I will add a logging in the next update. Right now I don't know what happened too, sorry.

Same issue, running through itch launcher. It quits before it's visible. I'm running on an Intel iGPU here, and they have been known to have issues with certain things, especially with some versions of OpenGL. What are you using to draw the display?

(1 edit)

Same issue, last version isn't working I will try the other ones

Edit: 10.0 and 9.1 work fine

Same, 10.0 and 10.1 was not starting, but the 9.1 started.

After execution of 9.1 both 10.0 and 10.1 could be started! :)

I got the same thing. 10.1 didn't work, but 9.1 fixed it

Was something important that's only on 9.1?

Developer(+1)

Can you check in appdata/local/pixel_composer/log.txt if any log message appears when opening the program version 10.1? If there is please send it to me, thank you.

(1 edit)

I was on 0.9.0.  It silently never really opens. The only thing I can see is the log is "session begin" and that you should add leading zeroes on the minutes and seconds. No other entries in the log. also it was at %LOCALAPPDATA%\Pixels_Composer\log_temp.txt
I upgraded to 10.1 and it also fails silently with "session begin" in the log.
I uninstalled all that and installed 0.9.1 
0.9.1 fails too, writing the same thing to the log, but not so silently:

Maybe it doesn't like dodgy Intel iGPUs?

Developer

Can you give me your system configuration? This software is made in GameMaker so if you can play GM games you shouldn’t have a problem. (Well unless it’s a DLL problem, or a vsync problem, or iGPU problem like you’ve said, idk really)

Operating System
Windows 10 Pro 64-bit

CPU
Intel Core i5 4570S @ 2.90GHz 47 °C
Haswell 22nm Technology

RAM
16.0GB Dual-Channel DDR3 @ 790MHz (11-11-11-28)

Motherboard
Dell Inc. 0WPG9H (SOCKET 0)

Graphics
OptiPlex 9020 (1920x1080@60Hz)
Intel HD Graphics 4600 (Dell)

Storage
232GB Samsung SSD 850 EVO 250GB (SATA (SSD))

Memory
Type DDR3
Size 16384 MBytes
Channels # Dual

Oh actually I just noticed a separate issue.
My windows username and user profile folder location aren't identical. Looks like you might be using the %Username% to determine the user profile folder? If so, don't do that. Try %UserProfile% instead.

Developer(+1)

That might be the case. I’ll change it, thank you!

Hello Came back to try the application again.

9.1 Launches and works YAY

10.1 Crashes still

I could not find the log folders local. Search both drives for that folder name in case it was going someplace else. It was not there. However in 10.1 there is a local ‘log_temp.txt’

The contents are just this.

[MESSAGE] 2022/11/17 5:39:5 > session begin