🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Butler failed with code 3221226505

A topic by DaddyDiscord created 93 days ago Views: 391 Replies: 15
Viewing posts 1 to 7

I cannot run itch.io app, it tries to download butler and failes every time. What should I do? Please help!

I have the same problem. Nobody have a solution?

Admin

Looks like 3221226505 corresponds to process termination code 0xC0000409, which seems to mean "Stack corruption detected (typically a result of /GS stack checks)." (according to this page).

I'm going to try and reproduce it, but in the meantime, could you both let me know:

  • What version of Windows you're running
  • Whether it's a 32-bit or 64-bit install of Windows
  • If you have any antivirus software installed

To find the Windows version & architecture, you can search for "System Information" in the start menu and post a screenshot of the first few rows of the "System Summary" tab. Mine looks like this:


It's in Russian, but you can see, I have Win 10 Home x64. Antivirus - Windows Guard

Admin

Re your antivirus: did you mean BullGuard ? I'm not able to find any software by the name "Windows Guard"

Admin

I'm not able to reproduce the issue - for me, the app is able to install butler just fine from scratch.

Can you try deleting all files in `%APPDATA%\itch\bin` and try starting up the app again?

I tried to even reinstall the app, still didn't work

Admin

Re-installing the app does not wipe the `%APPDATA%\itch\bin` folder though.

This is really frustrating because I would like to see exactly what's going on, but I can't because I can't reproduce the same issue on any of my windows installs :(

Here's what I would try out:

  • Open a Command-Line prompt (`cmd.exe` in the start menu)
    • cd to %APPDATA%\itch\bin
    • execute `butler -V`
    • execute `echo %ERRORLEVEL%`
  • Download an older version of butler, https://dl.itch.ovh/butler/windows-amd64/v9.0.0/butler.exe for example, and do the same thing
  • Run Process Monitor, filtered to "butler.exe", and do the same thing

Screenshots of the above would be super useful.

This is all I have in \bin

I tried to delete everything and restart, but the app simply restores all files and doesn't work. Then I tried to delete everything and install an older version of butler, the one you suggested, and then restart. Apparently, I made it even worse...


There is now a new butler archive. I unpacked it, the new file replaced the old one, and the old issue came back. So, this is the easiest way I tried. I appreciate your help, but I'm not sure, how to work with Command Prompt. I tried to print this, but the syntax error appeared. It says: "The File name, directory name, or volume label syntax is incorrect", so any advice would be very helpful. Thank you.

Admin

Hey,

Sorry, this is a hard problem to debug remotely.

The correct version of the first command is just `cd %APPDATA%\itch\bin` (without the `to`).

I tried your solution but the issue is always here. I reinstalled the app, downloaded butler from your link and nothing works. I have attached a screenshot of my command prompt to help you. The first error code is linked to butler installed by the app. The second code is when i tried to reinstall butler manually.

Admin

Hey, sorry for the late response and thanks for the info!

Do you have any antivirus software installed?

I have Avast! Free installed on my computer. And the UAC is at the maximum level.

Admin

Thanks for the response! This is consistent with my tests: Avast blocks access to butler until it can run its cloud scan (which can take several hours). They have a whitelisting program, so I'll get in touch with them.

Admin (Edited 1 time)

On a fresh Windows 10.0.16299.19 install, 64-bit butler v11.0.0 runs without problems for me:


Additional research:

  • With BitDefender Free edition, downloading and running butler.exe (even scanning it explicitly) is no problem either.

Me to!I keep clicking but it won't work. :(