Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Tailor Tales

Romance hot guys and create your own clothes. · By Celianna

4.0.3 Technical support & Bug reports Sticky

A topic by Celianna created Jul 15, 2021 Views: 1,152 Replies: 37
Viewing posts 1 to 14
Developer (1 edit)

For the general FAQ, check here.


Have you run into a bug or error? Please mention it here for help. Reinstalling should be a last effort.

---------

Errors are stored in an error file that would be great information to have, so please locate the error file in:

Tailor Tales > www > Last Error.txt

Copy its contents in your post.

---------


-- What to do when you run into an error that says a file is missing?

You may encounter an error that says a file is missing. That means the update didn't fully download. Unfortunately there is no way to force the Itch app to validate the files. However, you can make Itch reinstall the game, your save file will remain in tact. Note that if you're using a standalone version, you can simply re-download a new version from this page and replace the entire folder with the new download to fix any missing files.

-- My patterns on clothing don't show up, or they're covering the screen.
Please follow the instructions here to fix this error.

Any other errors or bugs? Don't hesitate to visit the Discord for immediate help with the game. You can also report anything in this thread.

When reporting a bug, please mention what you were doing before it happened and what you were trying to do. Screenshots help a ton! In the event of a black screen or considerate lag, please mention your computer specs as well, specifically your RAM.

Please help me !!!

I'm on the Jeames route, when I do the Palace Dress in the game it says I didn't do it

Developer

If you've completed the important client for the palace dress, then the dress should be in your Outfits, in the category outfits, so please check it and wear the dress before continuing :)

(+1)

Thank you very much you are a very attentive team !!!!

\\\\ > W < \\\\ ~S2

Deleted post
Developer

I'm glad that issue is resolved! There have been many behind the scenes quality updates to this version, so hopefully it runs smoother :)

(2 edits)

Hi, Celianna 

Hope all is well if you!? 

I love Jamie routing so far but unfortunately halfway through the way my computer got the black screen again ( it glitches out and closest to  game )  and I don't know what do to do you have any ideas on how I can fix it? 


From Mak 

( sorry if grammar or spelling is off I'm dyslexic ) 

Developer

Unfortunately, the game actually closing on you is more hardware related so it is hard to pinpoint. You don't happen to get the black screen at a specific point in the game, right? If it can be reproduced, then my programmer can work on it. If it's random, then that's much harder to tackle!

For now, you can try turning off the graphics enhancements in the Misc settings, this might improve how Tailor Tales runs.

Tailor Tales also requires enough RAM to run (it's very image heavy), so if you find yourself binging on the game for several hours, make sure to save the game, exit, and then open it up again to free up your RAM.

Let me know if the black screen is something you can reproduce reliably, and/or if turning off graphic enhancements works or not!

Thank you for your reply so quickly! It was hard to find but I figure it out and was able to fix it with some basic coding skills and just allow my Computer not to overheat too! thank you the game is really fun!!! 

Hiiii I love your games!! I just downloaded the new updated to play james but for some reason the game wont let me pass the dress up stage? I press yes to save your current avatar and it just doesnt do anything? Its a mac with 8GB ram - do you have any advice on how to fix this? Thanks and again your work is sooooo good keep crushing it xx

Developer

Mac is not officially supported due to this bug (the game is trying to save an image to your PC and Mac is blocking it because it is a third party software). You can try it out this advice:

Let Itch install the game for you. If you encounter an error when you try to create a character at the beginning of the game, please follow these steps:

- Click the Apple Icon in the top left corner.
- Go to System Preferences > Security & Privacy > Privacy > Accessibility > and allow the game to take control of your computer (checkmark must be off)
- Play the game again

If that still didn't work, you can try out this: - Locate the folder Tailor Tales\Game.app\Contents\MacOS - Open up the game by clicking the file  "nwjs". This should open the debug window as well, simply minimize it and play the game as normal!


Or you can try and run a Windows emulator to run the game on Mac.

(1 edit)

Hi,

I just started James' route and I'm getting this error: "Cannot read property 'length' of null". I'm on Mac by the way, I download the game through the itch.io app


Developer (1 edit)

That seems to be the part where James says your name. Can you confirm you named yourself JD (Jane Doe) as the MC? I may have forgotten to upload the fix with the name for Mac users. But if it's true, then your name is currently the issue - it doesn't have a vowel. If you temporarily change your name in the main menu, under profile settings, to something with a vowel, like Jane, then you can pass the chapter. I'll upload the fix later if you confirm that indeed, your name didn't have any vowels.

You're right, I added a vowel to my name and the error no longer shows up. Thank you for your help!

Hi, I need help!

I was playing the first chapter of James and these errors appeared:

Thanks in advance!
Developer

Hmm this seems hardware related.

Can you go to your Tailor Tales folder and find the Last Error.text file?

Tailor Tales > www > Last Error.txt

Copy its contents in your post please :) it shares more details than the screenshots.

(2 edits)

NAME: undefined

MESSAGE: Uncaught TypeError: Cannot read property 'resolution' of undefined

LINE: 29556

FILENAME: chrome-extension://odlameecjipmbmbejkplpemijjgpljce/www/js/libs/pixi.js

ERROR: TypeError: Cannot read property 'resolution' of undefined


Thanks for the reply!

Developer (1 edit)

Alright, some further questions:

1. Does this happen every single time you try to play the chapter, and at the same point?

2. When exactly does the error appear? You said you played James' first chapter, which I assume means the error will appear for EVERY chapter. Does the intro still run? Do the curtains open up, can you see the background? Can you see the textbox? Does the error appear as soon as a character is supposed to show up on screen? Any detail here would be appreciated, we're trying to figure out what exactly causes the error to happen, and that can be any number of things, such as a character sprite appearing, the background blurring, the characters tinting etc.

Some tips for now: make sure to check for any updates on your drivers, as it seems to be related to the shaders not working, and that could be due to outdated software.

(1 edit)

I've tried to uninstall and install it again. And appeared that there are some corrupted archives:
Maybe is that.

I'm Portuguese that's why the system is in Portuguese.

Sorry for the delay, the mail hasn't notified me



Developer

Can you answer my questions please? Reinstalling probably won't help here, as I said; it's hardware related.

Update your drivers and windows frameworks (.NET Framework ect.)

found some minor typos and an animation error, got pics but i'm not sure how to upload multiple here so i hope a file sharer is okay.

-

in dimitri's route at the mall, there's a line where an old lady is speaking but dimitri's mouth moved as if he was speaking;
-

-

found a missing letter in caine's ending;
-

-

and another missing letter in neil's route;
-

Hi! I really love the game btw and i'm kind of new to this since i never experience this when i play other games so i have no clue what to do, i also don't know if this is normal? but i would like to know if there is something i could do with the saved files. I am already at chapter 16 in Neil's route and every time i'm in the main menu and exit the game, it always restarts and i have to play a new game. I already tried to play it 3 times and tried to save it but when i leave, there is no saved file recorded in the game. I also tried to look at the files and check the "save" but it is empty. I already delete and reinstalled the game but in every route i enter,  it just won't save and will bring me to the route choices where you begin everything. But other than that,  good job for the game, looking for more games in the future;)

Developer

Remember that Tailor Tales comes in a zip folder and you have to unpackage it on your computer to be able to save correctly. Otherwise a save file will never be created. Please don't play directly from the zip file. You can try installing it through the Itch app instead if this confuses you.

I understood thank you very much for answering! Have a nice day!

I cant move past character customizationn, the game crashes! please helpp. Im on Mac btw, tried giving the game control over my mac under settings but whole laptop froze...

Developer

If these instructions below do not work for you, then Tailor Tales simply cannot run on your Mac, I'm sorry.

You can try this:

Let the Itch app install the game for you. If you encounter an error when you try to create a character at the beginning of the game, please follow these steps:
- Click the Apple Icon in the top left corner.
- Go to System Preferences > Security & Privacy > Privacy > Accessibility > and allow the game to take control of your computer (checkmark must be off)
- Play the game again

If that still didn't work, you can try out this:
- Locate the folder Tailor Tales\Game.app\Contents\MacOS
- Open up the game by clicking the file "nwjs".
This should open the debug window as well, simply minimize it and play the game as normal!

Hello! I know Mac is not the best for the download of this game so I appreciate your response and help. I've tried the first one,  didn't work for me sadly, but I cannot seem to be able to find "Tailor Tales\Game.app\Contents\MacOS" to be able to open the file nwjs, I only get the zip and the actual game file when I download..

Developer

Remember to unzip the contents, so you can browse through the folder.

there's only a credit file and the actual game tho.. is there supposed to be something else?

Developer

Sorry I can't help you further then. I don't own a Mac, I don't know how to browse system files. Tailor Tales is not encrypted so you can dig into any of its folders.

I have a problem

When i quit the game, it doesn't save. (I checked 3 times to make sure)

It just kicks me off to the beggining, i lost all my progres

Do i have to finish off the game without quitting or something? It kind of upset me since i spent over 4 hours in it and all of it was lost

Developer

Please make sure you are not playing the game from the zip file, you have to unzip the zip file to be able to save the game.

The game not only lets you save in the main menu, it even auto saves. There's no need to start a new game each time.

(1 edit)

I did unzip it, and i had the save
To make sure, i downloaded it again and also unzipped it
Same result.
I also checked other games, and they dont seem to have such problem? Everything saves

Developer (1 edit)

To make sure, if you open up the folder Tailor Tales is installed in, you can browse to this location:

Tailor Tales > www > save

If this folder is empty, a save file isn't being created. You can start a new game, and as soon as you are able to save, save the game (click the cogwheel in the top left for settings, then click the save option). Check the folder; is it still empty? Or does it contain files?

Somehow, i had to use winrar to save the game instead?

Developer (1 edit)

I don't think I follow? What does winrar have to do with saving the game?

When you said you unzipped it, that does mean you were playing the game from the installed folder on your PC, correct? You're not going back to the zip folder to press the exe file? Unzipping = extracting with Winrar.

Make sure the folder you extracted Tailor Tales to also has administrator permission rights to write/edit files.

I dont know either? when i open the game from winrar downloads its perfectly fine and saved, and if i use the regular way, it just doesn't save.
But i guess its fixed now, since it works? Not sure why i needed winrar to open it.
Somehow unzipping it, doesn't let me save the game, but playing frm zip folder does. Its a weird situation but i've seen it before, so it might just be a problem with my browser.