🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bug: Error when trying to download my game

A topic by DarkstoneStudios created 64 days ago Views: 193 Replies: 11
Viewing posts 1 to 12
(+1)

Trying to download my game from its itch.io page currently isn't working. Here is a link to the page: https://darkstonestudios.itch.io/dark-system-alpha

If you try to download the game, you will get this error:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

<Error> <Code>SignatureDoesNotMatch</Code> <Message> ###span class="text" >span class="html-tag"###</Message>

<StringToSign> GET 1505438588 /itchio/build/45380/169061-archive-default </StringToSign>

</Error>

I'm fairly certain this is a bug with itch, and not something I'm doing. People were able to download it yesterday without issue, and I haven't changed anything since then. Maybe having a space between the number and the rest of the string is the issue "1505438588 /itchio/build/45380/169061-archive-default" 

Any help would be greatly appreciated!

(+1)

Looks like it isn't working in the itch app either:

errors.errorString Giving up, getting too many renewals....

(+1)

I'm also having this problem, with nearly every game I've tried to download. That makes it seem like it's a problem with the site, not the games.

Hm, I tried a couple other games and was able to download them alright. I'll try a few more.

(Edited 1 time)

It might be a different error, then. The specific message I'm getting in my browser (on Automata Empire, which I picked at random):

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Code>SignatureDoesNotMatch</Code>
<Message>
The request signature we calculated does not match the signature you provided. Check your Google secret key and signing method.
</Message>
<StringToSign>GET 1505441309 /itchio/upload2/game/59781/288466</StringToSign>
</Error>

Me, too. Getting the same exact problem. Getting `errors.errorString Giving up, getting too many renewals....` in the app and `SignatureDoesNotMatch` in browser

I get this too, tried Chromium and Itch besides Chrome, no difference. I've only seen Mac stuff download. O_o

The latest Mac update for Overland is giving me this error too. Must be something on itch's end.

(Edited 1 time)

*EDIT* Found a work around. If you desperately need anything at the moment, you may need to use the Itch.io desktop client. Downloading appears to be working fine there.

I've tried using the app, I get the "errors.errorString Giving up, getting too many renewals...." message Darkstone mentioned.

Admin(+1)

Hello, we had some temporary issues with our storage provider. It should be resolved now. If you're seeing a "too many renewals" error in the app please restart it. If you're still having an issue reply to me here. Thanks

(+2)

Thanks leafo, its working for me now.