Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

phasermaniac

14
Posts
A member registered Dec 01, 2019

Recent community posts

Bien pensado lo de los menús exclusivos para arcade. Esta opción la echo de menos en muchos juegos de pc, que no se ven mal en crt de 288p max pero los menús tienen letras tan pequeñas que no se ven bien.

De momento mantendré la versión antigua en la arcade a 4:3, creo que iba a 256?x192 ahora no lo recuerdo pero se ve perfecta.

Ánimo con Rawal Ruble! Pinta muy bien

Hola! Muy guapo el juego. Pero veo que comentáis que esta nueva versión de la demo es en 16:9, no admite 4:3? lo vais a dejar de lado? sería una pena

Hi! I wanted you to know that I have no longer this problem:

The new x360ce version let you convert dinput to xinput and hide the original dinput pads, so now I don't have the double input problem anymore. Thanks anyway!

"Is it possible the pads have been setup to work with another opengl game and DP2 is using the same config?"

No, I'm sure.

Another problem I found with previous demo version was the config not saving, but I think this was working on the last version. I'll test to ensure.

As you can see in the pictures you can see it's pixel perfect, although the colors looks better live. The photos looks desaturated.

Many thanks!


Hi! Amazing game! 

I configured the demo in my arcade pc with crt and displays perfect at 240p without any filter.

I have ps2 pads wich I rewired to the arcade buttons. But they are messy and I have to reorder them via config.

In previous demo version I got it working fine with x360ce (a program that emulates xbox pads).

In last demo version I have problems because the direct input pads are always detected, so if you press a button you are pressing to pads.

Can you make a toggle to change between dinput and xinput? or maybe an option to remap buttons?

Many thanks anyway and congratulations for this game!

No he probado aún la 1.47, pero el otro día probé con la 1.46 en la Arcade, pensandome que el problema serían las pistolas, (que se reconocen como ratones) y en cambio eran los mandos.

La impresión que me da es que si encuentra algún mando enchufado, le da prioridad sí o sí sobre el teclado.

En mi caso, como las palancas estan hechas con mandos de ps2, parece que los reconoce y les da prioridad sobre el teclado pero no funcionan.

Supongo que a parte de ignorar las entradas de ratón, pen o touchcreen, que está bien porque está claro que no se van a usar para un juego de este tipo, habría que darle prioridad al dispositivo del que detecte alguna entrada, cosa que parece que se usa mucho en los juegos modernos. 

Pero bueno, supongo que mi caso también es un poco especialito. Gracias igualmente por las mejoras, aunque a mí no me lo solucione, creo que con ignorar los punteros a la mayoría le servirá.

Vale...

Resulta que tengo una wacom por cable que no tengo ni en casa y un programilla que hace tiempo que ni usaba que se llama "virtual tablet" para conectar un android al Pc y usarlo como tableta gráfica. No estaba iniciado, pero ha sido desinsatarlo y funcionar, tanto sólo con teclado y ratón enchufados como con eso más los 2 mandos x360.

El player 2 creo que no respondía simplemente porque en el splash siempre espera a que el player 1 esté activo, pone "wait for player 1" y claro no puedes pasar de ahi.

Eso sí, creo que lo suyo es arreglarlo, porque veo que no soy el único que tiene problemas con eso.

Por ejemplo, en otro win10 que tengo en una arcade, hay 4 mandos enchufados, dos pistolas y un trackball.  No puedo ir desconectando y conectando, porque cambia la numeración de los dispositivos y se me desconfigura todo.

Si, tengo una wacom pero no estaba enchufada, es lo raro, porque ya había probado desenchufando todo menos el teclado.

Ten en cuenta que he subido dos logs seguidos, no se si te has fijado. El primero sólo con el teclado y raton conectados, el segundo con teclado ratón y dos pads x360 simulados

Con teclado y 2 pads x360 (simulados con x360kb):

Mono path[0] = 'C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.46/AnAmericanWerewolfInLA/WerewolfInLA_Data/Managed'
Mono config path = 'C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.46/AnAmericanWerewolfInLA/MonoBleedingEdge/etc'
Initialize engine version: 2019.2.12f1 (b1a7e1fb4fa5)
[XR] Discovering subsystems at path C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.46/AnAmericanWerewolfInLA/WerewolfInLA_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: Radeon(TM) RX 460 Graphics (ID=0x67ef)
    Vendor:   
    VRAM:     4076 MB
    Driver:   26.20.13001.40003
Begin MonoManager ReloadAssembly
- Completed reload, in  0.085 seconds
<RI> Initializing input.

New input system (experimental) initialized
<RI> Input initialized.

<RI> Initialized touch support.

UnloadTime: 0.560075 ms
****** Player1 *******
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Assigned devices: 0
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Joysticks: 5
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Gamepads: 2
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

all: 5
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Player 0 Assigned: Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

So... NO GAMEPADS, USE KEYBOARD? False
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboards used? False False
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

****** Player2 *******
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Assigned devices: 1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Joysticks: 5
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Gamepads: 2
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

all: 5
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

XInputControllerWindows1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Player 1 Assigned: XInputControllerWindows
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

So... NO GAMEPADS, USE KEYBOARD? False
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboards used? False False
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Solo con teclado:

Mono path[0] = 'C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.46/AnAmericanWerewolfInLA/WerewolfInLA_Data/Managed'
Mono config path = 'C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.46/AnAmericanWerewolfInLA/MonoBleedingEdge/etc'
Initialize engine version: 2019.2.12f1 (b1a7e1fb4fa5)
[XR] Discovering subsystems at path C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.46/AnAmericanWerewolfInLA/WerewolfInLA_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: Radeon(TM) RX 460 Graphics (ID=0x67ef)
    Vendor:   
    VRAM:     4076 MB
    Driver:   26.20.13001.40003
Begin MonoManager ReloadAssembly
- Completed reload, in  1.167 seconds
<RI> Initializing input.

New input system (experimental) initialized
<RI> Input initialized.

<RI> Initialized touch support.

UnloadTime: 0.634892 ms
****** Player1 *******
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Assigned devices: 0
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Joysticks: 3
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Gamepads: 0
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

all: 3
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Player 0 Assigned: Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

So... NO GAMEPADS, USE KEYBOARD? False
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboards used? False False
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

****** Player2 *******
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Assigned devices: 1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Joysticks: 3
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Gamepads: 0
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

all: 3
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboard
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Mouse
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Pen
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

So... NO GAMEPADS, USE KEYBOARD? True
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Keyboards used? False False
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Player 1 Assigned: WASD
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Setting up 4 worker threads for Enlighten.
  Thread -> id: 1838 -> priority: 1 
  Thread -> id: 1134 -> priority: 1 
  Thread -> id: 33c8 -> priority: 1 
  Thread -> id: 35f0 -> priority: 1 
Clear assigned devices
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Clear assigned devices
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

si, probé todas las teclas.

Pero no tenía ningun pad enchufado, solo teclado.

Si conecto dos pads de xbox simulados el log muestra lo mismo, p1 Assigned devices: 0 y p2 Assigned devices: 1

Así es

Mi log:

Mono path[0] = 'C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.41/AnAmericanWerewolfInLA/WerewolfInLA_Data/Managed'
Mono config path = 'C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.41/AnAmericanWerewolfInLA/MonoBleedingEdge/etc'
Initialize engine version: 2019.2.12f1 (b1a7e1fb4fa5)
[XR] Discovering subsystems at path C:/Users/xabacanstyle/Downloads/AnAmericanWerewolfInLA_1.41/AnAmericanWerewolfInLA/WerewolfInLA_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: Radeon(TM) RX 460 Graphics (ID=0x67ef)
    Vendor:   
    VRAM:     4076 MB
    Driver:   26.20.13001.40003
Begin MonoManager ReloadAssembly
- Completed reload, in  1.189 seconds
<RI> Initializing input.

New input system (experimental) initialized
<RI> Input initialized.

<RI> Initialized touch support.

UnloadTime: 13.944768 ms
****** Player1 *******
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Assigned devices: 0
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

****** Player2 *******
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Assigned devices: 1
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Setting up 4 worker threads for Enlighten.
  Thread -> id: 3870 -> priority: 1 
  Thread -> id: 3670 -> priority: 1 
  Thread -> id: 2c04 -> priority: 1 
  Thread -> id: 3ca8 -> priority: 1 
Clear assigned devices
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Clear assigned devices
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

(1 edit)

Si, he probado en un win 10 normal sin ningún pad y el teclado no responde, Tanto en la primera versión como la actualizada (1.45)

En la recreativa tengo win 10 también, o sea que eso no es problema. Lo he puesto a 320x240 y no se ve mal, pero claro no he podido pasar de la pantalla de splash. A qué resolución está diseñado entonces?

(3 edits)

Hola! el juego pinta bien la verdad, ahora probaré a meterlo en mi máquina arcade con monitor crt a ver cómo se ve a bajas resoluciones. Me recomendáis alguna resolución en concreto?

Pero de momento, en un pc win 10 que he probado no me responde ni con el teclado ni con pads xbox simulados (usando x360kb)

Así de primeras, lo único que me canta igual es la poca variedad entre los dos protagonistas, pero bueno, ya digo, aún no he podido probarlo.