Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

I'm playing on a Windows computer, it's had problems before, but generally only with running speed. It's not even close to a perfect one, so chances are it's just an issue with a virus of some sort that's been on here for a while. Sorry for the bad quality, I couldn't take a screen capture so I had to take a picture and raise the brightness.

Hmmmm it almost looks like it's a problem with the GPU but I can't say for sure. Does the problem start when you launch the game or does it start after a while?

Directly when I start the game, I see that screen and get a little bit of mangled, cut-off audio

hmmmm I think it might be the GPU since at the start the company video launches. Do you happen to have an Xbox One?

I do, actually. Quick question, does the messed-up audio connect to the GPU issue, or is there more than one thing wrong?

The start logo audio is purposelly distorted. So that's normal ;)

The start logo audio is purposelly distorted. So that's normal ;)

Anyway thanks for bringing the problem to our attention. Could you please write about the issue to info@fantasticostudio.it so the guys in charge can look it up?

Sure, thanks for helping me this far.

Hey SquailWhale :). I am experiencing the exact same issue as you did and was wondering if you have had any luck sorting it out? 

Thanks!

No, sorry. I meant to enquire to the email but haven't yet, but I'll definitely do it now and see what happens!

Thanks :) if you do come across a solution, I appreciate if you let me know