Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Beta testing for Century

A topic by Zuuri created 58 days ago Views: 104 Replies: 15
Viewing posts 1 to 7
Submitted (1 edit) (+4)

I finally finished the game, or so I think. I'm sure there's bugs I haven't found, but that's what this is for! There's some more art that I need to make for certain things, but overall you should be able to beat the game. I recommend playing through a few times to see the different things you can do, there's lots of options! Please let me know if you find any bugs, weird sounding text or anything that obviously shouldn't be there. Thanks in advance!

https://zuuri.itch.io/century

The password is 5321


Edit: Game has been updated, I'm sure there are more bugs so please let me know if you find them. If you would like me to add any responses as well, let me know so I can!

Submitted

No hard feelings, but I am really struggling with this game. It appears to be full of bugs, but I'm not 100% sure whether they're bugs or not. Before I start reporting bugs that might not be bugs, can you tell me:

  1. Is it possible to place either of the fish on the pedastal [sic]?
  2. Is it possible to get an apple?
  3. Does the stick serve any purpose?
  4. Does the jagged rock serve any purpose?
  5. Does the nice warm meal serve any purpose, other than to kill you?

None of the verbs that I try are understood. The few that are understood do not work on the things that I would have expected them to work on.

Submitted

You've got further than me. So far, I've only found two of the numbers needed for the safe combination.

Submitted

It's updated, you theoretically should be able to get through 100% now. P.S. in the kitchen, rather than moving the board, you should turn it in the direction of the scratches!

Submitted (1 edit)

You've probably found the two numbers in the living room. I think finding the next two numbers is a bug, as you have to refer to something that has never been mentioned. Try using the flashlight in the kitchen.

Submitted

Actually, I must tell you a funny story. I spent ages stuck in the first room. The room was dark and I was searching everywhere for hidden objects or a light source or a means of opening that damn door. I tried unlocking it, opening it, hitting it, kicking it, breaking it, tapping on it, looking under it, picking the lock and so on. Sometimes the simplest solutions are staring you in the face. All I had to do was GO NORTH.

Submitted

I came back to it and got a bit further. I'm now stuck in the treasure room and can't find a way to get out. I only got that far because of all the bugs that allowed me to "cheat". I don't think I'll be able to get any further, so here's my (somewhat verbose) comments so far:

General comments:

The continual press_any_key in every room is very annoying. Why not just print it?
Don't print all the extra blank lines between paragraphs after all the press_any_key prompts, then you won't need the press_any_key all the time.
You can't drop anything anywhere. This is really annoying, especially when you have two fish and it keeps referring to the wrong one. You should use Adventuron's default handling of GET and DROP. Don't do your own thing, except in those circumstances where you need to test something first, or override the default behaviour.
There are lots of descriptions that imply you should be able to do something, but when you try to do those things, they are never understand, e.g. BREAK, CUT, CHOP, CLEAN, COOK, DIVE, HIT, RUB, SHARPEN, STAB, START, SWIM, TICKLE and so on.

Dark Cave:
Add ENTER, PRESS and TYPE as synonyms for DIAL, as you don't dial a number pad.

Living Room:
GLASS and WATER should generally be used as synonyms for the glass of water. For example, X GLASS doesn't work, but X WATER does.
You can't DRINK WATER.

Kitchen:
USE FLASHLIGHT: "You shine the flashlight in the hole..." Hole? What hole? You never mentioned a hole!

Beautiful Lake:
If you have both fish (plain and neon), X FISH describes the plain fish and the fish in the lake, but not the neon one, even if you X NEON FISH.
GO LAKE describes the lake.
There is no response for ENTER LAKE, DIVE, PADDLE, SWIM, DRINK WATER or anything else that you would expect to try at a lake.
USE SPEAR asks "What do you want to use the spear for?" CATCH FISH says "You use the spear to catch a fish. You really tried to catch something, but you didn't." So, did I catch a fish or not? It's hard to tell because I already had the fish. When I tried this a second time, I caught a neon fish, even though I already had it in my inventory. Now (at long last - see below), I could place the neon fish that I already had on the pedestal at the closed cave.

Closed Cave:
"pedastal" should be "pedestal" (many instances of this).
PLACE FISH: "in the pedastal" should be "on the pedestal".
When you place a fish on the pedestal, it says you place the fish in the pedestal (without telling you which fish), but nothing happens. The fish is not dropped and is still in your inventory. So, did you put the fish on the pedestal or not? I've tried this with both fish.
When you EXAMINE ROCKS, you get told there's a jagged one there, even after you've taken it. You can get it repeatedly.
When you GET ALL, it says "There's no spear here." Spear? What spear? As a result of this, and some trial and error, I discovered that you can USE ROCK to carve a spear and the rock disappears. You shouldn't use USE as a verb and the rock shouldn't have disappeared. Try commands like SHARPEN STICK, CARVE STICK or MAKE SPEAR. Even then, they'd be pretty hard to guess without a hint.

Forest:
When you GET APPLE, it says you take a low-hanging one, but it's not added to your inventory. It also says "Too bad your meal is already cold...", but your inventory says you've got "A Nice Warm Meal". You can GET APPLE over and over again, but nothing changes.
When you CLIMB TREE, the location description and image don't change, but you're apparently up a tree. If you CLIMB tree again to climb down, you climb up again. You need to CLIMB DOWN to get out of the tree.
When you GET BRANCH, a stick is added to your inventory, but the room description still says there's a branch stuck in the tree. You can GET STICK over and over again.

Treasure Room:
Oh my god. What did I do to deserve this? I'm in a room full of treasure and there's nothing to examine. However, GET ALL gets a key, an "It's the crowbar" and the "key for a treasure chest". What the?
There's an image of a door, so I X DOOR and get told "The single wooden door with a keyhole. is not here." But I can see it! It's in the picture! (And that extra full stop after "keyhole" is not a typo on my part.)
So I EXAMINE CHEST and get told "You open the chest, and inside is a crowbar." Hang on. I've already got that. You can repeat this again and again, but I didn't want to open it. I only wanted to examine it.
OPEN DOOR: "The door is locked."
UNLOCK DOOR: "The door is locked." Sheesh. I've got three keys and none of them work.
I resort to violence, USE CROWBAR, verbs like JEMMY, LEVER, PRY, PRISE, PRIZE and nothing works. YELL, SCREAM, SHOUT, PRAY, THINK and so on. Nothing works. I'm stuck at this point. Is there a way out of the treasure room?

You've got a lot to fix and only one day to do it. Good luck.
Submitted

Thanks for all your input, this is my first game so I truthfully had no idea what to expect when making it. I'll work on fixing all that you brought up, please let me know if you find anything else! Also, I sort of forgot to describe the final room which is a big problem on my part, sorry for that.

Host

Gary is very exacting, and I did get stuck when playing the game too, but I actually likes the pattern of delivering dialog in the first couple of scenes using the press_any_key and the tunes. I loved the beep tunes in fact. 

The graphics to me are very nice.

It's an atypical adventure game, and I'm not sure if eating the meal is a good thing or a bad thing, when it sends me back to the start. Based on your questions on pan_game variables, I assume that it's a game that involves the player learning facts every playthrough then resetting the game with the meal. But maybe I'm wrong. 

Anyway, it's unorthodox, and definitely pay attention to what Gary is saying, but I like the uniqueness of it.

Submitted

I expected some pretty bad bugs, luckily most of them seemed rather easy to fix! Ah thank you, I did it like that because I preferred taking in the sentence before moving on, so I'm deciding to keep it like that since you like it. I'm glad you like the tunes! I tried making them fit the scenery well, and I love music so that was fun.


When you complete the game, the restarts will make a lot more sense to you. Basically, whenever you "game over" or "die" it just restarts another year, and you'll see why in the final room. I realize it's rather atypical, I wanted to do something sort of unique, I wish I had executed it a little better. But still, thank you very much!

Submitted

When I was playing it, I thought all those dream-like interludes in a new room were downright annoying, as they didn't seem to have any relevance to the game. Based on your comments, it sounds like eating the meal did not kill you, but sent you back to the start. This was not clear to me and I just continued playing as if it was a new game. Certainly, nothing seemed to have changed.

Now that I know, I think I need to pay more attention to those annoying interludes. Maybe there was something in there that changed each time through. I'm now looking forward to playing the revised version, but won't have time today.

Good luck with the final submission.

Submitted

It's more of a story-based text adventure, so it's mostly up to your interpretation of what happens but yes, technically the meal does not "kill" you. Everything in the game just makes you restart a year, nothing changes between the runs because I didn't have the time to implement all that, but I did want to do that!


Thank you ^^

Submitted

It's updated! I fixed most of the bugs I believe, please tell me if you find any more!

Host (1 edit)

Hi Zuuri.

Please can you update Adventuron to beta 7a (press F5 in the window), and recompile.

There was a bug with saved games and the pan_game variable scope. The error is that different save files were overwriting each other, which meant that loading a game would mess with another game.

I also changed the name of "pan_game" to "survivor" (as it survives a restart), and updated the documentation on this. I think survivor is easier to understand.

Submitted

Updated! Thanks for letting me know.

Submitted

I've been playing it again and there are still lots of bugs. Some of the old ones are fixed, some aren't and there's some new ones. I tried eating the meal and could not see any difference in the "final" room. In fact, I could not see any difference in anything. It just looks like you start again.

Anyway, I've got the treasure and I'm stuck in the "final" room. That's the one with no description, no objects, no nothing. Have I done something wrong to make it unwinnable or is there some magic verb that I'm supposed to guess? The only thing I've found that provides any useful feedback at all is THINK, but that works anywhere.