Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Easy Feedback Form

Easy Feedback brings detailed player feedback and bug reporting to your Unity game directly to you! 路 By Noah Ratcliff

invalid token

A topic by Fishagon LLC created Sep 21, 2020 Views: 233 Replies: 7
Viewing posts 1 to 5

Hey Noah,

I recently purchased EF and brought it into my Unity 2020.1 project. It's able to login with my auth token, however, when I try to "Create Board" it gets an ArgumentException: JSON parse error: Invalid value.

I put a debug.log in Trello.cs at 300 "Debug.Log(resp.Text)" and it returns with "invalid token". 

Could you give the asset a try in Unity 2020.1?

Developer

Hello! This is the first time I'm hearing about this issue. I will look into it ASAP and get back to you.

In the meantime, could you please try logging EF out of Trello and re-authenticating to see if that fixes the issue?

Oh yea, tried that a bunch of times. 

I'll note I also learned that while EF was installed, I couldn't hit Play or change scenes in my project without Unity going unresponsive completely. Had to remove the asset before it would work again. 

I would specifically look into if this is something with how Unity 2020.1 works? Might have something to do with the Burst Compiler or Job Systems?

Developer

Huh! That's no good. Thanks for letting me know! I'll check it out this week.

Developer

Unfortunately, I can not reproduce either the token issue or the unresponsive editor issue in 2020.1.6f1. 

Here are the steps I followed:

  1. Create a new project in 2020.1.6f1
  2. Import Easy Feedback 1.3.0 from the Package Manager
  3. Configure EF as usual from Tools/Easy Feedback/Configure
    1. No errors in editor console during authentication
  4. Press the "New Board" button and create a new board on Trello
  5. Open the EF demo scene at Plugins/Easy Feedback/Demo.unity
  6. Hit the play button, use the buttons in the scene to log some messages and submit a couple test reports
  7. Hit the play button again to stop playmode

Because I can't reproduce this locally, could you please try and reproduce both issues on your end, then send me the Editor.log file(s) for the issue? You can find my email on the Easy Feedback Asset Store page.

This page shows where your Editor.log file should be located: https://docs.unity3d.com/Manual/LogFiles.html

Hello, I have what seems to be the same issue in Unity 2019.4.8f1 (LTS). I get the following error message when clicking 'create board' in the configuration panel. Just wondering if this was ever resolved? I think it should work with a basic (free) Trello account is that right?

Thanks

Jonah

Error message:

ArgumentException: JSON parse error: Invalid value.
UnityEngine.JsonUtility.FromJson (System.String json, System.Type type) (at <1386288601af43018501cce2912f52f4>:0)
UnityEngine.JsonUtility.FromJson[T] (System.String json) (at <1386288601af43018501cce2912f52f4>:0)
EasyFeedback.APIs.Trello.AddBoard (System.String name, System.Boolean defaultLabels, System.Boolean defaultLists, System.String desc, System.String idOrganization, System.String idBoardSource, System.String keepFromSource, System.String powerUps, System.Nullable`1[T] prefs) (at Assets/Plugins/Easy Feedback/Scripts/APIs/Trello.cs:302)
EasyFeedback.Editor.NewBoardWindow.SetupBoard (System.String boardName) (at Assets/Plugins/Easy Feedback/Scripts/Editor/NewBoardWindow.cs:83)
EasyFeedback.Editor.NewBoardWindow.OnGUI () (at Assets/Plugins/Easy Feedback/Scripts/Editor/NewBoardWindow.cs:61)
System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at <fb001e01371b4adca20013e0ac763896>:0)

never mind I seem to have resolved this by logging out and logging in again with the correct token. The original token I used had a trailing space at the end, I suspect this was the issue. Perhaps this is being automatically removed for some functions but not others?

Developer

Glad to hear you got it resolved. I'm making a note now to trim extra whitespace from the token during auth to prevent this issue in the future. 馃憤