Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

9 Nations

A turn based fantasy strategy game · By SvenTX

beginners problems

A topic by gabgab01 created Aug 11, 2020 Views: 110 Replies: 3
Viewing posts 1 to 3

hey, i just downloaded and tested out your game. here are a few ingame issues i'm having:

- ressources. i always lack wood or water. i built a lumberjack on a forest tile, but for some reason it just will not generate wood. no matter how many turns pass. i also run out of water really fast, so now my one worker can not move or build.

i have just built one lumberjack and one hunter at this point, on one tile of the oasis map on the left side where you have a forest, grass and water in range. there is no other place you can settle, as you can not upgrade the town hall, expand your borders far, or do anything else at all.

there also seems to be missing some cobblestone patches, and i cannot build a library to test research.

the tutorial is also kinda bugged, as i run out of water before being able to build the forester.


i also never know how many ressources are in my stockpile, i constantly have to check in the town hall menu, which is stupid.

- small bug: a worker on a mountain tile is stuck, as he will stop regenerating action points.

Developer

Hey gabgab01,

thanks for your feedback and sorry for the late answer, lot's of work.

@Water

I changed some game mechanics, so the base calculation was wrong. Balancing the game is not as much fun as developing it. But it should working in the next version.


@Cobble stone

You can build the cobble stone collector on a hill or on the mountain, but you should see this information in the build menu?


@Expand your borders

If you build a building you borders expand. You can see your border via the overlay menu. If some field is to far away your explorer can claim unknown areas, so your worker can build on it.


@Stockpile display

"i also never know how many ressources are in my stockpile, i constantly have to check in the town hall menu, which is stupid."

Mhm, where do you want the stockpile displayed? Or where do you need the size of your stockpile?

@worker on the mountain

"- small bug: a worker on a mountain tile is stuck, as he will stop regenerating action points."

If he get enough resources, he should regenerate his ap normally. So it should not a bug? You should get a notification, that he need more resources.


In the next days I will release the next version, then you can play the two tutorials normally. :)

And thanks again for your feedback :)


Greetings Sven

@water
Awesome! can't wait for the next update, game seems promising^^

@cobblestone
no, it wouldn't let me build them on mountains or other stony bits. but i was able to build a tent and my town hall there. also, the light is the only unit able to climb mountains. i can spawn villagers when my town hall is on a mountain, but then they are unable to move, as it costs more action points to move them than they can store.

@expand
i tried to place my town hall  on the left half of the default oasis, trying to get water, grass and forest. i then expanded with tents, as the claiming with scouts somehow didnt work. they just wouldnt do it for me. maybe my instance is just bugged?

@stockpile
usualy, stockpiles are displayed on the top or bottom of the screen, and would show things like "stored wood&wood per turn", "stored stone&stone per turn", "stored food&food per turn", "stored water"water per turn".
so far i dont know if/when my buildings produce. i've build a lumber hut for example, and one building which needed just one more wood to complete, and no matter how many turns passed, it just wouldn't generate wood, and the building wouldn't be finished.
also, different graphics for if the building is under construction vs if the building is working would've been nice.
as to how exactly a UI is supposed to be designed, well, i'm kinda the wrong guy to ask, but there are a few guides on youtube, some articles in the web and you can always take a look at how other games did it. maybe even come up with your own way?

thanks for the answer! i'll keep following your game and am looking forward to what you'll be doing^^ and thanks for making this game, it passed some boring hours when i had nothing else to do in class.

Developer

Hey gab,

At the moment the game is being exported, think in a few hours or for tomorrow it should be there ;)


@cobblestone

When you have built your town hall, the light element should not to be on the town hall. Then you can train the explorer or the worker in the town hall. Both have enough AP to climb the mountain. Maybe you create do a screenshot? At the moment i not really understand your problem? You can also use in the ingame feedback button, this generate also a screenshot.


@expand

If you want to build a building it need to be in your kingdom. You can show your border via the overlay, see screenshot (press the button at position 1 and then in the menu button at position 2)

If a field is to far away:

  • build a building, to at more fields.
  • use your explorer and claim a new field (button at position 3)


@stockpile

If you have no unread information in the top left corner, the building / unit will display the current city and resources. You can read all notifications with a right click or a left click.

The resource overview in the town show the last round produced resources.

When a building is under construction, it is colored green and the description shows its progress. It slowly turns normal. Maybe in the end it can hardly be recognized? I'll think of something for the next version.


If you find more bugs, let me know. I love to fix them :) Take care and see you soon 

Sven