Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

PQ93

a fantasy console for making small games · By pennie

Segmentation fault (core dumped) on Ubuntu 16.04

A topic by CiberSheep created Jun 11, 2020 Views: 439 Replies: 12
Viewing posts 1 to 11

Hello.

I have uncompressed de AppImage and run it and I get «Segmentation fault (core dumped)». Am I doing something wrong?

Developer

No, that will be my fault. :) If you could paste the core dump, that could be helpful, though!

(1 edit)

Mmmm... I can't manage to get any.

```
$ ./pq93-x86_64.AppImage
Violació de segment (bolcat de la imatge del nucli)
```

The message is just sayin «Segfault (core dump)». No other message.

Is there a parameter I could pass? Or a log? Or any other thing I can check?

Mmmm... I have tried the projector (with same result :)) and the Win64 through Wine (I don't know if that helps):

projectors/win64$ wine pq93-projector.exe system RAM: 7901MB
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x33f340,0x00000000), stub!
fixme:xinput:XInputGetCapabilities (3 1 0x33f6b0)
fixme:win:RegisterDeviceNotificationW (hwnd=0x10052, filter=0x12ae430,flags=0x00000000) returns a fake device notification handle!
fixme:win:RegisterDeviceNotificationW (hwnd=0x10054, filter=0x33f800,flags=0x00000004) returns a fake device notification handle!
fixme:xinput:XInputSetState (0 0x33f76c) Stub!
fixme:xinput:XInputSetState (1 0x33f76c) Stub!
fixme:xinput:XInputSetState (2 0x33f76c) Stub!
fixme:xinput:XInputSetState (3 0x33f76c) Stub!
audio spec:
    freq:     22050
    channels: 1
    samples:  4096
base path: Z:/home/cibersheep/Baixades/jocs/Bundle/pq93/projectors/win64/
pref path: Z:/home/cibersheep/Baixades/jocs/Bundle/pq93/projectors/win64/
--- loading config ---
overscan:
  left:    16
  top:      8
  right:   16
  bottom:   8
---       done     ---
fixme:win:RegisterTouchWindow (0x10056 00000003): stub
fixme:imm:ImmReleaseContext (0x10056, 0x8d9c00): stub
fixme:msctf:ThreadMgr_ActivateEx Unimplemented flags 0x4
fixme:msctf:ThreadMgrSource_AdviseSink (0x8d9aa0) Unhandled Sink: {ea1ea136-19df-11d7-a6d2-00065b84435c}
fixme:imm:NotifyIME NI_CLOSECANDIDATE
fixme:msctf:ThreadMgrSource_AdviseSink (0x8d9aa0) Unhandled Sink: {ea1ea136-19df-11d7-a6d2-00065b84435c}
fixme:win:EnumDisplayDevicesW ((null),0,0x33ef30,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33eac0,0x00000000), stub!
timer frequency:     10000000
target frame length: 166666
sleep resolution:    10825
loaded 2 controller mappings
wine: Unhandled page fault on read access to 0x00000050 at address 0x7bc48d88 (thread 0024), starting debugger...

(1 edit)

I am getting a stack overflow too. Tell me how to get a core dump from the appimage and I'll post it.

I'm on Linux mint 19.1.

Ok, a friend extracted the program from the appimage. And now it seems to work. There is something not right with the appimage container, if I understood correctly.

Developer(+1)

Hmmm it probably *is* something about my AppImage. I basically read how they work and construct one in a bash script. I haven't worked on this project recently, something I did may be deprecated now (or the mistake may not have affected me on my machine by luck).

Thank you both for letting me know, will get this fixed ASAP.

I think this means you can fix it just by taking the files you had in the appimage and zip them up as is. 
The user always need to give the binary file execute privileges though, standard fare on Linux so that's how it should be, just make sure to mention somewhere, in the readme or on the itch page, that it's in the bin folder. I am used to finding it in the applications root directory.

Even if a valid point. AppImage is a very handy way of shipping software :*

Hey! I've got a probably related bug when running it on ArchLinux: 

-----------
*** stack smashing detected ***: <unknown> terminated
Abandon (core dumped)
-----------

Ubuntu 20.04
*** stack smashing detected ***: <unknown> terminated

Developer(+1)

Thanks everyone! I've been working on PQ93 some this weekend, I'll have a bugfix release out as soon as possible.

That very kind of you... you know: we are not impatiente :D

Thanks for your work