Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Sky Rogue

A fwooshy, intense, procedurally generated fly-em-up · By Fractal Phase

OSX Issues - How to start?! (and Windows 10 too it seems)

A topic by uczmeg created Jun 09, 2020 Views: 802 Replies: 16
Viewing posts 1 to 16
(2 edits) (+2)

Running on MacOS Moiave 10.14.6 - The version in the charity bundle.

The game opens fine, allowing you to pick the language and once done you are prompted to press space to start.

This then shows your plane flying around to music, and getting into the odd skirmish. 

I can find no way to take over control of the plane. I do get a working hexagonal mouse cursor but that doesn't do anything.

Any suggestions on how to get it working much appreciated.


edit from developer: on Mac, simply move the game to Applications/ before starting it.

Having this same problem!!

Having the same problem with Win10 on the bundle version

same

+1

+1

Developer (1 edit) (+1)

Thanks for getting in contact. Could you please find a file called 

C:\Users\{your username}\AppData\LocalLow\Fractal Phase\Sky Rogue\Player.log
and send it to support@skyroguegame.com?

Also: I got an email from one particular Mac player who ran the game from their Downloads/ folder instead of Applications/. For reasons that are unclear to me, this caused the issue you describe and it was resolved by simply moving the game to Applications/ before starting it.

(+1)

I have Sky Rogue in my applications folder but I am still having this issue. 

(+6)

Confirmed: when placed in the Application folder the game works. Thank you

(+1)

I'm having the same problem on windows 10, any ideas for non-mac users to try?

Yes, that worked for me too (Mac). Thank you.

Developer

If you are on Win10, I would suggest you run the game from the itch.io desktop app (https://itch.io/app), I have been able to run the game in various locations without any issue but I would think the app would be the most reliable. Until I can get a player log from someone who is able to reproduce the issue that's my best advice unfortunately.

I can also confirm I had the same issue until I moved the app into the Applications folder.  Thanks!

For Windows 10 people, try putting the game folder in your downloads folder and run the game from there.  It worked for me!

same issue! MacOS 10.14.6...

Windows 10, moved my skyrogue into the downloads folder and it works great now.

Running from Applications on macOS 10.15.5 isn't working