Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

MewnBase

Planet exploration and survival game with base building. · By Cairn4

Can’t install on MacOS

A topic by vandanic created Jun 09, 2020 Views: 605 Replies: 11
Viewing posts 1 to 9

Downloaded via Itch.io today, the error message says the app developer can’t be verified. :(

I get the same message. 

Fix here: https://support.apple.com/en-us/HT202491  Scroll down to the last heading of the article.

(+1)

Still not loading for me on Mac. Catalina, version 10.5.5

I've already allowed it from unidentified developer. (I do that step all the time.)

It opens, bounces in the dock, shows a black dot for a second, then closes. I'm looking through system.log but I don't see anything related to it. 

Same as me... really wanted to play this.

(+1)

Here's the full trace log:


MewnBase launch args:
[LWJGL] Failed to load a library. Possible solutions:
    a) Install the library or the driver that provides the library.
    b) Ensure that the library is accessible from the system library paths.
[LWJGL] Enable debug mode with -Dorg.lwjgl.util.Debug=true for better diagnostics.
[LWJGL] Enable the SharedLibraryLoader debug mode with -Dorg.lwjgl.util.DebugLoader=true for better diagnostics.
java.lang.UnsatisfiedLinkError: Failed to locate library: libobjc.dylib
    at org.lwjgl.system.Library.loadNative(Library.java:299)
    at org.lwjgl.system.Library.loadNative(Library.java:205)
    at org.lwjgl.system.Library.loadNative(Library.java:187)
    at org.lwjgl.system.macosx.ObjCRuntime.<clinit>(ObjCRuntime.java:103)
    at org.lwjgl.glfw.EventLoop.isMainThread(EventLoop.java:85)
    at org.lwjgl.glfw.EventLoop.access$000(EventLoop.java:26)
    at org.lwjgl.glfw.EventLoop$OffScreen.<clinit>(EventLoop.java:30)
    at org.lwjgl.glfw.GLFW.glfwCreateWindow(GLFW.java:1842)
    at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.createGlfwWindow(Lwjgl3Application.java:450)
    at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.createWindow(Lwjgl3Application.java:394)
    at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.createWindow(Lwjgl3Application.java:380)
    at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.<init>(Lwjgl3Application.java:108)
    at com.cairn4.moonbase.desktop.DesktopLauncher.main(DesktopLauncher.java:62)
AL lib: (EE) alc_cleanup: 1 device not closed
(3 edits) (+3)

The game is now running when using this command instead:

cd /Applications/MewnBase.app/Contents/Resources/
java -Djava.library.path="/usr/lib/" -XstartOnFirstThread -jar desktop-1.0.jar

Adapt with the location of MewnBase.app.

Developer(+2)

Ohhhhh, interesting - thank you a_v_a.  I'm gonna try and modify the launcher config to include that library path and see if it helps.

I look forward to that because, like many others, it won't start on my Mac.

Developer

I've added that library.path argument to the launcher in the macOS build labeled 0.51 "unstable" - if anyone had trouble getting the 0.50 version of the game working on macOS, give that one a shot and let me know if it works for you!  (or if it still does the same) 😬🤞

(1 edit)

I'm having these problems with 0.51 unstable. EDIT: fixed it, not sure why this works but i moved it out of the little unzip folder and now it opens.

It works fine now!