🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Feedback: Merge object and tile function

A topic by ArtInPinkerton created May 11, 2017 Views: 118 Replies: 10
Viewing posts 1 to 11
(Edited 1 time)

Geod,

EDIT: Errors were result of bad rom and not the program.

Some feedback: I had a profile in the works for Castlevania that I was very happy with. However, I started trying to get fancy with the merge objects and tile functions and ran into problems that have unfortunately, ruined the profile.

1. When merging objects or tiles, it will not "highlight" or allow me to adjust that object without reloading. Sometimes it doesn't take at all.

2. Once I had done a few objects that way, the settings started to become unstable even in areas that had been thoroughly tested. Oddly enough, the sprites for the character, items, and critters were all OK (set to Char if it matters) but the background started readjusting then staying that way. I had two full levels done...and now the depths are a complete mess when it was rock solid before I tried using those functions. To be fair, it might only be one of them but I don't know.

3. Objects that use to be individual became "merged" with other objects on their own (e.g. column in the first level were seperate and I had them slightly protruding but after the glitches started, they became all part of the background.

After it started acting up I tried one of the other profiles I was working on, "Metroid - mOther" and it worked exactly as expected as did Faxanadu (although it freezes when the first text ballon/box pops up.

I'm super excited about the potential of the merge and tile functions.

- Martin

Hi, firstly thank you for the quick feedback. If you have some screenshots, the discussion will be easier and more concrete.

Those are advanced operations so make sure take it with care. And firstly we should understand the core concept of 3d presentation: "ShapePattern".

- Shape Pattern is an unique collection of nes tile which has its own 3D representation.

- Per frame 3DNes will analyses the frame buffer, segments it into instances of pattern (exited pattern or newly created one if needed) then instantiates all the instances/shapes.

- If if you create a new shape pattern manually, it's obviously will affect the whole game, not only at the location where it is created. All refereed patterns of tiles that create the new pattern will be delete and when you move to another scene, 3DNes will instantiate new pattern if it required to represent the new scene. That's probably the reason of your observation. So you it if it's the only solution to create the correct pattern.

- There is still an obvious limitation of the current mechanism. When the game has two obvious different shapes - from the human recognition point of view - that share the same set of tile then 3DNes is incapable of distinguish one from the other.

I hope you get some information from my bad English.

(Edited 2 times)

More Feedback: I tried to readjust the messed up levels hoping that once the merge and tile function was done, you could readjust and it would stick. But after reloading, the whole thing just went completely crazy. Most sprites are missing, it freezes up, if the character moves...I included the profile in the download if you wanted to check it out.

Screenshots

EDIT: I confirmed that the rom isn't corrupted (uses another emulator). Also, the program remembers the window size only for the splash screen then reverts back to the smaller default size.

- Martin

Thanks, I will analyse it. Don't say to me that you don't have a backup copy, don't you?

(Edited 1 time)

Of course not but I'll just remake it. I don't mind. The longest part was just learning the tool and how I wanted to achieve results. I'm pretty set now.

BTW, I think the bigger problem might be the merge function. I conducted a very simple and preliminary test.

1. I "merged" all the objects in the Castlevania 2 title screen (it's all one image visually minus the Konami logo). That bonked the profile after I reloaded. It might be I merged too much but 3Dnes definitely glitched. Three fourths of the title screen was missing on load.

2. I just "created" tiles (in tile mode) on the might and magic screen to separate out the NPC frame. It worked although it added to what I selected. The frame has a "demon" above it, it auto added that demon to the frame. I've added pics to the shared folder I already linked for reference.

- Martin

(Edited 3 times)

More Feedback: I think the tile selection function has a lot of promise. I worked really hard to try and see how I can make the Tile "create" mode work. I have the following observations.

1. Most importantly, the engine fights any changes any tiles you select and create. Its as if it is analyzing what you selected and then going I think you really wanted "this". After dozens of attempts to isolate individual block areas and such, 9% of the time, it added more to the selection or simply refused to make it its own object. POSSIBLE FIX: Make user input locked so that the software can't change any created objects unless they are deleted. In other words, restrict the software from making changes to user overrides.

2. Some selections don't take. I think this is related to the above as it's usually a tile near black or a different color. In this case, I tried making individual tiles near steps their own object so that the steps could be more their own shape. The program either simply ignores the override or changes it as soon as the game starts back up. An locked user override option would fix this too.

3. I'm not sure why but some tile layouts give an error upon reloading (Cannot not cast from source type to destination type) and completely corrupt the profile. EXAMPLE: I wanted to make the pillars in the first level of Castlevania separate objects. I could make the bases objects but the pillars wouldn't. So to trick it, I make the walls objects which then "automatically" makes the pillars objects. Additionally, I can make them stand out by creating 2 row of tiles in a pillar as an object then resuming game. At that point, the software readjusts my selection to make the whole pillar a separate object. However, the walls with windows (which show as a separate object now too) cause this error on reloaded. NOTE: I have tried many different combos of the above scenario and the error always comes after the wall with the window becomes it's own object. SEE THIS LINK FOR PICS

4. Have to hold SHIFT in merge and tile mode to multi-select is redundant and unnecessary. There are no other actions you can perform other than selecting tiles and unselecting tiles so holding shift is just an extra step. It would be much easier just to have as click to highlight and select all tiles needed and click again to deselect (in advent of accidentally selecting a tile which happens often).

The tile mode can really add some flexibility for us to make better profiles.

EDIT: I now keep backups of 3DN files so I can experiment so testing was fairly easy.

EDIT2: Sorry the screenshot for before I make edits is here

EDIT3: Lined out errors due to rom corruption and not software

- Martin

(Edited 1 time)

Hello,

First of all, i want to make sure we both are working in the same context. With the game Castlevania, without any manual adjustment. On my side, the screen is segmented as follow:

https://goo.gl/photos/PQL3Zt4DyPZkN4Hv7

I would like to repeat some info:

- The engine won't touch any pattern created by user

- By using Create, Merge operation you will created a new shape pattern and removing certain patterns in the process.

- Because of that after making those operations, you should forward the game some frames with the button > and >> so that the screen reflects the new, just changed pattern set and you can avoid the error message box.

- With your "demon" example, this is not your just created pattern but 3dnes had also created another pattern containing both the demon and the NPC. To separate the two shapes just manually create the demon pattern and if the mixed pattern still appears on the screen just select and remove it.

- I will continue to investigate the problem but i believe many things that you had observed are just normal behaviors of 3DNes, not bug or error.

- Please make sure to read carefully my explanation and if something isn't very clear just ask.

For the Simon Quest Wellcome Screen, i did exactly as you described, merge all shapes into one. Here is my result:

https://goo.gl/photos/6R8hnqrZBB3hpdRc7

After that, the game proceeds normally!

(Edited 1 time)

So I was perplexed why your results were so different than mind. The I realized that the only variable I hadn't tested was the rom. Turns out that my old stash of roms are degraded. While they worked for initial testing in other emulators, the longer I played glitches showed up. I tried a new Castlevania rom and tile mode worked perfectly. I'm sorry to have wasted your time on a red herring.

Martin

Finally i'm able to reproduce the error "Cannot not cast from source type to destination type" while loading an corrupted 3dn. Analyzing it right now.

I hope you can figure it out. I lost a Kirby and Donkey Kong Classic profile when it errored and I didn't know. Maybe adding a Backup folder to the 3dn folder that increment backups up to 5 or 10 copies back. It doesn't immediately error out when things go wonky so it's very easy to save the 3dn thinking it's all good only to have it break on load. 

- Martin