Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

KARLSON

Parkous-fps, Milk-Induced action shooter · By Dani

i cant open the game on mac os catalina, maybe because its 32 bit... i wanna play ittt

A topic by volpetarocca created 32 days ago Views: 710 Replies: 23
Viewing posts 1 to 9
(+1)

Pls halp ;-;

(+2)

Why does Unity even still have 32bit support for Linux and macOS? All it does is confuse people.

PLease Help  

(1 edit) (+1)

Managed to make it work.

Right click on the .app file (aka the game), click on "Show Package Content", it will open a Finder window, browse to Content -> MacOS.

Open the terminal and type "cd " (include the " "), then drag & drop the file inside the Finder windows (it will be a file with a white icon called Karlson).

At this point you will see a kind of long command, erase the word "Karlson" from the end of the command. (All of this is done to navigate to the same directory that Finder is in, but using the terminal.

Now type "chmod +x Karlson"

In case you see an error like "permission denied" try to use "sudo chmod +x Karlson", in this case you will be asked to enter the admin password.

Now type ./Karlson and the game should start!

If it doesen't because of the Apple security thing,  open "System Preferences", click "Security & Privacy", make sure to be in the "General" tab. At the bottom of the window you will see a button saying something like "Open Anyway", and red somewhere the name Karlson and the reason why it has been blocked (aka being downloaded from the Internet).

Now the game opens and runs!

ill try thank you!

(1 edit)

for me when i tried the "sudo chmod +x Karlson" command it says that there is no command found. what do i do?


nevermind i didnt read properly and i added the " to it

(1 edit)

nope, it says no such file or directory

(2 edits)

You probably messed up the cd command.

Make it simple, move the .app (well it's actually a folder but who cares) file on the Desktop.

Open the terminal and type this: "cd ~/Desktop/Karlson_mac.app/Contents/MacOS/", press enter.

Then type "chmod +x Karlson" (if it says permiossion denied try "sudo chmod +x Karlson"), press enter.

Then type "./Karlson" (probably going to ask you about security, open System Preferences -> Security & Privacy -> General and click "Open Anyway"), press enter.

Should run now.

Once you do this and it runs, simply double clicking on the .app will work.

Could you please post a screanshot of it please i still cant get it to work

(2 edits)

Step 1: Move the game (.app) to the Desktop.

Step 2: Open the terminal and paste this "cd ~/Desktop/Karlson_mac.app/Contents/MacOS/", then press enter (don't use cmd+v, right click and select paste).


Step 3: Now type "chmod +x Karlson", then press enter.


Step 4: Now type "./Karlson" (this will try to open the file, but since it's an executable downloaded from the Internet, macOS will complain, and a window will pop up, press "Cancel").


Step 5: Now open System Settings (press `cmd + space` or however you want to open it, click Security & Privacy, and make sure to be in the "General" Tab. On the bottom of the window a "Open Anyway" button should be present, click it.

Step 6: Now a new confirmation window will pop up, press "Open"


Now the Unity configuration window will open, choose your configuration


Finally press "Play!" and the game will successfully start


From now on simply double clicking on the .app file will make the game run.

so when I do ./Karlson it says no such file or directory is there a fix?

You are in the wrong directory, and the file is not there, that's why you can't open it.

Did you copy the step 2 command correctly?

When  I do "cd ~/Desktop/Karlson_mac.app/Contents/MacOS/". It says, no file or directory. Even when I drop the file in.

Sorry, way too late, youre spelling the directory right.

Did you change the name of the .app file? Is it in the desktop? Did you extract the game from the .zip archive?

IT WORKSSS THANK YOU!!!

sorry for stealing your time!

last ask does this work with every app with this problems?

(2 edits)

Not every app, but might solve the issue whenever you get that error.

If an app is 32 bit and you try running it on Catalina a different message will pop up saying that the developer needs to update the app (and you will see a different icon that usual).

(1 edit)

You mixed all the 3 commands, check the other reply, should be easier to follow.

THX but how does this whole thing work for the farty rocket game

(1 edit)

It works in the same exact way, you just need to change 3 commands (since 2 file/directory names change).

Step 2: type "cd ~/Desktop/Mac.app/Contents/MacOS", then press enter.

Step 3: now type "chmod +x Farty\ Rocket", press enter.

Step 4: Finally type "./Farty\ Rocket", press enter.

All the other steps are the same as Karlson (remember to move the game .app onto the desktop before doing anything). After doing this once it will open just by double clicking.

If you don't know what those steps are, refer to the previous reply with that sort of little "tutorial" that I made.

(1 edit)

jajajajaja thank you so much!!!

we need more people of you in the world!!

"sudo chmod +x Mac"  this doesn’t work 

btw im a pretty big noob in this category 

"chmod +x " is a command that can only be applied to an executable file in Unix like system to allow the current user to run it...

I don't know what is that "Mac" element, is it a file or a folder?

User wjuefjebf has found a potential fix: