Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Empire Deluxe Combined Edition

The latest in the classic Empire Series of games, which has spanned almost five decades. · By Killer Bee Software

EDCE won't open in MacOS Catalina 10.15.1

A topic by epo01 created 25 days ago Views: 29 Replies: 2
Viewing posts 1 to 3

Did a backup, wipe and install of MacOS Catalina. Just tried to install EDCE and it won't open but gives no further details. have looked for install instructions to see if I missed anything but can't find anything specific to MacOS. 

Erm, help!

Developer (3 edits)

That is interesting as I have a user on steam using this version and even though Steam has a general warning about it, it worked fine. - so I had not researched the issue.

The game does create both a log for Unity and a log for the game program itself  I am not sure where Mac would put the Unity log (which is probably what we need), but the game logs are in <Game Data Directory> /logs . I suspect the Unity log is near the actual binary package. I would be curious if there as any output at all.

Is there anyway you can look for them?

Evidently, this may have something to do with Apple insisting devs have their apps signed by Apple, even if the app is functional otherwise.  Your PC is becoming a console. That sucks.


Do me another favor if you have a Steam account, and see if you can get it running via that means (I suspect you can).


send me an email at mok@killerbeesoftware.com and we can discuss more as a solution will need testing.

--Mark

After some research I have found a fix. Doing this bypasses MacOS security so only do this for applications you can trust

I downloaded a fresh copy of EDCE for Mac (just in case) and extracted the app from the zip file. I moved this app to the /Applications directory.

Then in Terminal I typed the following command line

chmod +x /Applications/EmpireCombined.app/Contents/MacOS/EmpireCombined

Following this the icon in /Applications is double clickable but will not run because the developer is unknown. 

Click cancel in that dialog and immediately open Preferences. 

Open Security and Privacy and navigate to the General tab, in the lower part of the window there will be a remark about the developer of Empire Combined being unknown. 

Click "Open anyway" then click open in the resulting dialog box and you should now be in business.