Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Hexsweeper

Minesweeper on a hexagonal globe. · By tomatron

Test Bug / Let's PLay

A topic by DotGhost created Jan 28, 2017 Views: 205 Replies: 5
Viewing posts 1 to 2
(1 edit) (+1)

I absolutely love your rendition! It's beautiful, the choices of editing colors with an XML file is great and everything's labeled for easy changing. I did a let's play on your game to showcase not only the game but a test bug that I came across.

Bug: When starting game, the choices for Size and Difficulty are pre-selected to Small and Medium - the other buttons work on hover / can click but do not select, the choices stay at Small and Medium on the GUI (showcased in video bellow). Hope this helped and I can't wait for your finished versions!

Let's Play-Test:

Developer

Hey! Thank you so much for playing! And especially for making a video about it! I'm glad to see the color customization being utilized.

As for the bug you mentioned, that was actually an intended behavior as this particular build of the game is technically a 'demo'. This game is a bit older and I've I don't have the development environment set up anymore. So I'm going to try and get the development environment set up again and see if I can unlock those options. I'll let you know if and when when I've done that and upload a new version.

Thanks again!

Of course! Yeah, the customization of color & size and mouse buttons worked perfectly.
Ok, that's great to hear it's working properly then :), I wasn't sure as the other options seemed like they worked.
Ah ok sounds good to me, can't wait to try it!

Developer (2 edits) (+1)

Hey! I've made a few updates and pushed them up. The latest version now has the other sizes and difficulties unlocked. A Large board on Easy is pretty interesting. You should also notice the version in the menu now says 1.0. I've also added new input - now you can do left+right click instead of middle click for highlighting/revealing adjacent cells as per another player's suggestion.

Let me know how it goes!

(2 edits) (+1)

Awesome!
Just downloaded and tested 1.0, and it looks great with the different sizes/combinations. The large board and easy difficulty was really cool to watch as huge blank sections opened themselves up (as well as large on hard when you hit a mine, it's red encompassing was still just as beautiful to see); and small board w/ hard difficulty had its challenge too.
I also copied the pallet & config files I edited from the alpha to 1.0 and all worked perfectly.
The left + right click worked just as the middle click would.
One small thing I didn't notice, that I missed in the alpha as well, was in the menu's how-to-play instructions for the Middle Click - you have "...a 'relealed' cell."
This is still a beautiful game :)

Developer(+1)

Oops, haha. I will remember that for if I make any additional updates. Thanks for the insight. Let me know if you see anything else!