Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Nimble Kick

Kick sampler plugin typically used for Hardstyle. · By Nimble Tools

Mac sees Nimble kick as spam and cant open in Ableton

A topic by merijn.s@live.nl created Oct 15, 2019 Views: 239 Replies: 16
Viewing posts 1 to 7
(3 edits)

Hi, 


Since updating my mac to Catalina 10.15, I get this message...

"Nimble Kick.component" could not be opened because Apple could not check the file for malicious software.

What can I do, im so bad with computers so I have to reach out to you.. 

I got the feeling Nimble kick slow Ableton down allot, I cant add the crash report here for some reason?! 

And now the plugin is out of the project and can't open anymore, this is so frustrating.. 

(3 edits)

Have you updated Nimble Kick to 1.0.2 yet?

Also, try this: go to "System Preferences > Security and Privacy > General" immediately after you get that error, you might see a button there to allow Nimble Kick to run.

(In any case, even though it should work in most situations, I'm going to make sure it works 100% on MacOS 10.15 soon.. Apple made it quite a headache unfortunately.)

Yes I updated to nimble 1.0.2

It worked! thankyou for helping out man! 

Hey, can you specify what exactly helped you fix this? The system preferences thing? I saw your other reply too about it not working but didn't have time to reply to it yet.

Hi! I just got a new MacBook with Catalina and I'm having this same problem. After reading this thread I tried the 'open anyway' in security preferences. This worked for the AU, but not the VST. I prefer to use VST if I can incase woking on projects with people who are windows based. Any ideas on getting the VST version working? Thanks, John

Thanks for the reply, I already got it fixed, I forgot how I did it but thankyou for the help! 

(1 edit)

Hmm interesting, I think it worked for me with the VST too. I'll have to look into this a bit. Are you sure you don't get the "open anyway" prompt after trying to load the VST?

As a workaround, you can try opening terminal and typing: "sudo spctl --master-disable", which will unlock and select the "Anywhere" checkbox in the MacOS security settings, which should disable that security altogether. Not a great solution I know (actually bad security advice), but it might help.

I've tried that 'open anyway', but when I click it it doesn't do anything. I've had this problem trying to install a bunch of VST's today and the 'open anyway' worked for most of them actually, but unfortunately not nimble kick or misstorion. Strangely it won't see nexus VST at all. But they all work in AU, so it's not a huge problem got forward, just a pain when reopening half finish projects etc.. so something I want to get to the bottom if possible. 

My old Mac book died at the weekend and new one came with Catalina which is a completely nightmare at the moment tbh 😩

Yeah I feel you.. Catalina is quite a nightmare for developers as well. They changed a lot about application security which made everything a lot more complicated (and expensive).

Hi! I have the same issue and "open anyway" does not seem to solve it unfortunately. Cubase keeps prompting for the same error message even after I click it.  Has anyone found a solution to this since the last posts?  Looking forward to using the plug in :-) 

Which error are you seeing exactly? And which version of MacOS are you on?

MacOs 10.15.2 - I get this error :

“Nimble Kick.vst3” can’t be opened because Apple cannot check it for malicious software.

This software needs to be updated. Contact the developer for more information.

I'm still working on it. Apple is not really cooperating unfortunately, so it's going to take some more time. Have you tried the temporary workaround yet that I posted earlier in this thread?

As a workaround, you can try opening terminal and typing: "sudo spctl --master-disable", which will unlock and select the "Anywhere" checkbox in the MacOS security settings, which should disable that security altogether. Not a great solution I know (actually bad security advice), but it might help.

Thanks, no, I have not tried it - to be honest I had missed it!I prefer not to mess with Mac Os security. Happy to wait for the update once the issue is resolved.

Hey just chiming back in on this with an update. For me the VST still doesn't work but the AU is fine so I've just been using this. 

However I've been having this same issue with a bunch of things, one full application just will not open in Catalina despite being the version that is Catalina compatible for this exact same security reason. I got pissed off and disabled the security in terminal and its not nearly as scary as it sounds. All its doing it adding back in the "Allow" apps download from anywhere back in to the OS that they removed in a previous update. In fact it's not even adding it back in, they just removed the option to choose it!!! (see screen shot attached)

You can just hit any of the above setting and it will revert back to the standard Catalina options. Again I wouldn't "recommend" it to someone so not to be responsible, but if you're not downloading extremely dodgy apps, this is how I used to run OSX anyway. I spoke to Sam Audiofreq who suggested this to me, he's be using it like this fine and since I enabled it, literally all my problems have gone away lol!

Here's an article how to do it. Very easy and even easier to revert if you get cold feet.

http://osxdaily.com/2016/09/27/allow-apps-from-anywhere-macos-gatekeeper/

Thanks for protecting me from productively using my computer Apple x

 

Thanks for the update! Btw, I am fan :-)