🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Is there a fix for the lag I get?

A topic by Error-Chan created 273 days ago Views: 1,443 Replies: 13
Viewing posts 1 to 11
(+1)

I use a old Windows 7 laptop and I seem to get a lot of lag when I open the game. Is there any fixes or settings I can use to make the game more smooth? because at the moment I cant play the game at all.

I really love the look of the game and donated to help but I hope I will be able to play it after all.

I have the same problem, it's such a pain to play the game when even when I look around l lag. It's very hard to start out when you have the hook, l had to jump off the raft and grab items, even then l would have key delay and wouldn't pick them up.

I'm assuming you've already minimized all of the video settings?

In any situation where there is graphical delays it's mostly resulted from the lack of hardware. I play on full settings and I get a constant 120 FPS (since that's the cap). I also do have the latest hardware for my PC, and I can also stream/record fine.

Also, if you post your specs here maybe that would help, but ASFAIK laptops aren't that great for handling graphics.

(Edited 2 times)

A workaround would be to:

  1. Set graphics settings to the very minimum
  2. Reduce the screen resolution of the game (It'll look like garbage, but it should bring the graphics requirements down to around Portal 2 levels)
  3. Wait for the devs to implement a mouse sensitivity option (which really ought to be in the game anyway)

Sadly 3d Unity games tend to not be very well-optimized. There are far more performant ways to implement the mechanics present in this game. Oh well. Props to the devs for the game mechanics.

Thank you, everyone.

As for my laptops specs, I am pretty useless at things like this but this is a link to the info on my laptop: http://www.toshiba.co.uk/discontinued-products/satellite-l670d-13f/ if someone with more knowledge in computers can see that it's my laptop being rubbish then do let me know haha.

other than that I have tried it on all the settings avalabel and none have really improved it enough to be played.

I'm not surprised you can't run a game like Raft with those specifications. That thing was probably made like 7 years ago around the time Windows 7 was still brand new. Heck, I'd be surprised right now if you told me you can even run Minecraft with decent FPS.

Your system memory also seems like it's limited at 2GB, and overall everything just seems very outdated due to the age of the laptop.

Well that's why i thought the game would work as Minecraft and World of Warcraft work completely fine on here. I'm not a gamer so I don't have the best and newest thing going XD I spend my money on my hobbies and use this laptop as the large screen is nice for my digital art.

Your GPU is decent considering its age, except for the fact that it doesn't have its own on-board memory.

One of the consequences is that your GPU needs free RAM in order to work. Assuming your GPU needs the full 512 MB and the game itself needs 100MB, and rounding up to be safe, you will need to check Task Manager and make sure you have 700 MB of free RAM. On your system, that probably means no other programs should be running.

Another consequence is that your GPU's speed is bottlenecked by how fast your computer can move memory from the RAM stick to your GPU. This can really kill performance, and unfortunately there's no way around it.

Ah well.. I will keep an eye open if they do make a version that can work on something like my system will just go back to Minecraft as that one works fine.


Thank you all for your help.

After some FPS testing, I've found that the water effects take up a lot of resources. I bet if those could be disabled, they would double your framerate. (Source: me playing Raft on my 8-year-old laptop, and seeing the framerate double after I build the walls)

Hey Guys.
I found out that i only suffer those frap drops when my Laptop runs on battery. When I plug it in it runs with 30FPS straigth.
I don't know if this might help some of you. I find this a little bit wierd :D

That's normal. Windows laptops by default have battery settings that reduce power usage while not plugged in (computer hardware consumes more electricity when it's working harder). Clicking on the battery icon near the clock will lead you to more settings you can explore.

1. Go into your computer power management and set it to "Best Performance"

2. Turn water quality to 0

3. Get a better computer ;)

Water quality? Wut? Oh wait, there's a new update! Sweet!