Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Nimble Kick

Kick sampler plugin typically used for Hardstyle. · By Nimble Tools

Not working in studio one

A topic by Geoffreyvan_berkel created Sep 21, 2019 Views: 201 Replies: 13
Viewing posts 1 to 6

Hello, bought the legit version today.  I can see it in studio one under my instrument section but when i try to drag it to an instrument track notting happens. Any clue why?

Kind regards,


Is this on Mac or on Windows? (If Mac, are you using the VST3 or the AU version?) I don't have Studio One myself, but I might be able to activate a trial to test it..

I know there are some issues with drag and dropping samples in the Mac version on FL Studio, which I still have to look at.

Hello, its mac and i am using the au version

I can confirm that both AU and VST3 works fine in the newest version of Studio One 4 :).

AU and VST3 also working in Studio One, macOS 10.12.6

Good to know, but it stil doesn't work. I can also only see the au version in my instrument section. The vst3 is nowhere to be seen even if i put it in the vst3 map. Any other suggestions?

Which version of Studio One are you using. And are you using 32 bit of 64 bit?

Go to Studio One in the left corner and click on about.

Hello, its studio one osx x64. I tried opening the nimble kick in the 32 bit modus but then i couldn't find it under the instrument section.

That's because I'm only shipping a 64 bit version of the plugin on MacOS. (They're actively deprecating 32 bit applications on the latest versions of Mac.)

Have you tried updating your version of Studio One yet?

Hello, its a stand alone so its quit hard for me to update. But do you think that has would have any effect? I have bought some other plugins recently and they seem to work fine.  

Updating could potentially help, for sure. Can you check for any log files in "~/Library/Application Support/PreSonus Software/Studio One 3"? They might reveal why the plugin doesn't load.

I am on holiday now but will check when I get back home.

I don't know if you got it working but if not, VST3 plugins works only if they are installed in the default folder. FL Studio and Cubase will not show any VST3 plugins that are installed outside the VST3 folder. However, I'm not sure if Studio One works that way but in any case I believe this is worth mentioning.

Thank you, studio one works the same so I installed the vst3 in the vst3 map.

moved this topic to Technical support