🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Wont run.

A topic by RobotLord10 created 239 days ago Views: 671 Replies: 25
Viewing posts 1 to 11
(Edited 1 time)

So I just bought the game and installed it with the correct bit but when I clicked launch it said an error occured while launching Mewn Base. Please help!

Nobody can help without details...

What's your system, and what's the exact messages you got back? (copy paste!)

Developer (Edited 1 time)

Hey RobotLord10, sorry it's not launching from you :/ Got a few questions/steps that'll help me narrow down what might be wrong:

  • What OS is your computer running?
  • Did you download the game from the store page, as a zip file? Or did you download and try to launch it via the itch desktop app?
    • If from a downloaded zip file: try running the executable (e.g. MewnBase.exe, if Windows etc) from command line if possible, it should spit out the actual error message.
    • If the later (itch app) does the error message give you the option to "Examine the Cause of Failure" - if so, try clicking that, it should open up a log text file - and if you'd be so kind, email the the contents over to cairn4games@gmail.com - would greatly help me figure out what the issue is so that I can try to get it fixed for you (and probably some other people as well).

- Steve / @Cairn4

(Edited 1 time)

I seem to be having the same issue that RobotLord10 was.

On Windows 10; tried with the standard, Java, and win32 zip files; none worked. Nothing happens at all after double-clicking the exe (or the Java executable). Attempting to run from the command prompt, as suggested, returns no message whatsoever.

I also attempted to install it through the itch app (both standard and win32). When launching through that, clicking the launch button, and the 'play now' button in itch's mini-launcher, I briefly see 'running' in place of the launch button... for less than a second. Then it goes back to showing the launch button, as though nothing had happened.

Itch didn't return an error message during this process, and no log files were apparently generated in the unzipped mewnbase directories. However, the view logs function in itch did give me some errors; have a pastebin of the log: http://pastebin.com/j8Yeg2ye

Hope that helps!


EDIT: Nevermind, figured it out, and got the game to run. As the log file implied, it was a driver issue. The short version was that I needed to update my graphics driver. The long version is that I needed to do that because Windows 10 likes to randomly and silently downgrade your graphics driver during its update process... and the way it does that incidentally disables NVIDIA's own driver update app. This is an ongoing, and recurring Windows 10 issue, though I may have figured out how to stop it from doing that, this time.

That said, it'd have helped me troubleshoot if your game were able to notice the driver issue and give me an error message upfront, instead of dying quietly.

Developer

Hey Endovior!

*phew* glad you got it working - these are the sorts of issues that tend to stress me out the most, since their hardest for me to reproduce / easily fix.

Thanks for sending that log file! Like you said, having the game throw some sort of error popup if the game flat-out fails to start would be a great idea, I'll try and see if I can do that.

Cheers!

I just need a clear run through on how to download the game.

Developer

Yes, I understand you just want to play asap, but without providing any sort of information besides "I get an error" - it'll be hard for me to help you.

Thanks for sending over that log file. Since it doesn't seem to be launching from itch.io, try downloading the game from the store page: https://cairn4.itch.io/mewnbase -> the mewnbase-win.zip (or win32 if you're on a 32-bit machine)

Unzip, and run MewnBase.exe - that should be all there is to it.

I kind of found out the problem. I found out that the Mewn Base game wasn't compatible with my windows 10 computer. I'm not sure how to make it compatible. So I was wondering if you know how to do that. I think if we figure out how to make it compatible then the problem would be solved.

Developer

So you tried running MewnBase.exe from both the mewnbase-win.zip download, as well as the mewnbase-win32.zip version, on a Windows 10 machine and neither of them would start for you? Do you know what sort of video card your machine has in it?

If you previously tried downloading it via the itch desktop app - try uninstalling and reinstalling the latest win32 version. (Which sometimes fixes a issue with the game sometimes not being able to launch).

Finally!! I went back to uninstall the Mewn Base game I had downloaded and installed the 32.zip one and I worked!! Thank you for your help. :-)

Developer

Nice! Glad that you'll finally be able to play it :D

Enjoy!

i cant get my mewnbase to run it wont give me a error message either please help

Developer

When reporting issues like this, please tell me what OS you're trying to play it on (and which zip file did you download). Have you tried running it using the Itch Desktop App? Can you try running the executable via command line to see if any errors are printed out in there? I need more information in order to try and help.

Im on winows 10 i tried the win-32 file but that didnt work and yes i tried the itch app and how do i do the executable via command line

Developer

Actually, if you have the itch app installed, try this:

Open the MewnBase page in the app. You should see the red "Launch" button, "Uninstall" options etc on the right side of the screen.

Near the bottom one of the buttons should say "Version 0.30 (mewnbase-win32.zip)" -- Right click on that, should open a little context menu -> Advanced -> View Logs...

Email me the contents to cairn4games@gmail.com - and I'll take a look asap to see what might be going on.

Thanks

ok i sent them

Developer

Thanks! Main symptom of the issue looks like it's here, near the bottom of that log file:

err: Exception in thread "LWJGL Application" com.badlogic.gdx.utils.GdxRuntimeException: OpenGL is not supported by the video driver.
[2017-01-23 @ 15:24:10.262] [tasks/launch/native] err: at com.badlogic.gdx.backends.lwjgl.LwjglGraphics.createDisplayPixelFormat(LwjglGraphics.java:322)

A quick search recommends a couple things:
Try just giving your machine a reboot, and run the game again.
Try updating your video card drivers in Windows.

There's also a few posts on StackOverflow that suggest allowing the game to run in SoftwareOpenGL mode - In a couple hours, I can put that into a quick build and email it over to you so you can see if it works for you.

yeh that would be great if you would do that

Developer

Emailed you a build to test out with "allowSoftwareOpenGL" enabled.

Hey it was just my computer it still doesnt work but i used it on my other computer and it works thank you for your help

Hello Cairn4,

I saw mewnbase on Youtube and immediately downloaded it. But, alas, I cannot play it. Everytime I run the mewnbase.exe it creates an error log stating an EXCEPTION_ACCESS_VIOLATION (0xc0000005) (see one of the logs here https://dl.dropboxusercontent.com/u/33821854/hs_err_pid2412.log) (my computer specs can be found here: https://dl.dropboxusercontent.com/u/33821854/Specs.txt)

the error occurs whether I use the win32 or the win version. Using "the app" proved fruitless as well.

Also, uninstalling and reinstalling the Java environment did nothing to help

I hope you can help me out!

Thanks
Developer

Hey DrNoodles85 -

Oy, sorry that it's not working for you. But thanks for sending those log files. I've seen similar crash reports from a couple other people. The top line of the Java Frames section:

 org.lwjgl.opengl.WindowsContextImplementation.nCreate

... seems to suggest to me that it's having trouble creating the OpenGL context. Search results for that line always brings a bunch of Minecraft bug reports, in which the usual recommendation from people say to try updating your graphics card drivers. So that might be something you want to give a try? I'd have a hard time believing that an Alienware M17xR4 hardware wouldn't be able to support OpenGL haha

I know it's not the most convenient thing to test out, but not sure what else I could suggest at the moment (besides the 'ol Turn It Off and On again). If you try updating your drivers, let me what happens.

Random other idea: see if you can force your laptop to use it's dedicated graphics instead of the integrated Intel HD 4000 one?

(Edited 1 time)

hello my game won't launch I looked on the system log shows this unterminated quoted string I'm running Linux 32bit

Developer

Hey - sorry, forgot to reply to this the other day. The previous Linux version was 64-bit only, but over this past weekend I added a 32-bit Linux version of the game. Try giving that a shot and see if it works for you (fingers crossed).

Cheers

ok thank you I'll let you know if it works

got it working thank you for helping me