🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Microsoft Visual C++ 2015

A topic by fort447 created 249 days ago Views: 418 Replies: 8
Viewing posts 1 to 7

Aven Colony refuses to acknowledge that this IS installed.

Developer

There are multiple versions (or updates) of the Visual C++ 2015 runtimes - so if you're having problems, I can only assume that you don't have the correct one installed. The best way to make sure that you have the correct versions is to run the UE4PrereqSetup_x64.exe which is inside Engine\Extras\Redist\en-us assuming that you downloaded a ZIP (and extracted the game somewhere!)

We actually recommend that that people download and install the game via the itch.io desktop app though. It works similarly to Steam in that it downloads and installs the game for you, keeps it up to date - and, most importantly, it will automatically perform the above step!

I'm having similar problems. I just downloaded the latest itch launcher and downloaded the game through the launcher. When you go to launch the game, it prompts to install Microsoft Visual C++ runtime, so i click yes. That brings up the UE4Prereq x64 Setup. And that installs successfully. And then nothing happens after that. You go to relaunch the game, it prompts again the C++ requirement, and sends you into the UE4Prereq setup again, this time you can either uninstall it or cancel. Just wondering what i'm doing wrong.

@ pratticus26 that's exactly what was happening to me. It ended up being different updates that weren't installed. It took a couple of days searching the internet to get the right updates. The first one, I had to let run for over 12 hrs. That one, was the fix for my update problem. After that I was able to download a ton of updates, one of them worked, I don't know which one. That is one of pet peeves about tech, "say what you mean." Don't run some BS message that is totally unrelated to the problem. There is a web site I will never use, because I tried accessing my account with my phone, and kept getting a "incorrect password" message. The fact was that Yahoo was never going to let me access the site from a mobile device (morons, that's why they will go out of business). Instead saying F You, your never going log in for a phone, they say "wrong password" WTF. Anyway it's probably not about Microsoft Visual C ++, just like my problem wasn't. Say what you mean!! Don't BS me.

What where the correct updates? if you dont mind me asking, i am having the same issue.

I had the same problem. Went to the Microsoft site and typed in Microsoft visual c++ 2015. Found an redistribution update, first one on the list. It was update 3. I downloaded it for 64x and restarted. Game works now, I have windows 10.

(Edited 1 time)

I believe it was "Windows6.1-KB3172605-x64.msu" or "Windows6.1-KB3048761=x64.msu" I don't remember which one it was, think it's the first one. Let me know if it works I have a third file that might be it also.

im having the same problems on windows 7. we have made a purchase from this company, is there no cutomer support on this issue?

(Edited 1 time) (-1)

Note for vcredist issues

1) reboot your computer first

2) go to Aven Colony Beta\Engine\Extras\Redist\en-us

3) run UE4PrereqSetup_x64.exe

4) ensure no errors pop

5) reboot your system again

VCredists require reboots after installing. If you don't reboot the installer will fail catrastophically