Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Escaped Chasm

​A small little RPGmaker game about a lonely girl with a connection to another world that she sees in her dreams. · By temmie

Running on Linux

A topic by Luka Simić created Apr 03, 2019 Views: 1,947 Replies: 14
Viewing posts 1 to 7
(4 edits) (+11)

Since a Linux download doesn't seem to be available yet, here's how I got it to run on Linux (Wine didn't seem to work for me, as expected. NWJS never really worked well through Wine):

  1. Download NWJS v0.12.0 from here (or here if on 32-bit Linux, I guess).
  2. Extract the downloaded .tar.gz file.
  3. Download the Same Game but with RPGMaker icon download and extract it.
  4. From Same Game but with RPGMaker icon/Escaped_Chasm_Contents/Escaped_Chasm copy the www directory and package.json file into the folder you extracted from the NWJS v0.12.0 archive.
  5. Run nw from the extracted archive.

I'm on Manjaro Cinnamon 4.19.32-1. Hope it works on other distributions, too.

Edit: If the above instructions weren't very clear, here's a GIF of how it worked for me after downloading the files:


Edit 2: See my second post if you just want to make a simple fix and run the game through Wine.

Thank you for this. I can confirm that this works on Linux Mint 19.1

(1 edit) (+3)

Sent this to Temmie as well, but as she'll probably be trying to export the game for Linux there's a couple of things that won't work properly (based on exporting the game for Linux via RPG Maker MV myself):

  • In the exported version there's an executable named Game that seems to be using an older version of NWJS and crashes when the Start option in the main menu is clicked.
  • There's also a desktop launcher Game.desktop that doesn't seem to be working for me. Instead of the Game executable, it is supposed to launch the nw executable.
  • The nw executable actually works, but fails to load bitmap fonts due to an error in the Bitmap Fonts plugin. If this isn't fixed in Temmie's export, here's how to fix it:
    • Open the www/js/plugins/Bitmap Fonts.js file.
    • Replace ",a=!1){" with ",a){a=a||!1;" to fix incompatibilities with older NWJS versions.
    • Replace "Fonts/Bitmap Fonts/" with "fonts/Bitmap Fonts/" to fix the directory in which the plugin is searching for fonts. The reason this works on other OSes is that their file systems usually aren't case-sensitive, so a "Fonts" directory would be treated the same as a "fonts" directory, unlike on Linux. This also most likely fixes the crash when running the game through Wine.
    • Edit: If you're having issues with the custom font not being shown upon the first load of the game, additionally replace "return a}" with "ImageManager.loadBitmapFontImage('GameFont', t.meta.image.slice(0, -4));return a}".
    • Save the file.

It works on wine for me(I'm using wine 4.0) but it doesn't have sound and movies don't work , with your method I don't see the game for some reason, just this 

never mind it works now, I'm not sure what I did wrong before

You accidentally loaded the Escaped Chasm 2 easter egg instead of the default game.

I dunno if this topic is still alive, but i need help.

I did all that you said, but all that happened was this:

I need to know what just happened and how can i fix it, if it's possible, please. Thank you.

(1 edit)

Did you use the approach with fixing how the game runs through Wine or with using a newer NWJS version? Did you also try to use the other approach?

Try running

sudo apt install libgconf-2-4

in your terminal. After putting in your password and confirming by typing Y (May vary in your system language) it should install the missing library. At least that’s what did it for me.

Also judging by the borders of your window, your Ubuntu installation is outdated. you should upgrade to the latest version (20.04 as of now) when you can.

Huh. I was trying the native thing but I downloaded the game “manually” through the itch client, which initiated the installer, so I downloaded the recommended version through that and now it works out of the box with Wine 5.12. The borders are custom and scaling only makes things blurry, but other than that seems functionally fine.

(1 edit)

Doesn’t seem to work with the sanbox though.

All right, so it only works if you click the recent download button, not by any other means from within the itch client.

NVM, it also works by going to the library and right-click → launch.

Thank you so much ! Your advice is so detailed and useful, I'm glad I can play this game thanks to you ! If anyone else facing the same issue is cautious about using a download link directly from someone, you can find it here https://nwjs.io/   it'll be the new version of the program but it works exactly the same. Also for some reason clicking or double-clicking nw didn't execute it like in the gif (also I had permitted execution), if it does the same to someone else, just use the terminal to launch it.