🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Cannot Install

A topic by BlueClaws created Sep 08, 2016 Views: 958 Replies: 10
Viewing posts 1 to 6

I am new and this is my first time on itch.io. I very much wanted to play Aven Colony. I started by paying and downloading the game directly. It will not run, even after installing Runtime 2015 successfully. So I decided to try and use the itch.io app. After downloading, the app will not install. It says an entry point could not be located in the dynamic link library SHELL32.dll.

So not only is the stall file for Aven Colony not working by itself, but I seem to be incapable of using the app. Would it be possible to have a more clear set of instructions for installation of apps and games?

Admin(+1)

Hi,

As far as I can tell, you haven't done anything wrong while installing the game. May I ask which version of Windows you're using? If you're using Vista, itch.io/app isn't compatible with it, see this discussion thread.

As for the game, I'm pointing the developers at this comment so they can take a look at it!

Yes, using Vista. I may upgrade to 7 in the near future, but nothing I have seen about 10 compels me to use it.

(+1)

Hi BlueClaws!

Sorry to hear you're having this issue. If you could please do the following, that will help us track down the problem:

  • Find your AvenColony/Saved folder.
  • Compress that whole AvenColony/Saved folder into a ZIP file or RAR file.
  • Please e-mail that ZIP or RAR file to info@mothership-entertainment.com
  • Also let us know in the e-mail what OS you're using, and make sure to mention that you're BlueClaws so we know it's you.

I'm running Windows Vista Premium Home edition. I am in the process of updating, since I don't have automatic update turned on. I will try to email the file. Compressing it now. Just in case I can't send a file that large, I have tried downloading the game 3 separate times, all with the same results. Will try again once the updating completes.

Heya BlueClaws -- the game is built on Unreal Engine 4, which requires Windows 7 or 8 at a minimum.

So that would be your problem.

My apologies for not mentioning that on our itch.io page; I've updated that with the minimum system requirements now.

*sigh* Well, I've been refusing to update for a while now....guess it's about time. But yes, it would have been good to know that before paying. Thanks for responding so quickly and efficiently.

(Edited 1 time)

Well I have a related itch.io problem but mine is somehow different in some way..


I am using windows 10

Every time I try installing itch.io the latest advised version I get a Virus alert that blocks the installation, when I try Running it with Admins permission I get a windows 10 blue screen that windows haves to restart cause of installation issues ..

Either way I have bought the game one hour ago and simply am downloading it, but as I see it I should had waited for a Steam Version of this game...the itch.io App haves issues installing at least on my Rig and I do not even know if its needed to install the game ..I hope not or other wise what I have paid was a wasted 30 Eurs...for nothing more then issues in a Rig that haves lot more specs that this game and App require to be installed and played...


Another step back is that even if you bought the game already it doesn't have any value over the steam version, this means you will be forced to buy it again for a even higher value just cause I was dummy enough to believe in this system of your and in the end got Fulled and have nothing on my payed value...


The game is Beta...?!


OK but at least add it to buy when its working properly, itch.io is a App that haves lots of issues that can result in damaging my Rig...for what I see...



For all of this I am truthfully disappointed with the lack of info on this game install...

But then I guess I am not that important...just wished I have knew this before I bought the game...

(+1)

If your AV is triggering a false positive, you'll have to add an exemption into your AV. Also you should submit the exe to your AV for future white listing.

If you're getting a BSOD on the game installer that indicates a far lower level problem on your system. Games realistically cant cause a BSOD. The app is simply exposing an existing problem on your system. You should start by doing a full windows update on your system. If the system triggers a BSOD then the faulting kernel module will show up in the Event Viewer. Generally these are low level drivers such as graphics drivers. But the Event Viewer should show you what dll module caused it.

Hi there ..


Found out that the game works without installing it like an APP...Didn't manage to install the itch.io APP anyway...


My system was fully installed on the Windows 7 Ultimatum that I had before and haves a couple of Month ...Nothing is wrong with my Windows 10 install at all...Never had this problem with any App like this, also have installed Steam, Origin , that work on similar ways and no problems with them of what so ever...


Anyway I downloaded the game..Finally cause it takes an eternity ... and extracted it to the desktop and upon running the game exe the game worked like that !...


So far didn't had any problem with it this way ...Works like a portable Game ...

I was wondering if anyone could help me with my Itch.io application issue. When I open the "itchSetup.exe", or even attempt to "Run as Administrator" it does not run correctly. After a few seconds, an error box pops up entitled: " Installation has failed" and then says "There was an error while installing the application. Check the setup log for more information and contact the author." I have repeated the download multiple times, and each time it fails like this. I am using an IDM download manager, but I don't think that will mess with any of the files. Thanks for your help.