🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Odd pixel distortion is causing pixel art to look wrong

A topic by victoria lacroix created Aug 20, 2016 Views: 685 Replies: 6
Viewing posts 1 to 5
(Edited 1 time)

I'm trying to learn my way through this, and I'm making a decent amount of progress, but there's something that I can't get past.

I try to do pixel art, but when it's in-engine, it always seems distorted.

It comes out looking like this, when I created it to look like this.

I can't figure out how to make it not distort pixel art, and its making creating good looking pixel art difficult.

Is this my mistake, my browser's mistake, or an engine mistake, and if it's the first one, how do I avoid it?

(Edited 1 time)

I get this issue as well.


I don't know for sure, but I believe it has something to do with the engine and how it goes about scaling.

Have you tried messing with the screen ratio in the settings [ the width and height values ]? I think fiddling with these values may help a bit.


Again, though, I'm not really sure how to fix this. Would love one of the devs to go in depth about how Superpowers does its scaling.

I've yet to go into depth about this, but I'm pretty sure the 'Pixels / unit' property on your sprite assets are where you need to look. As Spencer said, the screen ratio factors in I think

Follow up, I still haven't found the ideal solution, which is pixel-perfect scaling.

Changing the sprite filtering to smooth instead of pixelated stops the distortion, but it's also very blurry looking. With pixel art, this looks like hot garbage, but if you use higher resolution assets, it's fine.

Also, when the sprite's transparency is set to Opaque, it looks really bad, but it's fine with transparency on.

But it looks pretty okay and doesn't have the ugly distortion issue, so... I guess it works?

My conclusion: When it comes to Superpowers, 256x256 is 8 times better than 32x32.

(Edited 1 time)

Would you mind sharing your project or at least one with the specific problem? that way i can replicate the result and see if i can help.

Here's a quick thing with a tileset made to be 16x16, at 16x16, 32x32, and 64x64 for scale.

I'm using 1.1.0, the portable version as packaged here, but the problem also exists in 0.19, 1.0.0, and 2.0.0.



Ok, i tried the project but i dont really see anything weird with the tiles, do your project look like this on your pc? i also tried using the tile i think you show on the first post but still not notice anything, here is how it shows to me.