🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

[Solved!] Binary to YAML conversion: type unsigned int is unsupported

A topic by SebasRez created 309 days ago Views: 950 Replies: 3
Viewing posts 1 to 4

Hey Kai,

For some reason when I import the asset from here it says

"Binary to YAML conversion: type unsigned int is unsupported"
as well as
"Binary to YAML conversion: type UInt16 is unsupported"

any ideas what this may be?

Developer

Hmm I tried looking it up and only found other people talking about it happening while importing assets. Just to check, you're using Unity 5.3.2+, right? Maybe it's a version problem?

I'm reading that it might have to do with "Force Text Mode" being enabled under "Asset Serialization" in "Edit > Project Settings > Editor". Try changing that setting to "Mixed"? This is just my best guess.

Using unity 5.3.5. Mixed seems to work, hopefully that does the trick, thanks!

Hi,
First of all, great asset!
Just to add a bit more precision, this does indeed happen when you import the asset with the serialization setting set to 'ForceText'. Changing it to 'Mixed' with the asset already imported will get rid of the errors but all builtin content (Gradients, etc.) won't work. The trick is to set the serialization setting to 'Mixed' before importing the asset and then set it back to 'Force Text'. Then all the builtin content will work.

Just thought I'd save everyone the 5 mins it takes to figure it out. :P

Btw it happened to me on 5.5.0f3.