Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

PixelCNC: Handy 3-Axis Mill/Router Toolpath Generation For Images!

A radical new CAM program for CNC artists to generate original and interesting toolpaths from 2D images! · By Deftware Industries

Help launching PixelCNC

A topic by MacboyCanada created 89 days ago Views: 180 Replies: 35
Viewing posts 1 to 4
(+1)

I’ve just purchased (didn't see the trial wayyy at the bottom of the page until it was too late) but unfortunately the software does not open. I first get a message saying “Search for App in App store? You need to install an app for this task”. Whether I click Yes or No (Yes doesn’t take me to an App store or anything) I then get the Early-Access Disclaimer. Clicking “Yes” here begins to load the software but an error pops up - “sys_glfunc: function not supported: glActiveTexture”. Clicking OK the software seems to continue to load but then just quits completely.

This happens whether I try to launch v1.20 or v1.21. Where can I look for assistance trying to get this software to run for me?

Developer

Hi Macboy, thanks for taking an interest in PixelCNC. What kind of computer are you trying to run PixelCNC on ?

Im super excited to see this in action, hopefully we can get it to run. Thanks for getting back to me. It's a Dell Latitude E6410. 2.4Ghz processor, 4mb RAM, Windows 10. I believe it's running 32 bit? (I'm a Mac guy and only have the PC for running Estlcam). I know how to find stuff if you tell me what you need to know and kinda how I can find out. I saw some references to graphics processor issues but not sure what this machine has inside.

Developer

Well looking at your machine's specs it should be plenty capable of running PixelCNC. The OpenGL rendering function error is a red flag to me indicating that something specific to the Windows installation on your machine is not properly configured, or that some kind of software is interfering with normal program operation. The function the error mentions, 'glActiveTexture', is something that 20 year old graphics hardware supports, so it could very well be a driver issue with your system.

The problem with Windows complaining about not knowing how to open a common everyday program EXE file indicates that something has taken the liberty to interfere with your Windows installation. It could be a virus, antivirus, or some adware/malware that tried to work its way into your system, or possibly has worked its way in.

Since it looks like PixelCNC did eventually run, in spite of the "search for an app" problem, and wasn't able to properly initialize OpenGL, I think there's a good chance you can at least get it running if you update your drivers. I suggest you visit the driver page for your machine and have it automatically detect which drivers to download. The important one you're going to want to get PixelCNC running will be a video/graphics driver. Your specific laptop model came in two flavors, apparently, one with Nvidia graphics and one with Intel HD graphics. Either one should be able to run PixelCNC.


The driver page should be able to automatically determine if you need the 32-bit or 64-bit version of the drivers, just click the "Detect Drivers" button: https://www.dell.com/support/home/us/en/04/product-support/product/latitude-e641...

It should show you a list of drivers specific to your laptop, and you could go ahead and download all of them and get your system properly setup, but if you want to just quickly skip to seeing if you can get it working then download only the graphics driver that it shows you, it will either say Intel HD, Intel GMA, or Nvidia, depending on the actual hardware you have. It will also likely say "graphics" somewhere in the name. Go ahead and download/install that, reboot, and try running PixelCNC again. You will probably encounter the same "search for an app" issue, but once you get through that PixelCNC should startup, if it managed to show you the glActiveTexture error before - which means PixelCNC did actually start at some point.

I did manage to find this, which might help you fix that problem with Windows, but it won't fix the OpenGL/graphics driver problem, which must be fixed in order for PixelCNC to use your graphics hardware for rendering. https://windowsreport.com/exe-files-not-opening-windows-10/

Good luck!

I'm on it! Thanks so much for looking into this for me. I wish "the big guys" were so thorough and prompt ; )

(1 edit)

Okay, five BIOS updates later seems to be the same result. I grabbed a photo of the point where it shuts down. Not sure if it'll provide any insight.


This is all greek to me but I did see the "INVALID_ENUM in the pic I snapped and there's reference to ti in this thread:

OpenGL Forum

Developer (2 edits)

Hi Macboy, did you determine which  graphics hardware you have in your laptop? I'm still fully confident we can get you up and running but I'm going to have to be up-front in saying that it appears as though you may have downloaded and installed a driver for your laptop other than the one for your graphics hardware. Can you tell me which driver(s) you installed?

EDIT: Before you follow through on the instructions I provided below, the black/console window that you snapped a picture of provides more information about your graphics hardware that it detects, and other useful information that will help me solve the problem. Scroll to the top of the window to the beginning of the output that PixelCNC generates there, and it should mention a GL_VENDOR and GL_VERSION. You don't actually have to take a screenshot, just telling me what it says there would be useful, but it sounds like you'll need to do a bit more work getting your system properly configured.

You mentioned BIOS updates, which are not related to graphics drivers, and should've only installed if you made it a point to install all of the drivers that the Dell page auto-detected that your system needs - which should've included the graphics hardware driver. Otherwise, if you made it a point to manually seek out and install the graphics driver by itself then BIOS updates would've only installed if you had accidentally mistaken a driver with "Intel" in the name as being the graphics driver. There are multiple drivers for your system with 'Intel' in the name which are not actually graphics hardware drivers. The Intel graphics drivers are distinguished from other various Intel drivers by the 'HD' or 'GMA' suffix that follows 'Intel' in their name. This is because your system has an Intel CPU and other Intel components, and therefore uses multiple Intel provided drivers.

Apologies if I am completely underestimating your aptitude, ability, or awareness, and you actually managed to install the proper graphics driver. I cannot stress enough that am not trying to be insulting or condescending by assuming a mistake, I am just going on the clues and evidence I have available to me, and I recognize that there's a distinct possibility that you may have simply installed a motherboard/BIOS Intel driver instead of the graphics driver, purely by mistake. There's also the possibility that because you have Windows 10 installed on an older laptop that is no longer supported by Dell that the automatic driver detector simply did not provide a graphics driver in the list of drivers it displayed to you - because there are no Windows 10 drivers for your laptop. If that's the case then you will simply need to manually install an older  driver, which will work fine regardless. Likely a 32-bit Windows 7 driver, if your system actually is 32-bit as you mentioned before, as Windows 7 was the last OS that Dell supported for that laptop, and thus provided drivers for.

I can assure you that whether your laptop has an Intel 'HD'/'GMA' or an Nvidia graphics processor that it will run PixelCNC - and be able to access long-existing OpenGL functions such as glActiveTexture which have been standard for nearly two decades. So something must be preventing your machine's graphics capabilities from being utilized, and in my experience the wrong drivers (or missing drivers) are the culprit. Also, the link to the glActiveTexture bug page you found was actually a discussion between programmers about writing software that utilizes the function, and erratic behavior one programmer was experiencing, which is unrelated to the problem you're experiencing.  "glActiveTexture" is one of many graphics functions that PixelCNC is unable to utilize from your hardware, and is only the very first one that it attempts to confirm accessibility for. A failure to access the function automatically prevents PixelCNC from attempting to access the rest of the graphics functions that it needs so that users are not bombarded by a barrage of error boxes for all of the missing graphics functions. The fact that PixelCNC errors out with "glActiveTexture" as being what the error specifies is purely incidental, and not specific to the glActiveTexture function itself. The problem lies in the graphics hardware not being properly configured for software to be able to access, which just means we need to make sure it's configured properly ;)

We can get to the bottom of the graphics hardware situation directly by seeing what Windows says about it. To do that you can look for yourself to see what graphics hardware you have, and what driver is currently installed for it - which I imagine is the default "Microsoft" provided driver that only grants very basic minimal functionality. It's provided as a last-resort graphics driver when the correct driver is not found. Without this default fall back driver Windows wouldn't be visible on the screen at all when the proper driver can't be located, so Microsoft provides it for convenience purposes. The problem is that it doesn't implement the advanced graphics features that the hardware offers, or that modern software utilizes, so it causes problems like the one you're experience when running proper hardware-enabled 3D software.

Take a look at what you have installed, and we'll have all the information we need. Start by right-clicking on your start menu button, which will pop up a 'context menu', and go to 'Device Manager', just like in this screenshot:

Device manager in the context menu


Once you're there look under "Display Adapters" by clicking on it to see what graphics hardware your system includes:



 I'd like to know what it says under there. I'd also like to know what driver is installed, so once you see what's listed under Display Adapters go ahead and right-click on whatever display adapter is listed under there and click 'Properties'.




This will pop up a dialog with information about your graphics hardware. There will be a row of tabs across the top: "General", "Driver", "Details", "Events", and "Resources".




Click the "Driver" tab and tell me what it says under "Driver Provider", "Driver Date", and "Driver Version", along with the name of the graphics hardware immediately above that. In this image from my netbook you can see it says "Intel(R) HD Graphics" as the adapter name at the top, next to the screen icon, and then "Intel Corporation" for the provider, "11/10/2016" for the date, and "20.19.15.4549" for the version.

These pieces of information will tell us for sure whether or not your system's graphics hardware's drivers are properly configured, and point us in the right direction. Lets first make sure that your graphics drivers are properly installed and we'll go from there.

Good luck!

(1 edit)

I had stumbled across a similar post (might have been you helping someone else or someone on the Inventables forum helping someone) but then couldn't find it again. Thanks again for being so thorough. And no - no insult at all. I am incredibly computer savvy.....but a Mac guru. Not a PC user at all. My last PC was an XP box that I literally only used for book keeping and an RC flight simulator! That must have been nine years ago.

When I did the driver check through Dell it told me I needed to install BIOS 10 and BIOS 14 (or was it 17?). But to install 10 I needed to find and install 09, then to install the next one I needed to install two other incrementals first. Seems so backwards....why can't they include all data in each update and disable it if the BIOS already meets those needs? You don't need to answer that of course. Just seems logical to me....

I did find the Intel driver and installed/updated it off the Dell site. Not sure what I had before. Still the same result happening unfortunately. I trapped pics of the screen anyway - can't hurt. I tried clicking "Yes" on the App question but it didn't launch anything, just proceeded with the PixelCNC launch.


Developer (2 edits)

Okay, I've done some more reading, and I think that you are possibly running a usable driver, but something is off. Could you find your PixelCNC log file and paste it here for me to see? It should be located somewhere such as:

"C:\Users\DELL\AppData\Roaming\Deftware Industries\PixelCNC\"

There will probably be a few log files, one for each time PixelCNC was run, but because you're experiencing the same issue they are probably all pretty much identical. Open the most recent one and paste its contents into a reply and we'll see what we can figure out. I might be able to code a work-around. Your hardware is right on the edge of being compatible so maybe something is tripping it up and causing it to default to an older version of OpenGL where glActiveTexture isn't supported.


EDIT: I think I found a way to work around the problem and get it working. I could still use the log file if you don't mind, but other than that you shouldn't have to worry about doing anything more to your system. I'll have a download link for you to replace your PixelCNC exe with to test out the patch in a few hours from now.

Sorry for the delay. Fridays and Saturdays are a bit zany in my world.

This is peculiar...I can't seem to locate that. I did a search for Deftware and nothing was returned. I did a search for PixelCNC and got lots of results but the long directory file location results were just "Recents" in the Windows system stuff.

Developer (1 edit)

No worries about the delay. Your search did, however, show you exactly the folder path I suggested your PixelCNC log files would be in. Here's the search result that was in your first screenshot which you can click on to see the log files:

You can manually navigate the folders on your harddrive to get to the folder indicated by a filepath, which in this case is 'C:\Users\DELL\AppData\Roaming\Deftware Industries\PixelCNC\'.  Just open each folder successively that is named in the filepath, no need for performing an excessive search. Your computer is just a little machine with some files/folders and configuration options organized hierarchically, like a tree :) It's nothing like a vast world wide web, and as such can be navigated much more succinctly.

Just go to your C: drive and open the 'Users' folder, and then the 'DELL' folder (the name of the Windows user that you are logged in with), then 'AppData' (where programs store peripheral/auxillary information), 'Roaming' (application info that is shared between users of the machine), 'Deftware Industries' (where any of my software would store its stuff) and finally 'PixelCNC' (the specific program in question). The log files will be in there. Easy-peasy :D

On a personal note, I suggest that it wouldn't hurt to sometime go crazy and just surf your machine and all of its options, menus, and folders, just to familiarize yourself with the where-and-how of everything. It's an investment that will pay back in dividends, guaranteed. There are many more folders all over the harddrive, but the important places are really just "C:\Users\", "C:\Program Files\" or "C:\Program Files (x86)\" depending on whether a program is 32-bit or 64-bit, and the "C:\Windows\" folder - which you will probably never need to go into unless you become a total PC expert. The rest of Windows comprises Windows/system configuration stuff, which is not on the harddrive but instead located in Windows' menus and interface.

The big one is the 'Control Panel', which has been around since Win95. You can get to that by right-clicking the start menu button (in Win10) and clicking 'Control Panel'. From there you can work with any and all of your computer's installed devices, hardware, etc.. and their configuration. The other powerful Windows dialog is the 'Task Manager', (around since Win95 too) which is also accessible from a right-click on the start menu, or by pressing Control-Alt-Delete (famously referred to as the 'three-finger-salute') and clicking 'Task Manager' on the options that popup. The task manager will let you see all of the running programs, their resource consumption (CPU/RAM/Harddrive), as well as running background 'services', which are basically programs that operate 'behind the curtain' to make Windows happen. Don't be afraid to get to know your machine! :)

Let me know how I can send a link to you privately. The link will be to a download of a custom version of the PixelCNC executable file, which you can then replace your existing one with to see if my workaround resolves your OpenGL driver issue.

I missed that one. Sorry. The weird thing is that once I click to the C drive, Users and DELL that's the end of the line. I can't actually see the AppData folder. I wonder if the previous owner of this machine set it up to hide those files that if touched might mess up the world?

In any case, I found the log file - below are it's contents. I wanted to say thanks for being so incredibly responsive and complete in your support. This has been the most amazing experience I've ever had with a software type......I hope others read this and if they are on the fence about working with you, this conversation string convinces them that they should have no fears.

You can email me at listmail [at] animatters.com


0.015 
0.015  [ PixelCNC v1.21a - Sep 12 2018 ]
0.125  [ Deftware Industries - deftware.itch.io/PixelCNC ]
0.140 
0.156 --- initializing ---
0.156 configuration...
7.301 system...
7.301 ...initialized libcurl
7.323 ...initialized SDL
7.330 system version: 2.0.6
7.336 system memory 3957mb
7.409 unable to disable v-sync
7.416 unable to disable v-sync
7.422 4 logical cpus detected
7.432 input...
7.438 render...
7.559 vertex size: 26
7.573 GL_VENDOR: Microsoft Corporation
7.584 GL_VERSION: 1.1.0
7.590 OpenGL version integer: 11
7.690 [ ERROR ] sys_glfunc: function not supported: glActiveTexture
16.168 image...
16.269 font drawing...
16.287 loaded ".\fonts\system.png" (256x128@4)
16.300 teximage: INVALID ENUM
16.318 ...loaded font "system"
16.328 loaded ".\fonts\fixedsys.png" (256x128@4)
16.336 teximage: INVALID ENUM
16.351 ...loaded font "fixedsys"
16.361 loaded ".\fonts\source_code.png" (256x128@4)
16.369 teximage: INVALID ENUM
16.384 ...loaded font "source_code"
16.396 loaded ".\fonts\courier.png" (256x128@4)
16.403 teximage: INVALID ENUM
16.416 ...loaded font "courier"
16.425 loaded ".\fonts\latha.png" (256x128@4)
16.432 teximage: INVALID ENUM
16.446 ...loaded font "latha"
16.457 loaded ".\fonts\latha_big.png" (512x256@4)
16.465 teximage: INVALID ENUM
16.502 ...loaded font "latha_big"
16.512 loaded ".\fonts\tahoma.png" (256x128@4)
16.519 teximage: INVALID ENUM
16.607 ...loaded font "tahoma"
16.629 loaded ".\fonts\tahoma_big.png" (512x256@4)
16.645 teximage: INVALID ENUM
16.668 ...loaded font "tahoma_big"
16.678 loaded ".\fonts\verdana.png" (256x128@4)
16.687 teximage: INVALID ENUM
16.702 ...loaded font "verdana"
16.715 loaded ".\fonts\verdana_big.png" (512x256@4)
16.724 teximage: INVALID ENUM
16.740 ...loaded font "verdana_big"
16.750 loaded ".\fonts\ocr_a.png" (256x128@4)
16.758 teximage: INVALID ENUM
16.833 ...loaded font "ocr_a"
16.852 loaded ".\fonts\ocr_a_big.png" (512x256@4)
16.862 teximage: INVALID ENUM
16.879 ...loaded font "ocr_a_big"
16.892 loaded ".\fonts\icons.png" (256x128@4)
16.901 teximage: INVALID ENUM
16.938 ...loaded font "icons"
17.042 loaded ".\fonts\icons_big.png" (512x256@4)
17.057 teximage: INVALID ENUM
17.160 ...loaded font "icons_big"
17.173 view...
17.186 mesh...
17.199 toolpath...
17.219 cam...
17.233 project...
17.244 tools to inch defaults
17.253 gui...
17.264 ...program initialized
17.273 --- entering main loop ---
17.292 r_end: invalid enum! (6, 4)
17.582 received 774 bytes at offset 0
17.596 downloaded 774 bytes (www.deftware.org/PixelCNC/version.txt)

Deleted post
Developer

My apologies! I forgot that on Windows 10 "hidden items" must be enabled via the 'View' menu when looking at the DELL folder's contents - and then the AppData folder will appear. Alternatively you can type the folder name in the address bar and it will still allow you to access it whether or not you have hidden items enabled.

Okay, this right here is pretty funky:

7.573 GL_VENDOR: Microsoft Corporation
7.584 GL_VERSION: 1.1.0

GL v1.1 is the very oldest version of OpenGL. Right now PixelCNC tries to create a v2.0 rendering context, which grants it the functionality it needs to draw everything to the screen quickly, and utilize the graphics hardware for some peripheral calculations. According to some Google searches, your Intel HD driver (v8.15.10.2900) should support up to OpenGL v2.1. The fact that it says Microsoft has me thinking it's not even using your Intel HD hardware at all, and is running an OpenGL driver that is emulating graphics hardware on the CPU (aka 'software'). That's not going to fly.

It looks like your only options are to either install a new driver from the Dell support page, downgrade to Windows 7 if the driver doesn't work, or find a new computer to use. Honestly, this entire situation originated from the fact that Windows 10 should not have been installed on such an old machine. Windows 7/Vista would've been fine. 

There's a good chance the driver will work and you'll be on your way: https://downloads.dell.com/video/VIDEO_DRVR_WIN_R296701.EXE

The biggest problem people seem to have is their screen becomes 'disabled' after installing the driver. If this happens when you boot your machine back up just let it sit for a minute, and then try pressing Windows Key + P simultaneously to switch through the various Screen/Projector modes and it should bring the screen back up after one or more tries. For some reason the driver will default to outputting on the video port, for a projector or external monitor, which just requires switching it back to the internal display.

Good luck!

(+1)

I'm not opposed to a downgrade. My requirements are Win 7 or newer so anything I need to do can happen in Windows 7. I have downloaded and installed the EXE from that link which then required me to download and install a .NET framework something or other. After all of that, still same result. I'm downloading and downgrading now. I'll let you know how I make out...I won't miss Windows 10 that much ; )

(+1)

Oh God.......what an adventure this has been so far! I'm finally downloading the first batch of 120 updates to Windows 7 after using my Macs to save the day and download network and display drivers just so I could get tings rolling. Why do people use PCs again? (kidding)

I'll keep plugging away at this and when I can will update you on progress. What do I do about reinstalling PixelCNC? Will I need a new key? I can't remember if it was serial protected or what. I do still have my "Download your purchase" email. Is that link still OK to use?

Developer

Yes, as long as you can log into itch.io with your account (which you seem to be able to do if you can post on this messageboard) then you should still have access to the latest PixelCNC download. I admire your courage and persistence! :)

Developer

 According to Dell's specs for the e6410 your CPU is either a i5-520M, i5-540M or i7-620M. You can look up your CPU on Intel's website (or Google it, and the Intel page will show up first) and from there go to the downloads link on the left side of the page. From there I'd try the first Intel Graphics download there is. I suppose you could continue extracting the drivers to a folder and manually installing, just to be safe.

Also, be sure you reboot after each driver install. If you install the right driver but try running PixelCNC without rebooting it will still be using whatever driver was already present - instead of the newly installed one. Windows needs to boot with the new driver installed in order for software to be able to utilize whatever functionality the driver exposes, otherwise it just lies dormant, waiting for the reboot, so it can fully swap in the new drivers in place of the ones already being used.

I think the key is definitely going to be finding the right driver for your CPU's graphics functionality. You should be able to see exactly which CPU you have in the device manager under 'Processors', and google that. It should be something iX-YYYM where 'X' is either 5 or 7 and YYY is a 3-digit number.

All I know for sure is that your machine is plenty new to have at least GL 2.0 hardware built into it, and it's just a matter of hunting down the right driver.