Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics


A high-end code editor for all things GameMaker · By YellowAfterlife

Fix for Mac Beta version

A topic by Nodens created Sep 02, 2022 Views: 212 Replies: 5
Viewing posts 1 to 4

Hello all (and thanks YellowAfterLife for this great tool, it convinced me to buy GMLive ;) )

I would like to share my experience with the beta version on macOS (the normal version, not the ARM-64 that is not working at all on M1 as already raised in a different topic).

So the normal beta version was stuck at "Starting up...", using the dev tools I could find that app.js and app-starter.js were not found, so if you have the same issue the fix is simply:

-Right click on GMEdit -> Show Package contents
-go to Contents/Resources/app/resources/app -> copy app-starter.js and app.js
- paste them in Contents/Resources/app

And voilà, GMEdit beta on Mac should now start.

I don’t understand that resources/app/resources/app path, that looks strange, there’s maybe an issue with the packaging...

Thank you for this!


The new stable+beta releases should fix this for good.

Hello YellowAfterLife,

I confirm this is now working out of the box, thanks !

2 issues remain though,
-The ARM-64 build is still not working on M1 (it says the package is damaged)
-The "Run" function is also still not working, it compiles, it starts the game, but no window/game appears



The first one will remain a mystery for someone with an M1 Mac to uncover.

If there are errors in the console for the second thing, I can try doing something.

Hello, there’s no error in the console, everything goes fine till the running command
Running /Users/Shared/GameMakerStudio2/Cache/runtimes/runtime-2022.9.1.66/mac/YoYo -game /var/folders/yd/4f_7n35x58j5gwl1qdl_nbl80000gn/GameMakerStudio2/GMS2TEMP/ActionRogueLite_F4875074/ActionRogueLite.ios...
Nothing happens at that point, I’ve checked the folders, they are correct and they exists.

To compare here’s the command executed by GMS2 directly
-game /tmp/GameMakerStudio2/GMS2TEMP/ActionRogueLite_34FAE482_VM/game.ios (I’ve removed the debug log parameter)

About the ARM64 build... If I find time I'll try to dig into it.