Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Empire Deluxe Combined Edition

The latest in the classic Empire Series of games, which has spanned almost five decades. · By Killer Bee Software

Can't start Linux version in Manjaro

A topic by pyhavk created Mar 12, 2018 Views: 760 Replies: 12
Viewing posts 1 to 2


I just paid for the game and downloaded the Linux version. I tried both the x86 and x86_64 versions of the game by starting them from the commandline (and yes I made sure the files are set to be executable), unfortunately nothing happens other than the following output:

Set current directory to /[path to game]/
Found path: /[path to game]/EmpireCombined.x86_64
Mono path[0] = '/[path to game]/EmpireCombined_Data/Managed'
Mono path[1] = '/[path to game]/EmpireCombined_Data/Mono'
Mono config path = '/[path to game]/EmpireCombined_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 3 screens
displaymanager screen (0)(LVDS1): 1280 x 800
displaymanager screen (1)(DP2): 1920 x 1200
Using libudev for joystick management
Importing game controller configs
Afterwards I'm thrown back to the terminal prompt. How do I troubleshoot this and start the game? Thanks!

P.S. I am running a fully updated Manjaro Linux with kernel version 4.14.


EDCE uses Unity as the engine. Manjaro may be an issue, as the most success  with Unity on linux appears to be Ubuntu. 

That being said, this thread

Seems to have a problem extremely similar to yours, so I suspect you video is failing to initialize. Though there is some VMWare in that thread, you should tried those solutions, including the -"-force-opengl" command line argument or turning off graphics hardware acceleration. 

Do you run any other Unity-based games?


Thank you for your quick response!! Using the "-force-opengl" option indeed starts the game. But a funny thing is that all the text appears "choppy", please see my attached screenshot. Since this appears to be a graphics issue I thought the choppy text might be related?

BTW, here's my "uname -a" output:

Linux [hostname] 4.14.24-1-MANJARO #1 SMP PREEMPT Sun Mar 4 21:28:02 UTC 2018 x86_64 GNU/Linux
Any ideas? Thanks!

P.S. I am not running other Unity games at the moment so can't speak to that.


Arg, I would not be surprised if this is something with your video card driver and possibly its open gl support.

You might fiddle around with any video card options you are supplied with.  What card do you have in the box? 

I've got integrated Intel GMA 4500MHD graphics. I know it's an older one, so is it unsupported?


Well, its the combination of Operating System, video card drivers (software) and  and the card itself  that is the issue. There are a lot of variables at play. Its not a question of supported/unsupported from my perspective, more a question of how the combination can process the graphics API, and if it does so correctly.  Something in the mix is causing the breakage on the font textures. Is it fixable? Maybe so, possibly not. We are kind of at the mercy of these  components working together.

There a couple of other flags that can be tried. Though they specify Direct X and I don't know if these are going to be non-starters for this.

Potential Flags are:

-force-d3d9 Make the game use Direct3D 9 for rendering. 

-force-d3d11 Make the game use Direct3D 11 for rendering.

-force-opengl Make the game use OpenGL for rendering, even if Direct3D is available.

I doubt the 11 would work as the card itself only supports up to DX10, but you might try the 9

Unfortunately, the card is 10 years old and its capabilities might just not be up to modern API calls and the memory is low.

Also, if there is some sort of "Control Panel" for the video card there are possible options you can perform. These sorts of things allow you to make adjustments inside the card and that helps.

You might cycle between the 32 bit/64 bit versions if you have not done both, though I would not anticipate this changing the situation. But you never know.

Regarding your support question again. If you don't think you can get it working to your satisfaction and want to refund it, itch has a refund policy.  I would think this would fall under "technical issues" and you have worked with me on it. I always hate to go that route as my goal is to keep people playing this classic game,  but if  this is the only component combination you can readily use I am afraid you may have to go that route. It is not my goal to take your money and run. ;> 

OK. I just tried running the game via the Wine compatibility layer, with and without those flags, and interestingly the choppy fonts still appear. So to me this suggests something pretty low level? I also tried running it in a Windows 7 virtual machine, and there the text appeared correctly! Unfortunately its performance was really bad and the game crashed upon generating a new map... Not sure if any of the above is a hint as to what's causing the problem.

There might be other machines I can try this on and I'll do so when I get a chance. I'd rather not give up yet, and I'd love to support your work keeping this wonderful game alive!
That said, considering there's such a lively community. It'll be great to open source the entire game so everyone can help make it better, which will also be profitable for you!

Anyway, thanks for the detailed replies. I'll keep trying for a bit more!


Well, keep in contact about it and let me know how it is going. As I think on it, I suspect the memory of the card is an issue. 384 is not a lot. 

I finally got a chance to try the game on a Linux system with an Intel® Core™ i5-4690 Processor with Intel® HD Graphics 4600 and a whopping 20GB of RAM. The fonts appear OK this time but the game is super laggy and slows the entire system (not just the game) to a crawl...

Looking at the screenshots, EDCE doesn't look like a game that's very taxing on the system. I wonder why the performance is so bad???

If we still can't get it to work then I might have to take up your refund offer...


did you run with the forcegl option?  If you did I would try without and see if it behaves differently. (or visa versa)

Hello again. I tried to start the game with and without the -force-opengl option, and either way my entire system slows to a crawl once the game starts...