🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Install problem on Ubuntu 16.04 LTS

A topic by gfilipski created Nov 29, 2017 Views: 181 Replies: 11
Viewing posts 1 to 11
(Edited 2 times) (+1)

Hi,

I downloaded and unarchived the Linux 32/64 bit version into a a directory, set the execute bit and tried to run it (there didn't seem to be any other instructions other than 'set the exec' bit) ...  no success.

From the terminal I get the following output:

        gary@homeUbuntu /opt/Apps/EmpireCombined/linux
       $ Empire*64
       Set current directory to /opt/Apps/EmpireCombined/linux
       Found path: /opt/Apps/EmpireCombined/linux/EmpireCombined.x86_64
       Mono path[0] = '/opt/Apps/EmpireCombined/linux/EmpireCombined_Data/Managed'
       Mono path[1] = '/opt/Apps/EmpireCombined/linux/EmpireCombined_Data/Mono'
       Mono config path = '/opt/Apps/EmpireCombined/linux/EmpireCombined_Data/Mono/etc'
       displaymanager : xrandr version warning. 1.5
       client has 8 screens
       displaymanager screen (0)(Virtual1): 1920 x 1200
       Using libudev for joystick management

       Importing game controller configs

       gary@homeUbuntu /opt/Apps/EmpireCombined/linux

        $

... and that's it.  Also tried running it with the *_Data directory as the CWD when starting, but still no luck.  Tried it with "sudo -H" and the restuls were the same.

I noticed that there's an 'install' subdirectory in the *_Data directory.  Are there any particular install instructions that are hidden somewhere?

Info that might be pertinent:

      gary@homeUbuntu /opt/Apps/EmpireCombined/linux
      $ uname -a
      Linux homeUbuntu 4.4.0-101-generic #124-Ubuntu SMP Fri Nov 10 18:29:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

      gary@homeUbuntu /opt/Apps/EmpireCombined/linux

      $ ls -l
      total 50000
      drwxrwxr-x 9 gary gary     4096 Nov 28 12:55 EmpireCombined_Data
      -rw-rw-r-- 1 gary gary 25457968 May 18  2017 EmpireCombined.x86
      -rwxrwxr-x 1 gary gary 25731952 May 18  2017 EmpireCombined.x86_64

This is a VM running under VMware workstation.  There is no joystick, only mouse & keyboard.  Very "vanilla" machine.  I don't run any software other than VMware workstation on the host machine. (Windows 7)

Ubuntu is an up-to-date edition of 16.04 LTS.

It kind of bothers me that the date of the executable is "May 18" of this year...

Any help getting this going would be appreciated.

Thanks,

Gary

Developer

/opt/Apps/EmpireCombined/linux will be the right directory.  The install directory is internal to the game, and most of that stuff gets placed in the Game Data Directory structure after it is created.

We had some trouble with trying to get it to run under a VMWare install, and I think it is related to the way the Unity engine tries to use the video card. Do you run any other Unity games on this instance?

I will ping my linux group and see if anyone has some words on it.

But this is an interesting thread:

https://forum.unity.com/threads/running-on-ubuntu-with-vmware-workstation.470925...


--Mark

Mark,

I'm running Workstation Pro 12.5.7, soon to be 12.5.8.  Didn't know that 14 was out (from the other thread) - haven't received any upgrade notices.

I'll try disabling the 3D hardware acceleration on the display, but I don't have quite the same symptoms as reported in the other thread... I don't get any play at ALL.  Just the shell prompt back after "Importing game controller configs".

Is the May 18th date on the executable correct?  This seems very strange since the dates on the directories in the archive (and all the data files in the *Data directory) are November 28th.

I'll try disabling the 3D acceleration and let you know.

Thanks,

Gary

Developer

The dates are "correct" in that it is how the Unity build sets them. 


--mark

Mark,
Disabling the 3D acceleration did the trick... the game comes up and displays correctly (or as correctly as I can determine from looking at the initial splash screen/menu :-).

Crap. Now I have to figure out what I'm going to do because I can't run with 3D acceleration disabled on a continuing basis.

I have an upgrade to 12.5.8 to install for VMware and I'll make sure that my nVidia drivers are up to date and report back any resolution (or non-resolution).

Thanks for your help with this!
Gary

Developer

I am sure it sucks and is not the best solution. ;<

I was looking into this some more, and while I did not find anything really useful, I did look at this page for RimWorld issues:

https://ludeon.com/forums/index.php?topic=4805.0

and noticed Tynan mentions a "-force-opengl" flag to run an earlier version of openGL. I wonder if that can help you.

I can replicate this error and a stack trace does seem to imply something in GL:

2840  write(6, "XError: GLXBadFBConfig (error 17"..., 93) = 93

I can also confirm that executing with "-force-opengl" does work to start the game, it runs quite well in even a modest vm. 

Mark, themensch,

Thanks for your help with this!

I upgraded VMware workstation to 12.5.8 (latest in the 12.5 Pro series) and also upgraded to the latest nVideo drivers... and this made no difference whatsoever.  The problem still existed (as it seems to with v14 also based on comments elsewhere).

I then tried Tynam's/themensch's command line option of -force-opengl and:  PROBLEM SOLVED...   or at least avoided.

Thanks again to all for the help!

Gary

Can confirm the same issue and fix (-force-opengl) on Linux Mint 17.3.

Developer (Edited 2 times) (+1)

Don't know if either of these guys are running mint. 

Edit: Oh I was confused. You did have the issue and fixed it. Yay!

(+1)

This isn't unexpected as Mint is downstream from Ubuntu.  Good to know the fix works!