Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Tilemancer

Procedural pixel-art tile creator · By Led

Mac OS build "damaged"

A topic by Hyperlink Your Heart created Apr 09, 2016 Views: 653 Replies: 8
Viewing posts 1 to 8

When I try to open the Mac OS build it tells me it is damaged and should be moved to the trash. I'm on Mac OS 10.10.5. I've downloaded it twice now with the same result.

Never mind, I had to change my security settings to allow apps downloaded from anywhere. Not sure why that's suddenly required considering I've run hundreds of Ludum Dare games in the past, but anyway...

Developer

Thanks for figuring this out. Some users have also reported this and i had no idea what was happening so i couldn't help them.

Well for future reference then, this is the relevant settings dialog and how it must be set for Tilemancer: http://imgur.com/7eBuFQB

I can't say if other versions of OS X are the same, I'm a relative noob.

Great application by the way! I've only done a bit of fiddling with it so far, but I'm looking forward to making a game with it :)

(2 edits)

Hey, I have/had the same problem and solved it same way you show here. But now I run into the next problem, that nodes and presets (everything .lua-related?) can't be loaded. Does any other mac-user experience the same? MacOS Sierra 10.12.5, Tilemancer 0.2.1 (3).

I also looked at this thread, but this does not to be the issue here...
https://itch.io/t/19845/ui-issue-on-osx

Oh, if any mac-user can't find the "Install from anywhere"-option in the system settings, you can type into the terminal the following to make the option available:
sudo spctl --master-disable

I had to  open a terminal, navigate to the directory and type:

xattr -rc Tilemancer.app

This is all I see...

I had  the same problem, but the suggestion from gll worked a treat.

  • drag the Tilemancer-0.2.1 folder to a location, e.g user/Applications
  • open a terminal window
  • cd ~/Applications/Timemancer-0.2.1
  • xattr -rc Tilemancer.app

Now you should be able to open the app from the Finder.