🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

MewnBase

Planet exploration and survival game with base building. · By Cairn4

Cat continually walks top left like controls are stuck

A topic by illumnis created Feb 28, 2018 Views: 109 Replies: 9
Viewing posts 1 to 7

First off.. great game. I'm excited to see new content down the pipe :)

This bug began expressing itself as of the latest 0.42.1 update and does not happen in 0.41. After loading a new or saved game, the cat wants to walk on it's own towards the upper left of the map. pressing other buttons will cause the cat to turn around but it resumes walking to the upper left after the controls are released

I have tried verifying integrity, reinstalling, rebooting, all to no avail. Reverted to 0.41 and the behaviour does not happen in the older version.

System: Fedora 27, Kernel 4.15.4.  Hardware: Ryzen R7 1700x, R9 Fury X, 16MB DDR4, Razer Blackwidow Ultimate (2016) keyboard (latest OpenRazer driver 2.2.2)

Thanks in advance

Developer

Hey, thanks for the report! Second mention I've gotten regarding the cat wanting to continuously walk left (or the flashlight pointing left) - so there's definitely something screwy happening in the latest version.

I haven't been able to get it to happen on my end, but my first thought is that it has something with the new gamepad controller input I added in.  Did you have a controller hooked up to your machine when playing?  The issues could probably still happen regardless of whether one is actually connected or being used, but just curious.

Developer

If it seems like controller input is the problem, I'll probably disable the controller stuff for now and make a new build this evening, since not being able to stop moving is pretty game-breaking ^^;

I wonder if that's the case. I don't have a game controller, however, I did notice in the game logs that my keyboard is added as the first controller:

[2018-02-28 @ 00:29:44.592] [launch/native] out: Controllers: added manager for application, 1 managers active
[2018-02-28 @ 00:29:44.592] [launch/native] out: 1st controller connected: Razer Razer BlackWidow Ultimate 2016
[2018-02-28 @ 00:29:44.592] [launch/native] out: Controllers: Setup controller mapping : ControllerMapping

Could it be that it looks at my keyboard driver and thinks it's a game controller?

I quickly updated the program from itch just now and it seems to have the same issue still. I also noticed that any changes to the control config I make in game don't seem to stick around (tried changing the tech button to T but doesn't keep the change next time I look). I also wonder if that is related.

Let me know if you need any more info.

Developer

Ooo thanks - def helpful info.

That's very odd that it thinks your keyboard is a controller haha. Random thought, if you have an older, more basic USB keyboard kicking around the house, could you try that and see if that fixes the issue with being stuck walking up-left?  

I think I'm going to add in a toggle into the Settings screen to enable controller support (that will also be off by default). I can also probably start making a list of device names to ignore as controllers.

I'll also look into the controller mapping screen not saving properly, were you going to it from the Main Menu?  or from in-game?

(3 edits)

Jo, its the razer driver, i get the almost same problems with my pc, only windows recognizes some input like i press it continualy, but try to press it again, then it stops. its anoiing as fuck. try to start the pc, start the game and try to change the usb port ingame. if this stops, then its not the game ^^

i use a ds4 with ds4windows driversuite, and i got no problems with my gamepad. its using a wrapper that converts the ds4 inputs to xinput (xbox-input)

PS: i am using the older (fullsize) blackwidow chroma with the normal, newest driver for it ^^

Much thanks Cairn4, switching to another keyboard worked. A toggle would be great as my other keyboard is way too mushy. Just a suggestion: is there maybe a way to have it do it's detection in the settings menu and have the user confirm the device is a controller? That way you don't have to program in exceptions for every device that might do this and save some time for more awesome content :)

As for the control mapping issue in the menu, it appears to be both main menu and in-game menus. I was playing around with it a bit and noticed it is working right for all the other settings, but the 'tech upgrades' hotkey displays whatever setting the 'map' hotkey is set to. However: it seems to be actually mapping 'tech upgrades' to the key I try to set it to and just displaying it in the menu wrong. I bet this is just it referencing the wrong variable when the menu is pulled up. 

Developer

Uploaded hotfix build 0.42.2: in which disables the new controller stuff by default (although not 100% sure if it would fix the issue with that particular Razor keyboard).  Also fixes the issue with the Research keyboard button not being set/reset properly.  Build notes here :)   https://cairn4.itch.io/mewnbase/devlog/25983/hotfix-v0422

That fix worked for me. Thanks so much.

Developer

Yay! 1 bug down, 999 more bugs to go :)