🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

macOS — Game launches and immediately closes (no screen visible, just immediately crashes)

A topic by Joshua Meadows created 53 days ago Views: 131 Replies: 13
Viewing posts 1 to 10

As above, the moment I launch the game it just instantly closes without showing anything. If I launch it directly (without the itch app) it remains open but it sits in the dock and there's no game windows or anything else visible. I hadn't seen this posted already so I don't know if it's a bug on my end or what.

Developer
Sounds like the 'ol macOS gatekeeper / security thing preventing it from launching. Easiest thing that usually seems to work is just drag the MewnBase.app (not the folder) into your Applications folder and try launching it from there. Let me know if that works for you.

Unfortunately, I did try that and it didn't fix the issue.

I tried downloading it through the itch app and launching (it just closes instantly), also I tried downloading it through itch as well as directly from the website and the same thing happens if I move the .app file somewhere else or the entire folder. I've had to resort to playing it in a virtual machine to get it to work at all.

Developer

It crashes instantly through the itch app too?  Hmmmmmm.  And it doesn't throw an error popup?  Does itch give any "Examine the cause of failure" dialog or something when it crashes?

Nope, it just literally opens for half a second, the icon bounces a couple times in the dock, and then the icon closes. If I open it directly, the application remains in the dock but doesn't show any windows or anything (it doesn't seem to be locked up, however) and nothing happens.

    __TEXT                 000000010066e000-000000010067e000 [   64K] r-x/rwx SM=COW  /Users/USER/Library/Application Support/itch/*/MewnBase.app/Contents/MacOS/MewnBase

Application Specific Information:
abort() called
*** error for object 0x117232160: pointer being freed was not allocated

throught itch.app

I get the same error, both through the itch app and downloaded from itch and run directly

Developer

Just wanted to mention that I'm still looking into this. There's clearly something up with the macOS version, unfortunately I can't reproduce this crash on my 2012 Mac Mini... but will keep at it. Is anyone with this issue able to launch the Java version directly?  or does that give the same result? 

(Edited 1 time)

Trying to run the jar directly also crashes, but with a different error:

Exception in thread "main" java.lang.ExceptionInInitializerError
at org.lwjgl.glfw.GLFW.glfwCreateWindow(GLFW.java:1647)
at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.createGlfwWindow(Lwjgl3Application.java:442)
at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.createWindow(Lwjgl3Application.java:391)
at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.createWindow(Lwjgl3Application.java:379)
at com.badlogic.gdx.backends.lwjgl3.Lwjgl3Application.<init>(Lwjgl3Application.java:108)
at com.cairn4.moonbase.desktop.DesktopLauncher.main(DesktopLauncher.java:41)
Caused by: java.lang.IllegalStateException: GLFW windows may only be created on the main thread and that thread must be the first thread in the process. Please run the JVM with -XstartOnFirstThread. For offscreen rendering, make sure another window toolkit (e.g. AWT or JavaFX) is initialized before GLFW.
at org.lwjgl.glfw.EventLoop$OffScreen.<clinit>(EventLoop.java:37)
... 6 more
AL lib: (EE) alc_cleanup: 1 device not closed
Developer

Thanks for posting this, think I'm starting to finally get some leads on why the macOS version is being so difficult...

Going to try out a few things over the weekend to see if I can get it launching more reliably.

Since it looks like you at least have a version of Java installed on your machine, see if running this from the Terminal works...

> java -XstartOnFirstThread -jar desktop-1.0.jar

(Assuming that you have the Terminal navigated to the same folder as the jar file)

There might also still be an issue where I'm using a AWT/Swing popup to show crash error messages... but worth trying.

I get the following error:

java(3906,0x7fff99cea340) malloc: *** error for object 0x123b69140: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
[1]    3906 abort      java -XstartOnFirstThread -jar desktop-1.0.jar

Here's the Java version on my machine

java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)
Developer

I've just uploaded v0.42.4 of the game.  It has some changes to the macOS version that I hope make it launch a little more reliably. Would love anyone that had the crash issues in this thread to check it out and let me know if it works better or worse. 

Note:  It sometimes will still silently crash the first time the .app is launched, but then will always run fine after that... still investigating.  

I still get it launching and then instantly/immediately closing whether I launch it through the itch app or from the standalone zip download. I tried opening it a couple of times to clear out the first launch issue, but nah — still unplayable for me on macOS unfortunately. Anything else I can test?

I too still get the same crash on launch