🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bugs Unearthed Sticky

A topic by Yotes Games created 1 year ago Views: 578 Replies: 9
Viewing posts 1 to 5
Developer (Edited 4 times)

Find any bugs? Post 'em here and I'll definitely see them. I aim to squash as many as possible for the next demo release.

We can work together to make Battle Gem Ponies as polished as possible!

Just post a picture (if you have one), what the bug is, and how you found it.

Developer (Edited 6 times)

Current Build Bugs (V4.5):

Class A (Crash/Game Break):
**************************
- Infamous "Zombie Lock" bug. 0 HP battle lock. Usually involves Vinerva. Leads to broken text IDs after battle
- Attacks calculated for pre-switch pony. Dont do math until both accounted for.
- Class match double check
- Multihit calc is too late
- HP perc check
- Move does not call nextstep
- Move lock-up GP depletion
- Pushing run/cancel too often boots to title or exits battle
- Exit from house to map corner or cave
- HPmax[] based on save data
- StatOrbs based on save data
- House Upstairs try loading NOT the same scene. Each floor gets a scene. No harm in having a ton right?



Class B (Gameplay Glitch):
*************************
- Force input off on level load for a few seconds
- Reset hp after battle
- NPCAI FindPreviewPos (wait during map load)
- NPC clipping

- [ESC] too many times from battle and you clone yourself in overworld.




Class C (Art/Sound Errors):
*************************
- Press run button, flickers before changing
- In battle nameless opponent
- Critical text color on no effect moves
- Pony in wall
- NPC turn rate too fast
- Partygems recalled
- Battle cam misplaced
- Dynamically fade txtShadow
- In battle, first stats set fades early. 2nd page runs normally. (being called be PhaseCon?)
- "Miss" needs to appear sooner or play sfx ahead.

I found another bug that happens when you play adventure mode, exit with esc and then try to play a random battle. It seem's like your opponent can not faint until one of your team does. They will be at 0 hp and only 1 attack will go off, If my pony is faster; my attack goes off then the opponents turned is skipped while they stay at 0hp.

Hello, I am on Mac OS 1.6 Snow Leopard and when I try to launch the game by double-clicking on it, the app quits immediately with an error message that says that "the app has unexpectedly quit". I've tried moving it to the application folder, but it doesn't change anything.

I think the problem comes from my OS (Snow Leopard is a bit old) but I am not an expert on the matter. Can you help me?

Developer

It may be because of Snow Leopard because I used El Capitan to build it. I just set it to OSX and it must've chosen the latest version by default. I don't think it's an issue with being blocked if you can get the app to open and crash. If resetting your computer and trying again fails, I'd assume I need to look into universal compatibility for the next build.

Developer (Edited 1 time)

Here's another possible (but annoying) way to fix the compatibility problem found on the Unity Forums:

It seems to be a normal unity-mac problem. Right clicking the application> Show Package Contents> Contents> Mac OS> (BGP Pre-Alpha, or something similar for the app title)


Open Terminal and type "chmod +x"
hit space
Drag your file over to the terminal
hit Enter

If you did this correctly the file image should have changed and the game should now launch correctly.

Nope, still doesn't work. The terminal executes the command without any error popping, but nothing happens.

If the problem comes from Unity though, it's definitively my OS that is too old. The recent versions of Unity work only for Mac 10.8+.

Developer

Dang. I really hope that isn't it. A lot of people have older Macs and I'd hate for them to be blocked from playing. The game isn't even THAT complex. I'll try to see if Unity let's me build to at least as far back as 10.6.

Worst case, I'll have to put OSX 10.8 as the minimum specs.

(Edited 2 times)

Hello, it's me again. I have recently bought a PC and have been able to play the demo. I will list the bugs I found here.

- When I first played the adventure mode, I passed by this sign and was teleported inside this house.

- When I exit said house, I glitched into the wall : capture

I can then move into the black area freely and go from house to house, but I can't enter any of them and I have to return to the title screen.

- I found an item on the ground where there was nothing, and I can't make the text message disappear. The animations are still playing so the game didn't froze, but I can press any key and nothing happens : capture (the duplicates are from the escape bug)

And even when I return to the title screen and try adventure mode again, I am still stuck and can't make any movement.

Developer

Yeah, a lot of those have to do with the duplicates glitch which I just fixed the other day. If one clone hits a wall, neither can move, they both detect items, they can both enter doors, and the clone is usually off-screen.

Fixing the other bugs will be much easier now that I Cleaned Up My Codebase and can more easily pinpoint these problems.

Hopefully build 5 will have all these things resolved! I'm dedicating next week to fixing every single bug so far. (Congrats on the new computer by the way!)