Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Empire Deluxe Combined Edition

The latest in the classic Empire Series of games, which has spanned almost five decades. · By Killer Bee Software

Bug Reporting Locked

A topic by Killer Bee Software created Nov 30, 2017 Views: 758 Replies: 85
This topic was locked by Killer Bee Software Dec 28, 2017

Got long. Feel free to create a new thread to report or send email to

Viewing posts 1 to 31

If you have encountered an issue first my apologies and second I would like to try and fix it. If you would rather contact me directly, you can always send an email to

If you have a “How do I..?” or “Why can't I...?” type of question, please post those in the regular forums.

There are essentially two types of problems: First with the vanilla game. Second with a modified game.

For vanilla issues, please remain constructive and describe the issue in detail. Saved games often prove very useful in repeatable situations. My first step will be to be able to repeat the issue. If I can, It will be fixed. If I cannot, it “might” be fixed after some digging around.

Some bugs only occur because of someone's unique play-style. So I also may try to work with you personally by requesting you send me an email and we may go through the issues to see where the bug is appearing. These situations do require your patience and understanding, and I thank you in advance for that.

For mod issues, (Unit Set, Source Code), the bug may or may not be related to your mod. With a mod, you may be traversing down an unintended code path or running against some assumption in the program. I cannot guarantee these can be fixed if mod related, but I would like to give it a try.

The philosophy towards mods is essentially everything is exposed, and whether or not it works like you would like is another matter. However, I can be approached with proposed changes and if I deem then not to be too much of a code risk and they do not violate any sacred game rules/mechanics, I can try to get them in. Most mod change requests that come about occur because there is some assumption in the code that needs to be a setting many changes are possible.


What about sending you short movies captured from screen?  I have Screenflow here. If some odd behavior shows up due to my own gameplay style, you can see an unintended result. You up for that?


If a picture is worth a thousand words, how many words do we get out of a video? ;> absolutely.

Oh, that's very Zen...

Deleted post

What "Regular Forums" are you referring to? On Itch or someplace else?


Regular forum I think would be:

Itch :




First two are pretty specific to EDCE. 

If someone has another place where it is being discussed, let me know.


(5 edits)

 Gday,  Playing with Expanding AI on turn 279, it hasn't expanded at all, alas. As you can it has spammed IN. It did have a lot of FI too, but that was all. A city it owned said it was building TR but never launched any. [I know you have said the AI needs help, I'm just giving feedback :)]

Also, the Activate last doesn't always activate the last unit. ( it does say in the RHS help box "The last child activated manually") it is inconsistent and doesn't always activate the last unit moved.


Finished the game. The above shots is his view for the game and stats.( In the units produced table he only produced IN, FI, DE & TR)

Also this window  "Unit Processing Stopped" (below) keeps appearing, is there an option to stop it appearing? I know unit processing is stopped :). 

Also, where do I find the battle odds calculator? It would be handy to have come up before you attack.

Sorry found something else: Inland cities with ship specialties seems a waste/unrealistic.

Developer (2 edits)

A huge challenge for the AI is geographical, if this was a fixed map every time, the game might be boring, but the AI would definitely not have issues like this. It looks like here it has encountered a road block which it is desperately trying to push through. You easily are able to bottle neck him and then it just becomes a cleanup op. This is a definite problem reoccurring issue for all the AIs. Thanks for the screen.  I have always contemplated and AI that has map strategies, like one dedicated specifically to a real world map. 

The Info Area (lower right) shows the basic battle odds for the active unit vs the unit the mouse cursor is over. It does not take into account readiness I believe. (because enemy readiness is not your intel).

Inland Cities with ship specialties _are_ a waste in most respects - as is a city at 10% efficiency. In other words, it is a handicap for that city and something to be dealt with strategically. Do remember that Engineers can build ports, and these can be useful sometimes in specific situations, but often yeah, it is a handicap.

Regarding activate last, what you have to remember is since the last unit you manually worked with several units could have been automatically processed when activated, which is why you see those before you get to the unit of choice. 

The Process Break Dialog will appear after you press the red flag stop sign while it is processing units. The flag is supposed to be  reset after it breaks, (the dialog), but I have had one other report that it might be going off at odd times as well. If you press it while the AI is doing its thing, the dialog will come up when it is done. 

Are you using the stop sign? If so, how?

Thanks for the comprehensive response :).

I use the "Stop sign" often for changing units orders near to the currently activated unit (e.g  A TR 's IN captures a city,  I may "stop/pause" and activate a nearby BO to land in the new city).



Ok, thanks. I will look into that. It should not be popping up if it is your turn, but something may be getting triggered.


Reviewing this, the stop sign is really intended for stopping processing going on, though it does also have the benefit of deselecting the unit. 

Might I recommend you use the "Deactivate" control, which is at the bottom if you mouse or default bind is the escape key. 

(1 edit)

Okay. i'll try that

Just jumped into game and that method is perfect, thanks


Oh, I missed this comment between the screens:

Finished the game. The above shots is his view for the game and stats.( In the units produced table he only produced IN, FI, DE & TR)

That is correct for the Expanding AI. He works with a very limited set of units to do his tasks. This was purposely done to create an AI that is effective at times but simple enough code wise so that people could expand on it if they chose to.  The other two AI's use more units in the arsenal, but does that make them any more effective? It is up for debate.  

Deleted post

Have a nice day.


I still am having problem with the very first army that won't auto activate.  Not a huge  deal.

There are some differences with EDEE.  Right click your cities tp see what is  going on.

I really love the zoom in and out.  A lot of good work went into this. 


I am confused as to how this could be happening. What are the steps you are taking to get to that point?

Got around to trying to actually play the game. 

There are a plethora of mildly irritating technical bugs with the interface.

There are some other bugs that make some of the features useless.  If you have a variety of units in a city with an air transport and perform any of the load functions, the priority of which units get loaded is arcane. I put one of every unit in a city. Load put the Long Range Nuke onboard the Air Transport first.  In EDEE, in the unit db, you could select the default unit to load for the specific transport unit. That is missing from the implementation of EDCE. A default would be workable but better would be able to prioritize the list of units to be transported.  

If you make a copy of any existing Unit DB, you cannot place any Air or Orbital unit (as applicable to the database) if using the copied database. The Terrain Placement Icons are grayed out and can't be changed. 

 Using the Enhanced DB that came with the game, whenever I bring up a unit that can be loaded (Truck, Helicopter, Transport, ...) in the unit dialog, the Load/Unload buttons are grayed out. The only way to load them is to activate the unit and then use either the keyboard binding  (if configured) or the buttons at the bottom of the screen. 

When I open the city dialog and the view the list of units, clicking on a nit should activate it. You have to go to the view units button at the bottom and then you can activate a unit in the list and then you can open the unit dialog by clicking on the active unit. Kind of cumbersome but it is inconsistent.

The save config dialog does not save the database. If you change the database, close the game, reopen the game and load the saved config, it does not restore the database for that config. It is unclear to me whether the database is being saved even when not desired or if the database if the database is not being saved separately.


There is no load filter or non-default loading in EDCE.  if there is loading that you do not want to occur, you should use the tree view. 

Air Units and Orbital Units cannot be placed outside of transports (cities, etc) in a buy points game. Can Be Placed is also used for other actions. The Unit Mod capability  is simply an exposure of the available data. Many entries may have hidden or non-intuitive results.

The load and unload buttons have been disabled but will most like be enabled in a future build.

When in the tree view, clicking  a unit does not activate it, because multiple units can be selected at a time. If you wish to activate a unit in the tree view, select the single unit, then click on the activate button.

If you are referring to the save config from the game setup, it only saves a Database key. The game will assume you are aware of the changes you made in a DB. The same is applied to the saving of a single player game. You can exit a game, change the Unit set, then reload the game. This could have ill effects on the save game in question after a reload, but it is up to you to police this.

I was attempting to place a fighter in a city! I it was implicit in my description that I was trying to perform a placement in a transport container. I could not.


To place in a transport, drop it on top of the transporting unit.

(1 edit)

By the way, it is spelled Seabee (not Sea Bee)  No space, no capital B <- straight from the U.S. Navy


Sea Bee is displayed as intended.

(1 edit)

Ok, when I copied the Advanced DB without any changes, no air units may be placed

When I copied the Enhanced DB without any changes, no air or orbital units may be placed

When I tried my database with a new unit, no air units are placeable. I tried playing it and discovered that my new unit could not be produced in a city. I went back into the DB editor and added my new unit as transportable by the city. I started a new game and all the air and orbital units may now be placed ??? If I go back into the DB Editor, the terrain placement blocks are still grayed out and inaccessible. If I save the DB and start a new game, no air or orbital units may be placed.


This is correct. Air Unit and Orbital Units cannot be placed in the open Buy Points mode. This is a rule enforced by the game engine, regardless of data settings. 

When editing a unit set, it is important to realize that  some data attributes may have multiple and hidden/non-intuitive purposes, and setting something may not work as one intended. 

The focus of the game design was not centered on modification, as EDEE was. So the road to modification will be rougher.

Apparently, damn nearly impossible given the extremely rudimentary  limitations of the Unity Engine.

When play begins, the Placement and Remove Placement button should go away. 


All of the button remain on the screen in the panel, regardless of the phase/state of the game. If you do not want to see them,  you can rearrange the container so they are not displayed.

(1 edit)

I was playing with efficiency and city name stuff and the game is now frozen solid.

No I wasn't in Production Mode. 


If you can create repeatable steps for this, that would be most useful.

It seems to freeze up on REPORTS after looking at the other displays.


Which other displays? What are the steps taken?

The City Name toggle ... persists between instantiations of the App. Exiting from the gain does not reset toggles even if a new game is started.


This is by design - as it was a popular request in testing. The toggles states are persisted through the account.

I did a little poking around in your GE name file. The diacritical E and umlouted o are not valid in UTF-8. That is the reason that the file won't load in an xml editor or in a UTF-8 only editor. It is also inconsistent with your stated standards for the file in your HELP - all the files need to be UTF-8.   I changed the characters to an e and an o and removed the one single quote and that worked. 

I rather suspect failure to escape the single quote may be what is  hosing up the Unit DB. I suspect when you make the copy of the Unit DB, you are not processing the single quote properly. This could cause all kinds of issues. 

The same issue with single quotes is present in some of your other files like the Localization XML. I went ahead and escaped all the single quotes per the standard and you are probably using a standard XML parser because all the single quotes appear like they should in the help and tool tip texts. I not sure why that was not giving you a problem with the game - maybe it is! In any case it appears that the escape sequences are being processed as they should be.

Developer (1 edit)

Thanks for finding this. It does look like it is in Ascii Standard and not Unicode. However, the changes you sent me are not correct in that the characters are not the same (now they are basic English). I will make the appropriate changes, but this file is not one that is updated in a game update - so the changed file will only be reflected if manual step are taken after the update or a new Data structure is created.

I have also amended the spelling mistakes you found, thank you for those.  The misspelled Friendly Defeat is in that localization file. 

Regarding the non-escaped single quote, I know you do not agree with it, but this is not standard XML nor will it be. And it would be a mistake to assume I use a standard xml parser because I do not.

I created a map 200x38 with wrap only horixontally. This means that the whole map fits vertically on my screen with room leftover top and bottom from the icecap. IMHO, I should not be able to move the borders of the map beyond the top and bottom but I can. If I press center on a unit, it should center it horizontally and ignore vertical. Essentially the way EDEE works. The way it is it is really wonky!


There are several not-perfect cases from a display perspective that very small maps will create.  This is one of them.

(2 edits)

I created the 200x38 map and populated a city with about 50 units I placed there. 

In the list of units, if you move a unit it swaps the unit. It should remove it from the list, and insert it in the list rather than swapping. This means anytime I drag and drop, my well ordered list gets all messed up. Moving a unit from near the bottom of the list to near the top of the list next to the units that I wanted to load onto it was tedious and time consuming in the extreme! Again, what it should do is when I reach the top of the list, the list should start scrolling until I get to where I want to drop it. I had to do 6 drag and drops to get it where it needed to be. 

Now if the load feature wouldn't always pick up my defensive units first (AA, Artillery) that might, repeat might be helpful. If I could, like EDEE select a "DEFAULT UNIT TO LOAD" or have a priority list for each unit that can host others that would be fantastic. (one priority list for each host unit). Drag and drop is extremely picky as far as positioning the item and there is no feed back like drag and drop in Windows that highlights the entry you are dropping onto before you release it. So a lot of my drag and drops just failed. What would be beneficial is if there was a Move Up or Move Down button (just one for the entire list) and pressing and keeping it pressed down would move my unit up or down in the list until I released the button. Better if I could select a group of units and move all of them as a group (like all of my infantry to my helicopters). What I would really like is a persistent Tree window like EDEE that allows interaction with the map. I could very rapidly organize (load/unload) and move out units. In most cases, for a city, I like to deal with all the  units in that city at one time.

You commented that a lot of people really liked the game. If you play a very simplistic game with very few units, yes, it is ok. Once you start accumulating units in one place, it becomes very tedious and onerous to deal with the unit lists. How to make this really  workable  - when I select a unit in the  list and I highlight  the load button, an additional list of all the units present in the City/Port/Airbase for my selected unit that I wish to fill  pops up and I get to select the units to add (multiples). That would really ease the tedium over the very the onerous multi Drag and Drop in these situations.   

Maybe a lot of the people who like this game just don't mind numbing, time wasting and extremely keyboard/mouse intensive tedium of doing what should be simple things with what I have found to be an extremely rudimentary interface. I am sincerely trying to be constructive. 

This game has absolutely tremendous potential for the concept but the interface needs a lot of turbocharging! It is sort of like an NFL game where every play gets flagged and every play has to be reviewed - it just ruins the flow of the game. By the time I get something done, I forget why I was doing it in the first place.. 

Developer (1 edit)

Unfortunately, there is not a Default/Non-Default loading option as there was in EDEE. This is by design as it confused more people than it helped. The tree view is a simpler method which people understand when they want to do special loading  situations. 

The tree view itself is set up for swapping and loading/unloading, not for ordering. So if you desire to order a list of 50 units in a particular way, you will have more work to do. The tree view can be impacted by a machine that has difficulty rendering the scene.

Regarding various comments involving the mouse and the interface, first, all command and info buttons can be mapped to a key. The map itself can also be scrolled via keys. All of those commands and a few more can be set through key binding.

The dialogs and interface controls do have only rudimentary key controls, and they are not fully compliant with standard windows controls. Unity only provides very basic controls, which must be built upon. This involves a great deal of time, which is a short commodity for this project. So some of the basics are in it for now. Time will tell if more can be added.

EDEE, being a Windows OS dedicated program, was able to take advantage of the built in Windows API. Unfortunately, Unity does not do this, it has a homegrown kit which is very basic.  This is one of the few disadvantages of using Unity. So a lot of the expectations of windows standards compliance are not going to be there, at least for now.  Do not construe this as a defense for the things you don't like, it is just the reality.

I had not wanted to Sort the list or keep it sorted but it is a rather arcane way to drag and drop from my experiences in Windows and Linux - I have both.

It still remains that the unit list for the city is very difficult to use if you have an accumulation of units.

By not being able to specify a load sequence the LOAD ALWAYS picks up AA, Artillery FIRST. It would be more appropriate to have the load function load infantry, armor, engineers, Seabees first rather than AA, Artillery that I usually want to leave in a city for defense. From my perspective, if this is always going to be the way LOAD works, that button and keystroke are useless in my play. Perhaps some compromise could be reached?


Right now the compromise is the tree view. I always like the non-default concept, and I will look into what can be done with this on the request list.

The game continually freezes up and my only recourse is to close the application. SAVE/EXIT does not work and neither does BAIL.

For buy/place games, why not permit Mines to be placed? If made expensive enough, that could provide interesting entertainment.


Mines are allowed in the game for placement, as are roads. But the appropriate rules options rules must be set for those to be active.


Regarding the freezes, is this with a modified unit set, or the standard?

Is the AI code for EDCE posted on the Killerbee web site? Is it the same as EDEE.


No. The new code is in C#, and it is for all three AI players., one of which is the older Enhanced Player.

It is a shame that you picked such a rudimentary development environment. The look and feel of the game is very similar to the original DOS version of Empire (Before EDIE). I still have a copy of that. Hope you figure out how to fix the general level of sophistication so that it more closely meets current UI Standards (Linux, Windows and Mac). The game concept has taken a giant leap forward but the usability has taken a giant step backwards. 

Oh if you would only fix the sound in EDEE!!!! 

Playing EDCE game on steam.. got words... EXIT FATAL ERROR #PLAYER 5, and something about finding LATEST LOG IN AREA WHERE DATA FILES ARE STORED.. where does steam save this on my computer??


Hi Ron,

The "game data directory"  is where is where info is stored, you can find the location for this off the Directories button in the Administration page.

If player #5 is blowing up, it is most likely repeatable. (meaning if you load the game again it explodes in the same way). It would be great if you could make an archive of the game and sent it to me. To make an archive, you go to the Load Game screen off of the main menu, and for the entry in questions you should see an "A" button. That will make an archive which you can find in the "game Data Directory"/archives. Zip that and send it to me and I will see what the issue is. Usually I can get the game back going.

The logs may be useful, you can find those in the "Game Data Directory"/logs directory. If you zip the whole log dir I can sort it out.


When it comes to Computer Technology, I know enough information to never cover a FullStop/Period. For the past three hours I have been pulling what short hair out to find this C:/users/Ron/AppData ............................ Where the hell is AppData... cant see it. (PS I do wear Glasses hehe)

Anyway did a complete search of my 3 hard drives and found a Steam/ file with stuff in it dated today - as today is whan I had Player#5 crash on me.. for some reason the game did reload after I closed the game down and P#3 did a toes up and crashed too. I know how much these files are important to you so did a humongous search and hopefully found what you needed. I could not tell what spacific file needed so zipped all files dated this dat 05/12/2017 (or as you USA folks put it 12/05/2017 - We like day/month/year .. where as USA puts the day After the month ... strange??)

ANY way sending all to you attached to an email Titled "Problems From Australia"


Going to send you mail offline.


Figured out how to lock up the game every time. If I select sort on the right border set of icons and then click on an icon, it seems to work but since I didn't complete the "sort" so it just locks up tighter than a tick.

Similarly  with the bottom set of icons

Imho, all the icons should be disabled while "sort" is enabled and if you single click on them, they should just return a message "finish sorting" or some such.

Developer (1 edit)

You are correct that the buttons do not work when you press sort, as there is a different display of the area where you can drag the buttons around to sort them in the area. 

So is the "Done" Button Not Visible?  Does it not work when you press it?

Exactly what is locked? Are you able to move the map with the mouse? Are you able to select a unit? How are you exiting the game? Do you press Bail?

(1 edit)

Yes, UNITY is limiting in the extreme! I now get that. Perhaps the choice to use the FREE  "Personal Unity Game Engine" may not have been such a wise choice. 

I have developed on multiple platforms and you take the strengths, not the least common denominator, of each platform when you develop and application. Then you port it to another platform and work through the issues of implementing the same or very similar functionality.  These all in one development tools usually are limited to the least common denominator between all OS and that usually means slightly better than single active window DOS functionality. Yeah, I will take a very long break from EDCE. It is nowhere ready for prime time. I want fluid, fast flowing fully featured games and this is not even close to it, yet. Why does it use 37% of all processors just sitting IDLE???? (for instance, just the opening screen but everything is 37% or much more  processor utilization (all processors) no matter what the game is or is not doing) 


There are some optimization steps that have not yet been performed. These  will be addressed in a later build.

I have an archive game with an AI error.  Is there a good place to upload this?

G'day, This just occurred


Maldev,, do you think you know how to make an archive and send it to me?


Hi I replied to your email. I am going to lock this thread, as it is a little long. but if you need to make another.


Send it to



Email the archive to when you can.


I am still having problems with units activating (flashing) once they are produced in a city.

I can manually check each and then manually activate them, but that would be a hassle later

in the game.  I suspect no one else is seeing this.


As far as I know I have not heard of it being an issue.. 

However, If they are a land unit in a single island city, they will not be activated automatically (as they cannot move). 

Send me an email describing how you get that first unit built. 

I just started a game with at least  2 cities.  Pavia, the first city, had its production set to make an army unit on turn 1.  I did 6 more turns.  On turn 7, the the city icon changed color.   No army icon is blinking.  On the turn, 8, I double clicked the city and the army unit is there but I have to activate it.  Move to the 2nd city, the same thing.  Later some of the cities will have armies that self-activate.


How much land is surrounding Pavia. Is it completely surrounded by water?


Also, there is an "Auto Start Turn" option. Have you disabled this or have any other break options set?


That sounds promising!  How do  you turn it on?  I've looked through the buttons and can't find it.


It should be on by default, but you may have  flipped it on accident.

Check your options dialog when in a game. Available in on of the buttons up on the top. (Near Save/Exit) 

Not sure if this is, as they say, a bug or a feature, but if multiple archives are created from the same game on OS X, only the latest one shows in the Load Game dialog, even though all the individual files show in the "archives" folder.


Once an archive is made, it does not show in the load panel as an active moment of the game.  The archive must be restored to be reflected in the load panel. But be aware that what ever state of the game that was represented in the load panel before the archive was restored will be gone. 

So in other words, when you restore the archive, that becomes the active state of the game. There is only one game state "active" at any one time.  Let's say I archive at turn 108, then play on to turn 125. Load panel says turn 125. If I restore the archive I previously made, it will be at turn 108 again. If I did not archive at 125 before this, 125 is not recoverable. anymore. i will only be able to play turn 108 forward.

I think there is  a write up that may better explain this in the manual.

I understand what the implications are when restoring an archive that doesn't represent the current game state, but my question (and I'm pretty sure the manual doesn't cover this) is how to restore anything other than the last archive, since the UI only shows that single file. Suppose I wanted to restore the latest archive minus 1, would deleting the latest archive work; i.e. the one I want to restore would now be the latest, or do I need to do something else.

Developer (1 edit)

I think there is some confusion here as you mention "the latest archive minus 1 ". Archives are not sorted by game, time, turn. They are named by you. It is up to you to choose the archive.

Saved games are displayed when you enter the loading screen from the main menu. Those are sortable by date, turn, etc. A saved game is different from an "archive". Making an archive is an intentional act on your part, not the act of saving. So when you make an archive, you are able to give it a name. Making an archive is discussed on/around page 74 of the manual.

To restore the archive, from the main menu you open to the Load Game screen, and click on the "Restore" button on the bottom. You should then see the list of all archives you have made, select the one you want and that will restore the game to that state. The archives are listed by name - there is not a date or turn information like there is in the Load Dialog, only the archive name you created.  Your selection will overwrite whatever was already there.

Have you tried this and are you seeing something different?

I now understand. My confusion arose because the behaviour of the Load Game dialog was not what I expected. The initial dialog shows ONLY the latest save for a specific game and it never occurred to me that the Restore button would launch another dialog to actually select an archive to be restored. The manual, to me at least, does not make this clear.

Assuming that the framework you're using supports it, may I suggest that you follow the standard Windows and Mac convention of putting three dots/periods after the word Restore on the button to indicate that the Restore button is not an immediate action button but one which displays another dialog. This alone would have eliminated my misunderstanding.

P.S. I've been getting "not delivered" on email I've sent you recently, including for older emails that I know you received (advanced game corruption due to a spotting error) since you replied to the email and fixed the bug.

I click 'wait' button and unit shows up at end of turn; click 'last' button and unit shows up either next or little later; button actions reversed?

Is there a missile/satellite launch button?

open reports window, click on a report, finish with it and close;  but reports window also closes; shouldn't it stay open and I close it with the 'close' button? also, at start of turn I read a few reports and then click 'continue' to start turn, sometimes get 'reports available'; very annoying since I just left reports.

could enemy units that are not seen anymore go 'darker', just to remind one that it is not seen by anyone.

the 'prep unload' button(s) don't seem very useful; or at least, have a 'prep to load' button, believe it would be more useful.

click on a unit and click a 'highlight' button, all same type units would highlight. useful in trying to determine distribution; (and where they currently are located).

  could the mouse be setup that click left button be move command and  right button be select unit?


Hi, thanks for the comments. The interface is different form EDIE/EDEE and does take some getting used to.

For some of the comments:

"Wait" moves your unit to the end of the processing queue. Activate Last will activate the unit previously active. Be aware that this includes units that may have been automatically processed, not just units you manually interacted with. 

There is a Launch command button. It will be in the command button group (bottom buttons). If you do not see it, you may not have this section open all of the way. 

The reports dialog does close upon choosing a report. All reports can be bound to a key, so if there is a report you frequent, I would recommend setting that up.

The extra reports message is a bug that has not yet been addressed.

If you mouse over an enemy spot, the info box in the lower right will list the age of the spot.

"Prep Unload" should be used when you have a transport you wish to move and then unload. If you need a prep load, "Load Till Full" may satisfy that, otherwise use load instant.

There is a right click menu  option which can be used for activating a unit, but there is not a select via right click option. 

installed build 7, immediately, got patrol routes remaining on screen when zooming in and out.

other games grey out areas' of the map that no longer can been seen. still don't understand why EDCE can't do this. would be 'easier' to see area's that are visually covered or find where satellites' are; ect....

would be nice if note tags could be set; to remember what I wanted to do in this location, ect... Or/and an art work layer or 'acetate' layer for making notes and drawing plans.......


If you have a screen shot or even better an archive of the game where this is happening, definitely send it along.

There is not annotation/art layer. However, you can add short notes to a location. Check Map Labels from the Reports Dialog - and then turn on the map labels toggle.

huh? where are games being stored?

Labels? duh,  will give it a try. (still like the acetate layer;)

patrols in black area's are, of course, not real.

(how do you position pictures?)

Developer (1 edit)

I think Itch's file server for images is not working today - but I don't know if you can position them or not. Anyway, will look over it when that gets fixed.

The files for a game are split up. but they can be wrapped by what is called an archive. Information on making n archive is here:


Now I can see the patrol picture. That is very interesting, I suspect that is something just introduced. I definitely would like to see the archive if you can make it.  I will fiddle around on my end. Thanks for catching it and posting it up

(1 edit)


A suggestion-- can we segregate Mac, Linux, and Windows feedback into their own threads?   Might be easier for users to share similar issues and help you isolate bugs related to one OS API but not others?

Still trying to parse the Steam link to the game-- I am successfully driving an earlier DRM download, and it looks fantastic.

Best, as always.

Loren S. Miller


You have to have the Steam Client installed. And I am assuming you have the key.

In the image, note the Games menu at the top of the Steam Client. Select that, Click on Activate, You have to click next a couple of times to pass the warnings and agreements. Then you will need to copy and paste the key where they request Product Code.

Regarding bugs, there has only been one platform specific issue thus far, and that was a Linux display startup issue. But if you have an issue you can create a new thread for it. I have been meaning to lock this thread as it is jumbled.

(1 edit) (-1)

Success! It's not laid out as your snapshot indicates but I found the Activate command. Played for an hour and a half, and posted my first bug report, all inside Steam.  I'm very proud of myself.

Game play very much as I remember it, but I have to bind those keys!! Body memory is making fingers twitch to unassigned keys.
X for Exploration mode, for example.

Pretty darn nice, Mark!  Take the rest of the year off, why don't you?



Ah, forgot about that install.  I have a "" listed, not a "Steam Client."  I figure that's the client on Mac OS X.

Thank you, I'll give that a try.  It'll be nice to graduate kindergarten.

Best, as always.



Locking this thread. If you have an issue feel free to post it in a new thread, or send an email to

Developer locked this topic