Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

How To Play On Linux?

A topic by kreeperskid created Nov 27, 2017 Views: 9,218 Replies: 19
Viewing posts 1 to 7

I see it has the Linux and Windows symbols on the same download page, but I cant figure out a way to play it. I've tried installing, says it's not compatible, which is what I figured. So I extracted it and got an EXE file that is also incompatible. How do I get it to run on Linux?

Developer(+1)

Download the Windows version and run it using the .sh file included in the game directory.

(+1)

Yep I figured it out, I wasn't in the right directory when I ran ./DDLC.sh  in Terminal. Thanks for the reply!

(1 edit) (+2)

Wondering why Linux version is not available on Steam.

(+1)

is it possiible to play on a raspberry pi on the linux operating system "raspian"?

yes

it didnt work on my pc. im running ubuntu 

Just hope monika won't be snooping around the game files. AGAIN

(+1)

For any total linux noobs:

Download the windows version

Extract it

Go to the folder that contains all the games files

Right click, "open in terminal"

Then type in "./DDLC.sh" and press enter.

Ur awesome for being a fellow GNU/linux user btw

(+2)

thanks this was super helpful

Deleted post
(1 edit)

Hey, guys!

I'm a Linux user too and I've been having some trouble installing DDLC.

 I downloaded the game and extracted it. Then, I tried to run it using the EXE file, but it didn't work. So I decided to find some help online, that's why I'm here.

Anyway, I tried also to run it (I just double clicked the DDLC.sh file), but it gave me this:

#!/bin/sh

SCRIPT="$0"

# Resolve the chain of symlinks leading to this script.
while [ -L "$SCRIPT" ] ; do
    LINK=$(readlink "$SCRIPT")

    case "$LINK" in
        /*)
            SCRIPT="$LINK"
            ;;
        *)
            SCRIPT="$(dirname "$SCRIPT")/$LINK"
            ;;
    esac
done

# The directory containing this shell script - an absolute path.
ROOT=$(dirname "$SCRIPT")
ROOT=$(cd "$ROOT"; pwd)

# The name of this shell script without the .sh on the end.
BASEFILE=$(basename "$SCRIPT" .sh)

if [ -z "$RENPY_PLATFORM" ] ; then
    case "$(uname -s)-$(uname -m)" in
        Darwin-*)
            RENPY_PLATFORM="darwin-x86_64"
            ROOT1="$ROOT/../Resources/autorun"
            ROOT2="$ROOT/../../.."
                        ;;
        *-x86_64|amd64)
            RENPY_PLATFORM="linux-x86_64"
            ROOT1="$ROOT"
            ROOT2="$ROOT"
                        ;;
        *-i*86)
            RENPY_PLATFORM="linux-i686"
            ROOT1="$ROOT"
            ROOT2="$ROOT"
            ;;
        *)
            echo "Ren'Py could not detect that platform it's running on. Please set"
            echo "the RENPY_PLATFORM environment variable to one of \"linux-i686\" or"
            echo "\"linux-x86_64\", or \"darwin-x86_64\" and run this command again."
            exit 1
            ;;
    esac
fi

for BASE in "$ROOT" "$ROOT1" "$ROOT2"; do
    LIB="$BASE/lib/$RENPY_PLATFORM"
    if test -d "$LIB"; then
        break
    fi
done

for BASE in "$ROOT" "$ROOT1" "$ROOT2"; do
    if test -e "$BASE/$BASEFILE.py"; then
        break
    fi
done

if ! test -d "$LIB"; then
    echo "Ren'Py platform files not found in any of $ROOT, $ROOT1 or $ROOT2!"
    echo "Please compile the platform files using the instructions in README.md"
    echo "or point them to an existing installation using ./after_checkout.sh <path>."
    exit 1
fi

if test -n "$LD_LIBRARY_PATH"; then
    export LD_LIBRARY_PATH="$LIB:$LD_LIBRARY_PATH"
fi

exec $RENPY_GDB "$LIB/$BASEFILE" $RENPY_PYARGS -EO "$BASE/$BASEFILE.py" "$@"


It seems I'm not using the right program to open it. But, well, I don't know which program I should be using then. I tried literally all the ones I've got. Some of them (like VLC) even gave some images (like Monikas.chr image etc). 

Am I doing it right?

I also tried using the terminal to run the DDLC.sh, but it says "File or directory not found".

 kreeperskid said it wasn't in the right directory. So, I tried moving the DDLC.sh file to the file named "game". Then, I tried running it again, in the Terminal, but nothing happened.

So I tried to follow Ocean_22's steps.

Download the windows version. Check.

Extract it. Check.

Go to the folder that contains all the games files. Check.

Right click, "open in terminal". This option is not available. When I right click it, I can: open,  open with..., cut, move, link, compress, anything but open in terminal. Either way, I opened the Terminal.

Then type in "./DDLC.sh" and press enter.  Check. Typed /DDLC.sh (without the quotation marks). But again it says: "File or directory not found".

I don't know  why it isn't oppening, so pls, if anyone could help me, I would be really glad.

>.<

If your file manager doesn't support opening your folder in a terminal, open a terminal somewhere else and type in

cd "/path/to/DDLC"

and replace  "path/to/DDLC" with your actual file path to DDLC from your file manager address bar. The quotes are necessary if your file have spaces in it.

Then, when you are at the DDLC folder, run

./DDLC.sh

The . (dot) at the beginning is important, as it tells the terminal to run the file named DDLC.sh at current directory.

Yeah, like the other guy said. That command will run the game, but you aren't in the right folder!
As a quick run down:

That .sh file is a script that runs the game. When you opened it and it came up with all that text? That is the script that makes the game launch. You are just looking at the programming that makes that possible.

A lot depends on your distro. On Linux Mint (what I used to use before moving to Ubuntu) you can right click a .sh file and mark "allow executing file as program" and then just double click the .sh file, and it'll run. Some distros don't really do this, because making you run it though terminal keeps users more safe.

Anyways. You are going to have to learn a very small bit of terminal to launch this game. Pretty much, you need to navigate in the terminal to the folder you have all the game files in, then type in "./DDLC.sh" and press enter.

https://linuxjourney.com/lesson/print-working-directory-pwd-command

That should help. All you need is pwd, cd, and ls. (you don't have to type the dollar sign)
Just read #2, #3, and #4)

If in the future you do just wanna play the game by double clicking an icon, open up your terminal and run this:

nano ~/Desktop/DDLC.desktop

and paste in this:

#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Exec=~/DDLC/DDLC.sh
Name=Doki-Doki Literature Club
Category=Games

then, finally...

chmod a+x ~/Desktop/DDLC.desktop
bash: nano: command not found How do i fix

What distro are you running?

bash: nano: command not found How do i fix
> Right click, "open in terminal"

Hi, you have to set the viewing of the files to icons, and then you have to click on the window, not over a file. Then the option "open in terminal" appears.

> bash: nano: command not found

Depends on your distro. Ubuntu/mint:

  sudo apt-get install nano

Redhat/Fedora:

  yum install nano

Running from terminal, you do "ls", the file must be listed, the do:

  bash DDLC.sh

or, if DDLC.sh is in your current directory and it is executable, precede it with ./ (or else Linux will only search for it in directories in PATH):

  ./DDLC.sh

  1. Download the Itch "Appstore" 
  2. search ddlc
  3. click install
  4. click start

You could also use Wine, a compatibility layer for Windows applications for Linux, to run the .exe file.