Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Damsel Quest 3 (nsfw rpg)

Adult Hentai RPG starring a party of 3 girls with sexy bad ends when you lose · By azurezero

Post bugs here (version 1.31 onwards) Sticky

A topic by azurezero created Nov 15, 2017 Views: 2,515 Replies: 58
Viewing posts 1 to 16
Developer

Self explanitary.

(1 edit)

Not sure if a bug, all CG is available when I checked the wardrobe, shouldn't they be unlocked when I see them?

Another one, when I choose the "mix" option in bouken, the potion is repeated twice, with the same ingredients. Will post if I saw more.


EDIT: one more, during mix, I can make weapons (axes) for free, none can equip them, but I can sell them for gold.

Developer

the cg are all unlocked, but the ones specific to the routes and yuki ought be unlocked through gameplay.

That's odd, I never made any recipes for axes. the double potions might be a result of hitting new game, for people using old saves i manually added the recipes. so the same recipe might be on twice

(1 edit)

Here is the save if you want to check it out:

https://mega.nz/#!8JFAED7Y!yQbNjzK3FnDWLgmymJotldLRUldwf_eAAEKj9kJAJfw

Developer

nah i get it, it's fixed in the project now. just need to redeploy. though your save will still have those recipes

(1 edit)

sorry not a bug/glitch. But do you require the rpg maker app to play the game

Developer

you need the vx ace rtp, which is free to download. http://www.rpgmakerweb.com/download/additional/run-time-packages

it keeps the file sizes down not to include it

thanks works great now nice work too

I cannot find the other gold piece in the mines, I have searched every square and back tracked multiple times. Any ideas? I might be a moron here, but I can't find any route of progression in the mines since the gate is closed outside the treasury/vault. (Aside from the main story that is.) No idea where to go either...

Developer

it should be in a blue chest up the middle of the bottom floor. i presume youre talking about the 2nd instance of the mines. because that's when it appears.

I can't find a chest on the bottom floor of the mines. Do you mean the area outside the vault or the middle level covered with shifts in terrain? (I think I might just be a moron right now.)

Developer

oh, it's been moved, it is the floor above  to the right of the map where kiri and emi got rescued in the earlier version of the mine

Then where is the other one?(I honestly think it's not a bug and is instead just me not knowing where to go.)

Developer

you already had that? the other is for sale from the sleeping guy in the black market in the city




and the other is here

it's my own fault for having such an obscure side quest in the game.

That really is obscure...I honestly wouldn't have thought about checking there for something from the mines...


Follow-up question, is there a shop I can use in the game?

Developer

should be plenty around.

I got a couple. First one's simple: handing in the Medic Leaf quest doesn't actually remove them from your inventory.

The second one has to do with the Enforcer. It's pretty weird so bear with me: after catching Katsu, the Enforcer caught me. At that point, Ren and Emi were naked (2x Armor Break). After the scene, I slept at the inn, but Emi wasn't in the party, so her clothes weren't repaired. Afterwards, I found Kiri at the mixing shop. The Enforcer was still chasing me, even though both my characters were clothed. If you get caught by him at this point, he says his line, the screen fades out and back in, nothing happens, and the game just continues. If you don't move, this will repeat infinitely. This actually made it impossible to leave the Red Light district without using the fast travel point there, as he would just trap me between the guards immediately.

I couldn't find Emi anywhere, so I just went to sleep again a couple of times. Eventually she showed up downstairs. Talking to her also added Kiri to the party for some reason, even though she wasn't there.

Developer

this is gonna take some fixing... :3

will get on it now

Developer


that's odd... the enforcer shouldnt even be aggro if emi's not in the party (you pick her up by the well anyway, so you can grab her before running into the enforcer)

id post proof but itch wont let me.

I've never seen Emi near the well (or did she go down it? I don't think I checked there). Sometimes she's downstairs at the inn, sometimes she's at the Adventurer's Guild, sometimes only Kiri is downstairs but talking to her adds Emi to the party anyway, sometimes I can't find her at all so I just go to sleep again.

Is Emi supposed to have a cutscene when you're caught by the Enforcer? In my case, both Ren and Emi were naked, but only Ren got a scene. Maybe it has something to do with that?

I've encountered some in-battle oddities, both of which happened only occasionally. I've seen the Princess of Fire skill activating at the start of battle, despite no healing taking place. Once for player Ren and once when you fight her.

Secondly, when fighting Filia, the Defense Orb's effect sometimes doesn't seem to work. The orb did its thing at the start of the turn, but Filia would still take damage from physical attacks. Maybe the Stonewall effect isn't guaranteed to be applied? I haven't seen this happen with the Reflect Orb.

Thirdly, you know how the game shows damage values and status effects during battle? Somehow it stopped doing that. I think it stopped when fighting the slimegirl. Closing and re-opening the game doesn't help. If I load an earlier save, though, they show up again.

And finally, a question. There's these two blue chests in the ruins where you need the stone tablet. Are they supposed to contain 0 G?

Please don't get me wrong here, though, I'm definitely enjoying the game. These are fairly minor things.

Developer

they get taken to specific places when arrested, kiri gets spanked on the plaza, emi is chained up to the right of the inn before the next screen
but if you just rest at the inn they get freed sometimes. other times theyre not downstairs you got the rng for them showing up elsewhere.
the first day emi isnt downstairs she's in the strip club watching the blonde repair girl. the day after she's dancing herself.

the princess of fire skill activates because her hp has increased since the last battle.

the slimegirl fight used to have an issue where it disabled the whole portrait battle system by accidentally enabling the side view battle system. no idea if that's relevant to the new issue.

as for the chests... i never thought of anything to put in them.


Developer

oh though i did fix the quest.

I'm not sure if this is a bug with the game or my RPG Maker install. But during any battle, all of the enemies die no matter what action I take on the first turn. 

Developer

that should only happen if you press the A key... its a cheat.

(1 edit)

I've got some USB pedals + wheel I use for racing games. I've had trouble in the past with them being seen as controllers and having a constant button pressed down. I'll try removing them and seeing what happens. Thanks. 

Edit: That was exactly it. 

  • In the slaver's pit (the old mine), I paid 15000 gold when asked (I didn't partake in their "sexual services") and, after Ren took a couple steps, the game stopped.
    • Note: It didn't freeze. The animation of the girl in the stocks being fucked just played forever, and none of my input did anything.
  • I'm not sure if this is a bug, but in the second city (with the adventurer's guild) I can go to the mixer and mix an infinite amount of axes and quickly amass an infinite amount of gold from this. 
    • Note, I really appreciate being able to do this, as I'd normally just Cheat Engine my way to doing it.
Developer

it really should skip the fight but it might be a bug where rpgmaker runs slightly differently for different people.
can you tell me what is said before the freeze?


and theres a few ways to get infinite money.

Developer

i cant even find anything that says ren should take a few steps but i did find a missing switch so the scene would loop.

so i guess her walking is just... the scene restarting... and her not having anywhere to go to finish the move so it freezes.

easy fix...

will upload new version.

(1 edit)

Emi's sprite is missing next to Kiri at the inn after Ren wakes up once Aya joins the inn.

I mean, when I arrived in the city, I explored the inn and got a room for my party and every time that I slept, Kiri and Emi were waiting for Ren downstairs at the inn desk.

But since Aya joined the inn, for some reasons, Emi's sprite is missing at her usual place next to Kiri at the inn desk even though she joins the party at the same time as Kiri.

Developer

she shouldnt be joining the party if her sprite isn't there and the eventing agrees with that. ah, the number is off by one. 0-1=at the desk but that event has no sprite.

So are you going to fix it?

Could you remind me of where I am supposed to deliver the 16 medic leaves for the rank E quest please? I forgot and I can't remember because I can no more read the quest on the adventurer guild board and the quest scroll in my inventory doesn't mention anything about the location nor the person who posted it. How could you miss such an important information when you wrote the description of the quest scroll?

Developer

you hand them in at the guild unless otherwise prompted

Right, after running everywhere and talking to everyone in order to find the person who requested these leaves, I ended up handing the quest at the adventurer guild clerk and it appeared it was the guild themselves who requested this quest.

I still think you should mention it in the quest scroll description though, "deliver 16 medic leaves to the adventurer guild" is a simple line which could spare some troubles.

There's a glitch when it comes to the second mine quest. If one of your  troops go down (in this case: Emi) and you complete the quest you can't get them back, you can't re-enter the mines after you've been warped out, and you can't exit any dungeon you enter. so essentially, if this isn't fixed ill have to make a new game. And I've already unwittingly saved, so no going back for me.

Developer

gimme 10 minutes to fix it

Developer

i do need your save though

Developer

bugs fixed, re-exporting, winning the fight now removes all the captured/slaver captured states so it wont happen again.
re-upping asap.
i'll cheat my way back into the mine, save emi, and put you back where the save was

sorry for the wait on the reply, but I don't know how to give you my save, could you tell me how?

Developer

upload somewhere and give me the link?

just for clarification (first time doing this), I take the files and upload them, then give you the link. You do the cheat and get Emi out, and you send it back or something like that?

Developer

yup, just the save that needs fixing though.

Got it, give me a sec, also thanks for doing this

https://drive.google.com/drive/u/0/folders/1ZbiJQxxgcmN-5AwNZbcxiKK7AXQWndgf

i decided to do the whole thing just in case

Developer

you need to grant access

Developer

also which numbered save is it? so i dont have to check them all

Done, and it's on save 1

Developer

i just dropped the fixed version in

quick question, there are 2 saves, do I remove one?

i tried it out, but it didn't work. is there something I'm supposed to do in-game or out?

Developer

you just need to overwrite it or rename it in the same style  like save02.rvdata or whatever it was

It worked, thanks for every thing, and a hope you have a good day/night. :D

Developer

i still have to stay awake til noon/til my parcel arrives... but i should be able to get a good sleep after that

I cant enter the stripclub, it crashes and says "unable to find file Graphics/Characters/$Slave aya"

Developer

i'm so relieved that this wasnt another ad post
https://mega.nz/#!6oAFmSqb!-PxwQEyOVFehUJqIaZjCSrN8C7e-OjuMo7XrmSMGBhQ

when i checked the version i had upped to mega the file was properly in place
if your version is encrypted, then you need this https://mega.nz/#!3spgkBwQ!NwfZ2chpa767kjrYDQ5bu50vJwULYfxISE84PJ_6l00
to put the graphics above in (be sure to put the game.rvdata elsewhere so it can read from the folders and place the stuff in the extract bit in the main folder with the exe)

hows this thing work?

Nvm i figured it out

Developer

it work now?

yea, got confused to where to put files but figured ou